Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Insecure connection issues

  • 2 replies
  • 62 have this problem
  • 6678 views
  • Last reply by balfim

more options

Recently getting:

The owner of www.facebook.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Message on both facebook & Google. No recent software changes. If I open the browser immediately after booting i can browse both sites no problem then all of a sudden get the message.

Using Bulldog antivrus etc and issue persist when firewall etc are disabled.

Its driving me nuts and I really dont want to change Browser!.

Chosen solution

hi, please try this:

  1. Open the dashboard of your Bullguard application.
  2. Click on Antivirus settings > Browsing.
  3. Uncheck the Show safe results option for those websites which are showing an error message.
Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

hi, please try this:

  1. Open the dashboard of your Bullguard application.
  2. Click on Antivirus settings > Browsing.
  3. Uncheck the Show safe results option for those websites which are showing an error message.
more options

Great - HUGE THANKS!