X
Tap here to go to the mobile version of the site.

Support Forum

Why can't I get Kaspersky to update because Firefox is blocking it

Posted

Kaspersky cannot function because Firefox is making it impossible. I can't get a "certificate" from Kaspersky to satisfy Firefox. Kaspersky will not accept my appeals because I no longer use the email address I used when I started with Kaspersky 7 years ago. I see MANY OTHERS HAVE HAD THIS PROBLEM, BUT YOU DO NOT REVEAL THE SOLUTION. FIX THIS. mY COMPUTER IS IN REPAIR BECAUSE OF THIS CONFUSION.

i AM CONTACTING YOU FROM A PUBLIC LIBRARY

Kaspersky cannot function because Firefox is making it impossible. I can't get a "certificate" from Kaspersky to satisfy Firefox. Kaspersky will not accept my appeals because I no longer use the email address I used when I started with Kaspersky 7 years ago. I see MANY OTHERS HAVE HAD THIS PROBLEM, BUT YOU DO NOT REVEAL THE SOLUTION. FIX THIS. mY COMPUTER IS IN REPAIR BECAUSE OF THIS CONFUSION. i AM CONTACTING YOU FROM A PUBLIC LIBRARY

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Google Update
  • Google Updater pluginhttp://pack.google.com/
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • 5.1.41105.0
  • VLC media player Web Plugin
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 43.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.3/WINNT/en-US/

Extensions

  • Google Toolbar for Firefox 7.1.20100701W ({3112ca9c-de6d-4884-a869-9855de68056c}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 1-29-2014
  • driverDate2:
  • driverVersion: 9.17.10.3347
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4272 solutions 59919 answers

Do you have a profile with Kaspersky. Edit it.

I've called the big guys to help you. Good luck.


This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox

https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”

Do you have a profile with Kaspersky. Edit it. I've called the big guys to help you. Good luck. -------- This will disable add-on signature enforcement; Enter '''about:config''' into your Firefox address bar Click the ''I'll be careful'' button Find '''xpinstall.signatures.required''' in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”
cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159076 answers

Helpful Reply

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.


If the certificate is issued by your Kaspersky security software then you have two options:

If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer. ---- If the certificate is issued by your Kaspersky security software then you have two options: *disable scanning secure connections in Kaspersky *install the Kaspersky root certificate.When prompted set the trust bit to use the certificate to "Trust this CA to identify websites"<br>http://support.kaspersky.com/us/9093#block1<br>http://support.kaspersky.com/us/9927#block1