Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since installing el capitan, my firefox will not respond to any key strokes of track pad actions until I move away to another window and then come back

  • 5 replies
  • 5 have this problem
  • 334 views
  • Last reply by FredMcD

more options

If I click on a blank field no cursor appears. If I click on another window eg. a safari window and then come back to firefox, the cursor is now in the field I clicked on. Then I type in e.g. a dollar amount, but no numbers appear then I go to safari and comeback to firefox and the numbers are there. Then I try to scroll down using my trackpad and nothing moves then go to safari and come back and the screen has scrolled. The same happens if I go to another window e.g. open office and then return. This began after installing el capitan. At first I may have had a lack of RAM, but I have taken care of this. Ideas? Is there any way to reinstall Firefox completely, preferably without losing my bookmarks to see if this helps? I'm on version 43.0.2.

Chosen solution

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

more options

Note that the System Detail list shows two Silverlight plugins:

  • Version 5.41.0.0
  • Version 5.41.3.0
more options

Fred, that worked but only if I open it that way each time. Is there something I czn do to not have to open it in safe mode?

Cor-el, Were you answering my question/problem? What should I do with these plugins? I've never been good at getting Silverlight to install so have tended to watch videos in Safari.

Thanks to both of you, but we're not there yet! Charles

more options

I was merely noticing that you have two Silverlight plugins showing in the System Detail list. You can find the installation path of all plugins on the about:plugins page.


You can try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

If it works in Safe Mode and in normal mode with all extensions (Firefox menu button/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via *"3-bar" menu button > Exit (Power button)

  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit
  • Windows: File > Exit
more options

If the above does not help,

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.