Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I accepted the auto-update for Firefox. I updated Firefox and said start later. Now it is later and now will not start.

  • 3 replies
  • 7 have this problem
  • 42 views
  • Last reply by FredMcD

more options

I click the task bar icon for Firefox after auto-update, Nothing happens. I do not have the Nvidia manager mentioned in Hot Topics.

Chosen solution

I rebooted my computer. I clicked on the Firefox taskbar icon and was prompted to update to v43.0.4. Evidently the previous update stalled somehow even though I was also prompted to restart. For the first update I had clicked the Restart Later icon.

The second update completed and when prompted, I restarted Firefox immediately. It is working OK now.

Read this answer in context 👍 0

All Replies (3)

more options

Do you have the Firefox icon on your quick launch? Close Firefox. Right click on the icon and select Open New Tab. Sometimes this works. If it opens, close it by Menu > File > Exit.


This is not a cure but will make it easier if Firefox locks up in Windows. https://support.mozilla.org/questions/997866 {web link}

more options

Chosen Solution

I rebooted my computer. I clicked on the Firefox taskbar icon and was prompted to update to v43.0.4. Evidently the previous update stalled somehow even though I was also prompted to restart. For the first update I had clicked the Restart Later icon.

The second update completed and when prompted, I restarted Firefox immediately. It is working OK now.

Modified by RicWatkins

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.