Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't delete corrupted profile.

  • 5 replies
  • 1 has this problem
  • Last reply by Spamlet

more options


I use FEBE and Profile Manager, because I have tailored FF to my small screen, and personal needs, with many add-ons.

I recently made a new profile for FF42, and used FEBE to overwrite it with my customary profile settings.

All went well until I came on here to ask a question about my Thunderbird: Halfway through asking the question FF froze, and I had to kill it in Process Explorer. When I opened it again, the first tab just said 'connecting', and the whole thing froze as soon as that came up. Clearing all my caches with CCleaner made no difference. There was no malware detected by Malwarebytes.

I opened a previous version of FF (Thank g-d for FEBE!), and tried to overwrite the stuck profile with my current settings again, but it just froze, and had to be terminated from Process Explorer.

I tried to delete the corrupt profile in Profile Manager, but that just froze as well. :/

Luckily, it didn't break Profile Manager altogether, and, after reloading it, I could make a new profile for 42, and give it my preferred FEBE profile, and am using it now. As I don't know what corrupted the first 42, I'm a bit wary that this one might break too.

The corrupt 42 is still in the list in Profile Manager, but freezes everything when I try to delete it. How can I clean it out?

Thanks for any ideas as to what went wrong, and any tips on clearing the corrupt profile without damaging my good ones. Have I been locked out of that profile by something changing my permissions? I would have thought that MWB would have detected any obvious mischief.


Chosen solution

The second screenshot shows a looking up message and this means that the DNS query is still in progress. You can try different DNS servers and also make sure that security software and possible malware isn't causing this issue.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

Read this answer in context 👍 1

All Replies (5)

more options

Try to start Firefox in Safe Mode by holding down the Shift (Mac: Options) key to see if that helps.

Try to start Firefox with the about:blank page by creating a copy of the current Firefox desktop shortcut. Add a space and -url "about:blank" to the target field in the Properties.

more options

Thanks for the tip about adding 'about:blank' to the url of the start link, Cor-el. I'll have to remember that for next time!

I do use 'about:blank' as my start page, anyway, but, presumably, in this case, it was still trying to continue whatever action it was on when it froze, each time I turned it on.

As it turns out, I could delete the bad profile when I turned on today, so, I guess there must have been an action still trying to continue in the background, even after supposedly shutting the programme in Process Explorer, and this stopped me deleting until after a complete pc restart. ___________________________________- ? :( I thought that had solved it, but I then went to reply to my other current question, and it seized up again after I had written a couple of lines, so it looks like it is something to do with losing contact with Mozilla Support in the middle of writing.  :(

The profile isn't corrupted, but the pc itself has to be restarted to break the failing attempt to connect to Mozilla Support.  :(

Rather a pain.

I'll add a couple of snips: Every time I go to reply to Zenos, I write a couple of lines, and then it freezes, and I have to restart pc to clear. Yet--so far--I can reply to you!


Modified by Spamlet

more options

Chosen Solution

The second screenshot shows a looking up message and this means that the DNS query is still in progress. You can try different DNS servers and also make sure that security software and possible malware isn't causing this issue.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

more options

Thanks Cor-el!

I'd already scanned with Malwarebytes, but I'm in the middle of deeper scanning now. Starting with Roguekiller.

I've also changed the pc to openDNS (router is Technicolor and part of phone/internet package). Signing in here was quicker, after, which may be a good sign.

I'll go on to Eset scanning when I've updated you here.

Unfortunately, I now have a bigger email problem than the query I had over Thunderbird folders. I'll tell you here, in case it's connected, and I may still not be able to get to my other thread. I had virgin mail, originally (ntlworld as was). This was passed to googlemail, but was recently passed back to virgin. This led to my Tbird redownloading several thousand messages.

I leave copies on server, in case I need to open profiles on new pcs, but when the isp moves like this, I end up with these thousands of duplicates. This time, I downloaded the remove duplicates add on, and it appeared to work very well, but, this evening, there was a notice to compact folders. I used to be very wary of this on Outlook Express, but it has always worked ok on Tb, so I let it continue. Then I noticed I had two of everything again.  :( So I reran the remove duplicates. And now I find that the folders I ran it on, have the headers attached to the wrong messages, and many of the messages have no body at all.  :(

I don't know if this was a fluke combination of removing duplicates and compacting at the same time, or if, there might have been an eml with a virus in, among the thousands of redownloads, that somehow got activated and is now munching its way through my mozmsgs files! If it's the latter, I'm screwed, as all my correspondence records (many very important) were stored in Tb, and, due to illness, I've not been able to back them up lately!  :(

Hopefully, after scanning, i'll try to set up another Tb profile, and download all the messages yet again. A right pain, when I'd have to open all the messages still on the pc, one at a time, to see if each is corrupted or not! A nightmare I did not need, as my illness, severely restricts how much time I can spend at the keyboard.

I do try quite hard to keep the pc bug free, but, I can't believe how others seem to get away with ignoring all cautions, while I seem to get one catastrophe after another!

Anyhow: It's very good to have Mozilla Support and your good self to help. (Touch wood: it seems to have let me type all this without freezing...)

more options

Just about sussed now:

The openDNS seems to have improved the initial problem; and the sudden email hassles were roughly this:

Virgin had stopped showing a pop settings page, so I couldn't match Tb pop with virgin any more, and had to switch to IMAP.

They had put my gmail folder tree in a sub folder of 'my folders', so Tb had stopped seeing mail after Sept 29. My phones had continued adding to the sent folder though.

In various places, I now had sent items/inbox, and trash, under three different folder names, each, in three different file trees. On top of this, my phones had each created their own folders, and each was mapped to different ones, so I had to work out what was being sent where, and remap everything to the same boxes.

Very fiddly indeed, but I think I've managed to save most of the mail, and am still dealing with the backlog before rationalising all the boxes that aren't being used any more.

Apologies for not updating before now, but I've had a lot of trouble with Blur, as well, and couldn't get my log in details until now.