Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

If I have a Firefox page minimized I cannot open a NEW page. It will only let me open a new tab on the minimized page

  • 2 replies
  • 2 have this problem
  • 6 views
  • Last reply by DebGamble

more options

If I have a Firefox page minimized I cannot open a NEW page. It will only let me open a new tab on the minimized page. I used to be able to open a new browser page from the icon on my desktop, but for the last few days it won't let me. This is a desktop computer, running Windows 7. Everything is up to date.

If I have a Firefox page minimized I cannot open a NEW page. It will only let me open a new tab on the minimized page. I used to be able to open a new browser page from the icon on my desktop, but for the last few days it won't let me. This is a desktop computer, running Windows 7. Everything is up to date.

Chosen solution

Hi Deb, this is hard for me to test personally because I pinned the Firefox shortcut to the taskbar, which changes its behavior, and when I unpin it, I don't get my desktop icon back. (?!)

Anyway, as a temporary workaround while we sort this out, you could use the "jump list": right-click the Firefox icon on the taskbar and choose "Open new window" which should definitely generate a separate window, and not just a new tab in the existing window. Does that work normally?

Firefox has a hidden setting that you might try changing to see whether it makes any difference. Normally, when you open a link in another program, it opens in a new tab in the last Firefox window you used. Does yours do that? I'm going to suggest changing the setting so that the link must open in a new window to see whether that has any effect on this problem.

(1) In a new tab, type or paste about:config and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.o and pause while the list is filtered.

(3) Double-click the browser.link.open_newwindow.override.external preference and change its value to 2 and click OK.

The possible values for this preference are as follows:

-1 = follow your setting in Options for new tabs vs. new windows (default) 3 = open external links in a new tab in the last active window 2 = open external links in a new window 1 = open external links in the last active tab replacing the current page

There are some other similarly named preferences, so make sure to change the one that has "external" in the name.

Any difference?

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi Deb, this is hard for me to test personally because I pinned the Firefox shortcut to the taskbar, which changes its behavior, and when I unpin it, I don't get my desktop icon back. (?!)

Anyway, as a temporary workaround while we sort this out, you could use the "jump list": right-click the Firefox icon on the taskbar and choose "Open new window" which should definitely generate a separate window, and not just a new tab in the existing window. Does that work normally?

Firefox has a hidden setting that you might try changing to see whether it makes any difference. Normally, when you open a link in another program, it opens in a new tab in the last Firefox window you used. Does yours do that? I'm going to suggest changing the setting so that the link must open in a new window to see whether that has any effect on this problem.

(1) In a new tab, type or paste about:config and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.o and pause while the list is filtered.

(3) Double-click the browser.link.open_newwindow.override.external preference and change its value to 2 and click OK.

The possible values for this preference are as follows:

-1 = follow your setting in Options for new tabs vs. new windows (default) 3 = open external links in a new tab in the last active window 2 = open external links in a new window 1 = open external links in the last active tab replacing the current page

There are some other similarly named preferences, so make sure to change the one that has "external" in the name.

Any difference?

more options

Thanks. That seems to have taken care of my issue. Have a blessed day!