X
Tap here to go to the mobile version of the site.

Support Forum

How do i stop firefox opening websites related to my search?

Posted

Hello.

I'm having a problem with firefox and it is getting really annoying.

When i search for something on the top right search box, Firefox opens a website with my search already put into the site (For example ebay or amazon but it is irrelevant because i search something like "How to...") But i do not want to do this, It has never opened a site i want.

I have also disabled every search engine apart from google in the "Search" settings.

I have also refreshed firefox and reinstalled it multiple times.

Thanks

Hello. I'm having a problem with firefox and it is getting really annoying. When i search for something on the top right search box, Firefox opens a website with my search already put into the site (For example ebay or amazon but it is irrelevant because i search something like "How to...") But i do not want to do this, It has never opened a site i want. I have also disabled every search engine apart from google in the "Search" settings. I have also refreshed firefox and reinstalled it multiple times. Thanks

Chosen solution

@jscher2000:

Note that you posted the same code twice and included #PopupSearchAutoComplete .addengine-item in both (should only be in the second example).

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#PopupSearchAutoComplete .search-panel-header.search-panel-current-input,
#PopupSearchAutoComplete .search-panel-one-offs,
#PopupSearchAutoComplete-anon-search-settings,
#PopupSearchAutoComplete .addengine-item { 
  display: none !important;
}

#PopupSearchAutoComplete-anon-search-settings should hide the "Change Search Settings" item in the search bar drop-down list.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 19.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

FredMcD
  • Top 10 Contributor
4270 solutions 59896 answers

What ever is entered into the search box is set to that search engine. Are you saying another search engine is coming up?

What ever is entered into the search box is set to that search engine. Are you saying another search engine is coming up?

Question owner

The only search engine i have set is google. But it keeps opening pages like ebay and amazon.

The only search engine i have set is google. But it keeps opening pages like ebay and amazon.
FredMcD
  • Top 10 Contributor
4270 solutions 59896 answers

Check your add-ons. Do you have any shopping add-ons?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Check your add-ons. Do you have any shopping add-ons? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? --------------- You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Helpful Reply

If you start typing in the search bar then it is possible that the drop-down list opens. If the mouse pointer is by accident on one of the other search engines that show in the list then you may be doing the search with another search engine than expected. Best is to avoid having the mouse pointer in the drop-down list area.

If you start typing in the search bar then it is possible that the drop-down list opens. If the mouse pointer is by accident on one of the other search engines that show in the list then you may be doing the search with another search engine than expected. Best is to avoid having the mouse pointer in the drop-down list area.

Question owner

Ok, i have found the problem. But i do not how to stop it.

The redirecting is being caused because firefox keeps adding things to my "One Click Search Engines" in the firefox settings. Is there a way to stop firefox adding sites?

(The Dark Souls 2 page was added recently after i used the site...)

Ok, i have found the problem. But i do not how to stop it. The redirecting is being caused because firefox keeps adding things to my "One Click Search Engines" in the firefox settings. Is there a way to stop firefox adding sites? (The Dark Souls 2 page was added recently after i used the site...)

Question owner

mrjezbud said

Ok, i have found the problem. But i do not how to stop it. The redirecting is being caused because firefox keeps adding things to my "One Click Search Engines" in the firefox settings. Is there a way to stop firefox adding sites? (The Dark Souls 2 page was added recently after i used the site...)

Also, when i remove them all and try and search, it sometimes randomly opens that preference page about search engines. That is before any more get added randomly and i only have google.

''mrjezbud [[#answer-793870|said]]'' <blockquote> Ok, i have found the problem. But i do not how to stop it. The redirecting is being caused because firefox keeps adding things to my "One Click Search Engines" in the firefox settings. Is there a way to stop firefox adding sites? (The Dark Souls 2 page was added recently after i used the site...) </blockquote> Also, when i remove them all and try and search, it sometimes randomly opens that preference page about search engines. That is before any more get added randomly and i only have google.
FredMcD
  • Top 10 Contributor
4270 solutions 59896 answers

FredMcD said

You may have ad / mal-ware. Further information can be found in the
Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.
''FredMcD [[#answer-793846|said]]'' <blockquote> You may have ad / mal-ware. Further information can be found in the <br>[[Troubleshoot Firefox issues caused by malware]] article.<br><br> Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up. </blockquote>

Question owner

FredMcD said

FredMcD said
You may have ad / mal-ware. Further information can be found in the
Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

I have no adware or malware. I have used many scanners including Malwarebyes, Kaspersky Rootkit Scanner, Spy Hunter and Avast.

''FredMcD [[#answer-793892|said]]'' <blockquote> ''FredMcD [[#answer-793846|said]]'' <blockquote> You may have ad / mal-ware. Further information can be found in the <br>[[Troubleshoot Firefox issues caused by malware]] article.<br><br> Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up. </blockquote> </blockquote> I have no adware or malware. I have used many scanners including Malwarebyes, Kaspersky Rootkit Scanner, Spy Hunter and Avast.
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

The issue of Firefox occasionally opening settings or using a different search engine that has an icon on the drop-down is one I experience myself. Here's what I think is happening:

Often when the panel drops down, the mouse pointer is over some part of it. If you move the mouse, Firefox interprets that as selecting what you want to happen when you press Enter. Bumping the mouse may be all it takes to trigger this feature, using a different search site or opening the settings page, depending on where the pointer is.

Other than moving the mouse pointer away, I don't know of any workaround for this, although removing unwanted search engines should take care of accidentally using those.

The issue of Firefox occasionally opening settings or using a different search engine that has an icon on the drop-down is one I experience myself. Here's what I think is happening: Often when the panel drops down, the mouse pointer is over some part of it. If you move the mouse, Firefox interprets that as selecting what you want to happen when you press Enter. Bumping the mouse may be all it takes to trigger this feature, using a different search site or opening the settings page, depending on where the pointer is. Other than moving the mouse pointer away, I don't know of any workaround for this, although removing unwanted search engines should take care of accidentally using those.

Question owner

jscher2000 said

The issue of Firefox occasionally opening settings or using a different search engine that has an icon on the drop-down is one I experience myself. Here's what I think is happening: Often when the panel drops down, the mouse pointer is over some part of it. If you move the mouse, Firefox interprets that as selecting what you want to happen when you press Enter. Bumping the mouse may be all it takes to trigger this feature, using a different search site or opening the settings page, depending on where the pointer is. Other than moving the mouse pointer away, I don't know of any workaround for this, although removing unwanted search engines should take care of accidentally using those.

I don't see how it could be that problem for me. The gap between the box and the settings menu is at least 2 inchs apart.

Also it just adds random sites i visit to the search engine. It happens really often.

''jscher2000 [[#answer-793936|said]]'' <blockquote> The issue of Firefox occasionally opening settings or using a different search engine that has an icon on the drop-down is one I experience myself. Here's what I think is happening: Often when the panel drops down, the mouse pointer is over some part of it. If you move the mouse, Firefox interprets that as selecting what you want to happen when you press Enter. Bumping the mouse may be all it takes to trigger this feature, using a different search site or opening the settings page, depending on where the pointer is. Other than moving the mouse pointer away, I don't know of any workaround for this, although removing unwanted search engines should take care of accidentally using those. </blockquote> I don't see how it could be that problem for me. The gap between the box and the settings menu is at least 2 inchs apart. Also it just adds random sites i visit to the search engine. It happens really often.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

If a website offers a search engine then you notice a green plus next to the search engine icon on the search bar on the Navigation Toolbar.

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

If a website offers a search engine then you notice a green plus next to the search engine icon on the search bar on the Navigation Toolbar. Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

Question owner

cor-el said

If a website offers a search engine then you notice a green plus next to the search engine icon on the search bar on the Navigation Toolbar. Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. You can also do a check for a rootkit infection with TDSSKiller. See also:

I have done this. Also the Kapersky rootkit tool i mentioned was TDSS Killer. I have also checked firefox on a laptop and it also uses different search engines even when they are all disabled.

Is there a way to fully disable the feature?

''cor-el [[#answer-793968|said]]'' <blockquote> If a website offers a search engine then you notice a green plus next to the search engine icon on the search bar on the Navigation Toolbar. Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked </blockquote> I have done this. Also the Kapersky rootkit tool i mentioned was TDSS Killer. I have also checked firefox on a laptop and it also uses different search engines even when they are all disabled. Is there a way to fully disable the feature?
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

mrjezbud said

Is there a way to fully disable the feature?

Which feature?

If my theory is correct that the problem is caused by the position of the mouse pointer over the drop-down, you could try hiding the settings button using a custom style rule. However, you were skeptical of my theory, so let me know if you want to pursue this idea.

''mrjezbud [[#answer-794004|said]]'' <blockquote> Is there a way to fully disable the feature? </blockquote> Which feature? If my theory is correct that the problem is caused by the position of the mouse pointer over the drop-down, you could try hiding the settings button using a custom style rule. However, you were skeptical of my theory, so let me know if you want to pursue this idea.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then create a new profile.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

Helpful Reply

For hiding parts of the drop-down, I'll post these now since I may be away for a while:

(1) Hiding the "one-off" buttons and settings button (first screen shot attached):

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #PopupSearchAutoComplete .search-panel-header.search-panel-current-input, #PopupSearchAutoComplete .search-panel-one-offs, #PopupSearchAutoComplete-anon-search-settings, #PopupSearchAutoComplete .addengine-item {   display: none !important; }

(2) Also hiding the "add this engine" button (second screen shot attached):

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #PopupSearchAutoComplete .search-panel-header.search-panel-current-input, #PopupSearchAutoComplete .search-panel-one-offs, #PopupSearchAutoComplete-anon-search-settings, #PopupSearchAutoComplete .addengine-item {   display: none !important; }

For hiding parts of the drop-down, I'll post these now since I may be away for a while: (1) Hiding the "one-off" buttons and settings button (first screen shot attached): <code>@namespace url(http://www.mozilla''.''org/keymaster/gatekeeper/there.is.only.xul); &#35;PopupSearchAutoComplete .search-panel-header.search-panel-current-input, &#35;PopupSearchAutoComplete .search-panel-one-offs, &#35;PopupSearchAutoComplete-anon-search-settings, &#35;PopupSearchAutoComplete .addengine-item { &nbsp;&nbsp;display: none !important; }</code> (2) Also hiding the "add this engine" button (second screen shot attached): <code>@namespace url(http://www.mozilla''.''org/keymaster/gatekeeper/there.is.only.xul); &#35;PopupSearchAutoComplete .search-panel-header.search-panel-current-input, &#35;PopupSearchAutoComplete .search-panel-one-offs, &#35;PopupSearchAutoComplete-anon-search-settings, &#35;PopupSearchAutoComplete .addengine-item { &nbsp;&nbsp;display: none !important; }</code>

Question owner

jscher2000 said

For hiding parts of the drop-down, I'll post these now since I may be away for a while: (1) Hiding the "one-off" buttons and settings button (first screen shot attached): @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #PopupSearchAutoComplete .search-panel-header.search-panel-current-input, #PopupSearchAutoComplete .search-panel-one-offs, #PopupSearchAutoComplete-anon-search-settings, #PopupSearchAutoComplete .addengine-item {   display: none !important; } (2) Also hiding the "add this engine" button (second screen shot attached): @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #PopupSearchAutoComplete .search-panel-header.search-panel-current-input, #PopupSearchAutoComplete .search-panel-one-offs, #PopupSearchAutoComplete-anon-search-settings, #PopupSearchAutoComplete .addengine-item {   display: none !important; }

That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box.

''jscher2000 [[#answer-794016|said]]'' <blockquote> For hiding parts of the drop-down, I'll post these now since I may be away for a while: (1) Hiding the "one-off" buttons and settings button (first screen shot attached): <code>@namespace url(http://www.mozilla''.''org/keymaster/gatekeeper/there.is.only.xul); &#35;PopupSearchAutoComplete .search-panel-header.search-panel-current-input, &#35;PopupSearchAutoComplete .search-panel-one-offs, &#35;PopupSearchAutoComplete-anon-search-settings, &#35;PopupSearchAutoComplete .addengine-item { &nbsp;&nbsp;display: none !important; }</code> (2) Also hiding the "add this engine" button (second screen shot attached): <code>@namespace url(http://www.mozilla''.''org/keymaster/gatekeeper/there.is.only.xul); &#35;PopupSearchAutoComplete .search-panel-header.search-panel-current-input, &#35;PopupSearchAutoComplete .search-panel-one-offs, &#35;PopupSearchAutoComplete-anon-search-settings, &#35;PopupSearchAutoComplete .addengine-item { &nbsp;&nbsp;display: none !important; }</code> </blockquote> That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box.

Question owner

mrjezbud said

jscher2000 said
For hiding parts of the drop-down, I'll post these now since I may be away for a while: (1) Hiding the "one-off" buttons and settings button (first screen shot attached): @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #PopupSearchAutoComplete .search-panel-header.search-panel-current-input, #PopupSearchAutoComplete .search-panel-one-offs, #PopupSearchAutoComplete-anon-search-settings, #PopupSearchAutoComplete .addengine-item {   display: none !important; } (2) Also hiding the "add this engine" button (second screen shot attached): @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #PopupSearchAutoComplete .search-panel-header.search-panel-current-input, #PopupSearchAutoComplete .search-panel-one-offs, #PopupSearchAutoComplete-anon-search-settings, #PopupSearchAutoComplete .addengine-item {   display: none !important; }

That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box.

Never mind. I got it. Thanks for the help everyone :)

''mrjezbud [[#answer-794033|said]]'' <blockquote> ''jscher2000 [[#answer-794016|said]]'' <blockquote> For hiding parts of the drop-down, I'll post these now since I may be away for a while: (1) Hiding the "one-off" buttons and settings button (first screen shot attached): <code>@namespace url(http://www.mozilla''.''org/keymaster/gatekeeper/there.is.only.xul); &#35;PopupSearchAutoComplete .search-panel-header.search-panel-current-input, &#35;PopupSearchAutoComplete .search-panel-one-offs, &#35;PopupSearchAutoComplete-anon-search-settings, &#35;PopupSearchAutoComplete .addengine-item { &nbsp;&nbsp;display: none !important; }</code> (2) Also hiding the "add this engine" button (second screen shot attached): <code>@namespace url(http://www.mozilla''.''org/keymaster/gatekeeper/there.is.only.xul); &#35;PopupSearchAutoComplete .search-panel-header.search-panel-current-input, &#35;PopupSearchAutoComplete .search-panel-one-offs, &#35;PopupSearchAutoComplete-anon-search-settings, &#35;PopupSearchAutoComplete .addengine-item { &nbsp;&nbsp;display: none !important; }</code> </blockquote> That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box. </blockquote> Never mind. I got it. Thanks for the help everyone :)
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

mrjezbud said

jscher2000 said
For hiding parts of the drop-down, I'll post these now since I may be away for a while:
That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box.

I only tested on my own Firefox. There may be something I missed. In case it matters, I used the Stylish extension instead of userChrome.css.

''mrjezbud [[#answer-794033|said]]'' <blockquote> ''jscher2000 [[#answer-794016|said]]'' <blockquote> For hiding parts of the drop-down, I'll post these now since I may be away for a while: </blockquote>That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box. </blockquote> I only tested on my own Firefox. There may be something I missed. In case it matters, I used the Stylish extension instead of userChrome.css.

Question owner

jscher2000 said

mrjezbud said
jscher2000 said
For hiding parts of the drop-down, I'll post these now since I may be away for a while:
That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box.

I only tested on my own Firefox. There may be something I missed. In case it matters, I used the Stylish extension instead of userChrome.css.

I used the codes and they worked. I also used the about:config and disabled "browser.search.showOneOffButtons"

One of them worked. Not sure which because i did both. But thanks! :)

''jscher2000 [[#answer-794037|said]]'' <blockquote> ''mrjezbud [[#answer-794033|said]]'' <blockquote> ''jscher2000 [[#answer-794016|said]]'' <blockquote> For hiding parts of the drop-down, I'll post these now since I may be away for a while: </blockquote>That looks like what i want. But i have tried both and neither removes the "Change Search Settings" box. </blockquote> I only tested on my own Firefox. There may be something I missed. In case it matters, I used the Stylish extension instead of userChrome.css. </blockquote> I used the codes and they worked. I also used the about:config and disabled "browser.search.showOneOffButtons" One of them worked. Not sure which because i did both. But thanks! :)
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

Oh, the about:config change switches to the older style search bar with the "g" icon instead of the magnifying glass icon. That works for now (not sure how long it will work in the future).

Oh, the about:config change switches to the older style search bar with the "g" icon instead of the magnifying glass icon. That works for now (not sure how long it will work in the future).