X
Tap here to go to the mobile version of the site.

Support Forum

addons page displays white text on a white background

Posted

I am legally blind. It has become a never-ending struggle to get Firefox to display colors properly. I use the high contrast black theme. and Firefox is configured to display white text on a black background. Recently I needed to tweak the colors for unvisited links. I couldn't because the palette colors were all black. I found a fix here to toggle the state of (I think) browwser.treference.inconfig. That gave me the old options screen back and it worked. Now I can't go back because the addons screen and about:config display white text on a white background.

I am legally blind. It has become a never-ending struggle to get Firefox to display colors properly. I use the high contrast black theme. and Firefox is configured to display white text on a black background. Recently I needed to tweak the colors for unvisited links. I couldn't because the palette colors were all black. I found a fix here to toggle the state of (I think) browwser.treference.inconfig. That gave me the old options screen back and it worked. Now I can't go back because the addons screen and about:config display white text on a white background.
Attached screenshots

Chosen solution

Last post on this subject - this is a known bug, #1207084, which is marked as resolved.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Content Blocker Extension
  • Version 5.41.2.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 19.0 r0
  • 5.1.20513.0
  • Virtual Keyboard

Application

  • Firefox 41.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
  • Support URL: https://support.mozilla.org/1/firefox/41.0.1/WINNT/en-US/

Extensions

  • Classic Theme Restorer 1.4.0 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Dangerous Websites Blocker 4.5.1.379 (content_blocker_663BE84DBCC949E88C7600F63CA7F098@kaspersky.com)
  • Download YouTube Videos as MP4 1.8.3.1-signed ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • Password Exporter 1.3.1.1-signed ({B17C1C5A-04B1-11DB-9804-B622A1EF5492})
  • Virtual Keyboard 4.5.1.379 (virtual_keyboard_07402848C2F6470194F131B0F3DE025E@kaspersky.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 760
  • adapterDescription2:
  • adapterDeviceID: 0x1187
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 27623842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 8-25-2015
  • driverDate2:
  • driverVersion: 10.18.13.5582
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 760 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158922 answers

Does NoSquint work better with the colors?

I don't know if the extension works with about pages.

Does NoSquint work better with the colors? *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/ I don't know if the extension works with about pages.

Question owner

I wouldn't be able to configure it - white on white addons page. Further info - it happens with an old profile created before the problem occurred. I also have Waterfox installed using the same profile as Firefox - it doesn't happen with Waterfox. I dunno...

I wouldn't be able to configure it - white on white addons page. Further info - it happens with an old profile created before the problem occurred. I also have Waterfox installed using the same profile as Firefox - it doesn't happen with Waterfox. I dunno...
jscher2000
  • Top 10 Contributor
8790 solutions 71880 answers

You can try editing the prefs.js file directly. Usually that's where the modified preferences for text color and background color are stored.

Start by opening your profile folder. In the search box on the Windows 7 Start menu, type or paste the following and press Enter to load it:

%APPDATA%\Mozilla\Firefox\Profiles

Here you may find one semi-randomly-named folder, in which case, go ahead and click into it, or you might find two or more, in which case, explore around and find the most recent.

That semi-randomly-named folder is your profile folder, and the prefs.js file in that folder is the one you'll want to edit. But first, you'll need to exit out of Firefox (so... make sure you have this message in a place you can read with Firefox closed).

Note: if you do not see the .js extension on the prefs file, you can set Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Right-click prefs.js and open it in an editor such as Notepad. Then use the editor's Find or Search command to look for this preference:

user_pref("browser.display.background_color", "#FFFFFF");

Carefully edit FFFFFF (six Fs = white) to 000000 (six zeros = black) and save the change. If your editor wants to convert the document to a rich text format, make sure to override that and use a plain text format (but without adding a .txt to the file name). Then close the editor.

When you start Firefox, it should read your updated settings file.

You can try editing the prefs.js file directly. Usually that's where the modified preferences for text color and background color are stored. Start by opening your profile folder. In the search box on the Windows 7 Start menu, type or paste the following and press Enter to load it: %APPDATA%\Mozilla\Firefox\Profiles Here you may find one semi-randomly-named folder, in which case, go ahead and click into it, or you might find two or more, in which case, explore around and find the most recent. That semi-randomly-named folder is your profile folder, and the prefs.js file in that folder is the one you'll want to edit. But first, you'll need to exit out of Firefox (so... make sure you have this message in a place you can read with Firefox closed). Note: if you do not see the .js extension on the prefs file, you can set Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions Right-click prefs.js and open it in an editor such as Notepad. Then use the editor's Find or Search command to look for this preference: user_pref("browser.display.background_color", "#FFFFFF"); Carefully edit FFFFFF (six Fs = white) to 000000 (six zeros = black) and save the change. If your editor wants to convert the document to a rich text format, make sure to override that and use a plain text format (but without adding a .txt to the file name). Then close the editor. When you start Firefox, it should read your updated settings file.
jscher2000
  • Top 10 Contributor
8790 solutions 71880 answers

When experimenting with these settings, of course, I created the same problem you have. I found a faster way to change the setting is to type the first part of its name into the search box on about:config

display.back

Then just below where the heading are, double-click the blank area to call up a little dialog that allows you to edit the color. (Screen shot attached for illustration.)

Either way, the Options page is hard to use with white text.

When experimenting with these settings, of course, I created the same problem you have. I found a faster way to change the setting is to type the first part of its name into the search box on about:config display.back Then just below where the heading are, double-click the blank area to call up a little dialog that allows you to edit the color. (Screen shot attached for illustration.) Either way, the Options page is hard to use with white text.
FredMcD
  • Top 10 Contributor
4269 solutions 59847 answers

This is probably a good site to be aware of http://www.accessfirefox.org/Firefox_Accessibility_Extensions.php It is a semi official mozilla community run site. IIRC the site and many of its addons were caught out by Australis. That is probably one site we should reach out to in advance if for instance making anything less distinct smaller, or lower contrast.

This is probably a good site to be aware of http://www.accessfirefox.org/Firefox_Accessibility_Extensions.php It is a semi official mozilla community run site. IIRC the site and many of its addons were caught out by Australis. That is probably one site we should reach out to in advance if for instance making anything less distinct smaller, or lower contrast.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158922 answers

Note that the Developer Toolbar (Firefox menu button or Tools > Web Developer; Shift+F2) also allows to inspect (pref show) and modify (pref set, pref reset) a pref. When you type the name of the pref then you see a list with matches and you can use the Tab key to accept an highlighted item.

  • pref show browser.display.background_color
  • pref reset browser.display.background_color
  • pref set browser.display.background_color

browser.display.background_color browser.display.foreground_color

Note that the Developer Toolbar (Firefox menu button or Tools > Web Developer; Shift+F2) also allows to inspect (pref show) and modify (pref set, pref reset) a pref. When you type the name of the pref then you see a list with matches and you can use the Tab key to accept an highlighted item. *https://developer.mozilla.org/Tools/GCLI *pref show browser.display.background_color *pref reset browser.display.background_color *pref set browser.display.background_color ---- browser.display.background_color browser.display.foreground_color

Question owner

I appreciate your assistance, and here goes: prefs - background color already set to black. The problem doesn't affect options - options has a different color problem; I used a workaround posted here and problem solved. The problem I'm experiencing affects addons and about:config. neither of those are available to me now. I also have Waterfoxx installed. Waterfox is a 64-bit build of Firefox. The problem does NOT affect Waterfox even though it uses the same profile as Firefox.

Thej problem began within the past few days, so I tried swapping the profile out with a month-old backup profile. The problem is still here even with a month-old profile.

What triggered the problem: I of course needed t0 change the link color. A dark blue link on a black background is virtually invisible. I fixed that years ago. A few days ago, I decided to lighten the color a bit, so I opened the options dialog, went to content, and discovered all colors in the palette were black. I searched here for a solution and found one. Go to about:config, in the filter bar type "incontent" to filter the options down to one. I forget the full name. Toggling that option (it's Boolean) gave me the old "icons on top" options dialog back, and I could change the link color. Now I can't access addons and about:config. I used Waterfox the toggle the aforementioned setting back to no effect.

I appreciate your assistance, and here goes: prefs - background color already set to black. The problem doesn't affect options - options has a different color problem; I used a workaround posted here and problem solved. The problem I'm experiencing affects addons and about:config. neither of those are available to me now. I also have Waterfoxx installed. Waterfox is a 64-bit build of Firefox. The problem does NOT affect Waterfox even though it uses the same profile as Firefox. Thej problem began within the past few days, so I tried swapping the profile out with a month-old backup profile. The problem is still here even with a month-old profile. What triggered the problem: I of course needed t0 change the link color. A dark blue link on a black background is virtually invisible. I fixed that years ago. A few days ago, I decided to lighten the color a bit, so I opened the options dialog, went to content, and discovered all colors in the palette were black. I searched here for a solution and found one. Go to about:config, in the filter bar type "incontent" to filter the options down to one. I forget the full name. Toggling that option (it's Boolean) gave me the old "icons on top" options dialog back, and I could change the link color. Now I can't access addons and about:config. I used Waterfox the toggle the aforementioned setting back to no effect.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158922 answers

The pref that is used for the document colors has changed from a Boolean pref (browser.display.use_document_colors) to an Integer pref with a different name (browser.display.document_color_use) that uses three values

  • browser.display.document_color_use
    Never(1) - Always(2) - Only with High Contrast themes(0)

Waterfox may still be using the old Boolean pref. Such changes are why we recommend to use a separate profile and not share a profile among different Firefox versions. Firefox may remove (reset) such no longer used prefs at ay time from the prefs.js file.

The pref that is used for the document colors has changed from a Boolean pref (browser.display.use_document_colors) to an Integer pref with a different name (browser.display.document_color_use) that uses three values *browser.display.document_color_use<br />Never(1) - Always(2) - Only with High Contrast themes(0) Waterfox may still be using the old Boolean pref. Such changes are why we recommend to use a separate profile and not share a profile among different Firefox versions. Firefox may remove (reset) such no longer used prefs at ay time from the prefs.js file.

Question owner

Boolean refers to about:config -> browser.preferences.incontent. Toggling this setting from true to false solved one color problem and caused another. Toggling it back does not solve the problem; it makes worse. I just experimented, and toggling it back to true adds the white on white now affects options as well. I have to use Waterfox to set it back. Turns out that if Waterfox and Firefox weren't using the same profiles, Firefox would be completely unusable. I had them using different profiles, and I didn't like that.

browser.display.document_color_use is 2 (always), and Waterfox sets it properly. This value can also be set in Options -> Content -> Colors in a drop-down box, right?

My assumption is that the problem isn't in the profile. I brought in an old profile from before the problem occurred. Problem was still there. I uninstalled Firefox and reinstalled it. No change. I am a retired computer professional, troubleshooting problems was my specalty and this buffaloes me.

Boolean refers to about:config -> browser.preferences.incontent. Toggling this setting from true to false solved one color problem and caused another. Toggling it back does not solve the problem; it makes worse. I just experimented, and toggling it back to true adds the white on white now affects options as well. I have to use Waterfox to set it back. Turns out that if Waterfox and Firefox weren't using the same profiles, Firefox would be completely unusable. I had them using different profiles, and I didn't like that. browser.display.document_color_use is 2 (always), and Waterfox sets it properly. This value can also be set in Options -> Content -> Colors in a drop-down box, right? My assumption is that the problem isn't in the profile. I brought in an old profile from before the problem occurred. Problem was still there. I uninstalled Firefox and reinstalled it. No change. I am a retired computer professional, troubleshooting problems was my specalty and this buffaloes me.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158922 answers

The name and function of the pref is confusing as it is about overriding the document colors, so with 2 you always override the website document colors with the selected colors.

  • Label in Options/Preferences > Content
    "Override the colors specified by the page with my selections above"

Keep in mind that the user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. Remove the user.js file or comment out lines once they have served their purpose to initialize a pref unless you want to make sure that prefs that you change regularly are initialized on the next start and do not want to preserve changes.

The name and function of the pref is confusing as it is about overriding the document colors, so with 2 you always override the website document colors with the selected colors. *Label in Options/Preferences > Content<br />"Override the colors specified by the page with my selections above" Keep in mind that the user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. Remove the user.js file or comment out lines once they have served their purpose to initialize a pref unless you want to make sure that prefs that you change regularly are initialized on the next start and do not want to preserve changes.

Question owner

Here is my user.js file:

user_pref("plugin.state.npcontentblocker", 2);

user_pref("plugin.state.nponlinebanking", 2);

user_pref("plugin.state.npvkplugin", 2);

What does the "2" value imply?

Here is my user.js file: user_pref("plugin.state.npcontentblocker", 2); user_pref("plugin.state.nponlinebanking", 2); user_pref("plugin.state.npvkplugin", 2); What does the "2" value imply?
jscher2000
  • Top 10 Contributor
8790 solutions 71880 answers

Helpful Reply

minaust said

Here is my user.js file: ... What does the "2" value imply?

A plugin.state.pluginname preference sets a plugin's default permission to Always Activate, Ask to Activate, or Never Activate. Those look like lines added by Kaspersky to default their plugins to Always Activate.

''minaust [[#answer-791382|said]]'' <blockquote> Here is my user.js file: ... What does the "2" value imply? </blockquote> A '''plugin.state.''pluginname''''' preference sets a plugin's default permission to Always Activate, Ask to Activate, or Never Activate. Those look like lines added by Kaspersky to default their plugins to Always Activate.

Question owner

OK I just ran one more test, and this is a bug in Firefox. I have a computer that's been in a closet since March 2015 that had a healthy working copy of Firefox installed. I pulled it out and tested Firefox - no problem. I upgraded Firefox, to 41.0.2, and it now has the same problem: Options, Addons, and about:config all have white text on a white background. No other changes were made.

Where do I go to report a bug in Firefox?

OK I just ran one more test, and this is a bug in Firefox. I have a computer that's been in a closet since March 2015 that had a healthy working copy of Firefox installed. I pulled it out and tested Firefox - no problem. I upgraded Firefox, to 41.0.2, and it now has the same problem: Options, Addons, and about:config all have white text on a white background. No other changes were made. Where do I go to report a bug in Firefox?
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158922 answers
  • plugin.state prefs (0:Never Activate; 1:Ask to Activate; 2:Always Activate)
*plugin.state prefs (0:Never Activate; 1:Ask to Activate; 2:Always Activate)
jscher2000
  • Top 10 Contributor
8790 solutions 71880 answers

You can file a bug here: https://bugzilla.mozilla.org/

You can file a bug here: https://bugzilla.mozilla.org/

Chosen Solution

Last post on this subject - this is a known bug, #1207084, which is marked as resolved.

Last post on this subject - this is a known bug, #1207084, which is marked as resolved.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40300 answers

Bug #1207084 - Resolved Fixed for Target Milestone: mozilla44 - which is now on the Nightly channel - slated for Release on 2016-01-26 .

Bug #1207084 - Resolved Fixed for Target Milestone: '''mozilla44''' - which is now on the Nightly channel - slated for Release on 2016-01-26 .