Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do I get Kaspersky activated on firefox

  • 8 replies
  • 110 have this problem
  • 3724 views
  • Last reply by ozlemmc

more options

I would like Kaspersky to protect my browser, but Firefox says it is not recognized

Chosen solution

Totally remove, then re-install Kaspersky using current full installer.

If there is still a problem, contact Kaspersky support.

Read this answer in context 👍 15

All Replies (8)

more options

Chosen Solution

Totally remove, then re-install Kaspersky using current full installer.

If there is still a problem, contact Kaspersky support.

more options

I have had this problem since last Firefox update. Working with Kaspersky, I have replaced 1915 version with 1916 version of Kaspersky. Firefox still disabled it. Kaspersky suggested I replace new Firefox with an older enterprise version. That solved that problem but introduced others -- inability of Firefox to recognize certain download links. I am now using Chrome, though I do not feel comfortable with it. I am about to download most recent Firefox update. I hope it recognizes Kaspersky. I suspect this is more a Firefox issue than a Kaspersky issue, since none of the other three browsers I have experience this problem. All work well with Kaspersky, as did Firefox before this newer version.

OK, latest update still does not recognize Kaspersky. Chrome does. Explorer does. What is with Firefox? Using Chrome until it recognizes Kaspersky.

Modified by Annie Stratton

more options

This will disable add-on signature enforcement; Enter about:config into your Firefox address bar Click the I'll be careful button Find xpinstall.signatures.required in the list Right click the preference Select Toggle until the value is false https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox

https://wiki.mozilla.org/Firefox/AddOns/Status/Updates#Exec_Summary “Currently targeting Signing with no pref to turn off in Firefox 47”


If this doesn't solve your problem,

Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.

more options

I prefer not to mess with config, and do not feel I should have to. I know, my choice. But I really do not get this. I've been using Firefox for years both because I support the effort, and because I like the way Firefox works and looks. All of a sudden it decides that my security package is risky. Out of the blue. Like I said, much as I dislike Google, it does work, and it does work with Kaspersky.

more options

I totally agree with dastratton. However I did change toggle to false and now the message I get is;

Kaspersky Protection could not be verified. proceed with caution.

so still not working!

more options

That is just a warning message. Make sure the add-on is enabled.

more options

ozlemmc said

I totally agree with dastratton. However I did change toggle to false and now the message I get is; Kaspersky Protection could not be verified. proceed with caution. so still not working!

Thanks, it is nice to know what it would do. I am not going to mess with config sys. I am going to see if I can make this whole issue go away. I scolded Firefox, and discussed with Kaspersky the other day. Yesterday, when I opened Firefox, I noticed that the K icon did not disappear after a few seconds. Ditto today, and it seems to be active even though in the addons FF says it is disable. Beats the heck out of me. I am still going to try what Kaspersky suggested, though, which is to uninstall it and then download and install again. They say FF should be accepting K. I think this is a Firefox issue more than a Kasperski issue, especially since Explorer and Chrome are fine with it.

Modified by Annie Stratton

more options

FredMcD said

That is just a warning message. Make sure the add-on is enabled.

It must be enabled now as "disable" icon is available in add-ons:-)