X
Tap here to go to the mobile version of the site.

Support Forum

Restarted Firefox and my bookmarks (and history) is gone

Posted

After recovering files to my C drive from Sandboxie (virtual browser) Firefox no longer shows my bookmarks and history. I see the places.sqlite file and others in the profile folder. I can't import because I only seem to have a backup from last month and it's a jsonlz4 file. The places.sqlite file is 10M so I know it has all the data I need but how do I get it to load into Firefox?


FYI, Sandboxie is a virtual browser so as bookmarks are added inside Firefox the file is saved in a virtual space. You have to "recover" said files to make them copy to the C drive. I did that before I cleaned out the Sandboxie (which needs to be done periodically to clean out malware and other junk). I then restarted Firefox after doing this and apparently it was referencing another file (that didn't get recovered) when it loaded my bookmarks.

After recovering files to my C drive from Sandboxie (virtual browser) Firefox no longer shows my bookmarks and history. I see the places.sqlite file and others in the profile folder. I can't import because I only seem to have a backup from last month and it's a jsonlz4 file. The places.sqlite file is 10M so I know it has all the data I need but how do I get it to load into Firefox? FYI, Sandboxie is a virtual browser so as bookmarks are added inside Firefox the file is saved in a virtual space. You have to "recover" said files to make them copy to the C drive. I did that before I cleaned out the Sandboxie (which needs to be done periodically to clean out malware and other junk). I then restarted Firefox after doing this and apparently it was referencing another file (that didn't get recovered) when it loaded my bookmarks.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.30514.0
  • Used to make VSee installation status and version number accessible via JavaScript

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Firefox uses profile folders that, as you probably discovered, are semi-randomly named. To discover the name and location of the profile folder Firefox is currently using you can launch it from the support information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Here you should find the current places.sqlite file and swap in the old one. Please make sure Firefox is fully shut down first. Either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Then allow a few moments for Firefox to reconsole the temporary files into the main places.sqlite database file. Then you can rename/remove it and copy the old one in.

When you start Firefox, are you back where you were?

Firefox uses profile folders that, as you probably discovered, are semi-randomly named. To discover the name and location of the profile folder Firefox is ''currently using'' you can launch it from the support information page. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Here you should find the current places.sqlite file and swap in the old one. Please make sure Firefox is fully shut down first. Either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Then allow a few moments for Firefox to reconsole the temporary files into the main places.sqlite database file. Then you can rename/remove it and copy the old one in. When you start Firefox, are you back where you were?

Question owner

Update: I moved an older places.sql file into my profile and it loaded so now I just need to know how to repair my apparently corrupt places file.....

Update: I moved an older places.sql file into my profile and it loaded so now I just need to know how to repair my apparently corrupt places file.....
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

What do you mean by "apparently corrupt"?

What do you mean by "apparently corrupt"?
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

The file size of places.sqlite doesn't mean much because its size is fixed to a minimum of 10 MB and gets incremented in 10 MB chunks if necessary. If the file has -corrupt appended (places.sqlite-corrupt) then Firefox has marked the file as such.

If you use undelete software to recover a file then there is no guarantee that a recovered file isn't corrupted because clusters may have been reused. With text files you can check that, but that won't be possible with binary files like places.sqlite.


The file size of places.sqlite doesn't mean much because its size is fixed to a minimum of 10 MB and gets incremented in 10 MB chunks if necessary. If the file has -corrupt appended (places.sqlite-corrupt) then Firefox has marked the file as such. If you use undelete software to recover a file then there is no guarantee that a recovered file isn't corrupted because clusters may have been reused. With text files you can check that, but that won't be possible with binary files like places.sqlite. ---- *Places Maintenance: https://addons.mozilla.org/firefox/addon/places-maintenance/ *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file

Question owner

I think I'm going to be sick. I copied an older version (5/15) of the places.sql to my folder and it worked. So that means my latest one from today may be corrupt. Anyway, I was playing around with my husband's profile with restoring backups and copied my old places file to another folder. Now what I had recovered from May is completely gone from my profile. Even taking the old one from May and overwriting my current one reverts back to my husbands profile. How can a copy of it in a different folder not take effect?

I think I'm going to be sick. I copied an older version (5/15) of the places.sql to my folder and it worked. So that means my latest one from today may be corrupt. Anyway, I was playing around with my husband's profile with restoring backups and copied my old places file to another folder. Now what I had recovered from May is completely gone from my profile. Even taking the old one from May and overwriting my current one reverts back to my husbands profile. How can a copy of it in a different folder not take effect?

Question owner

OK. I got the file back. I had an issue with a corrup bookmark that linked to the wrong profile. Back to my original issue now. I have a places.sqlite file from today before my 'crash' that won't load. I can only open the older file. That tells me it is corrupted otherwise I don't know what it wouldn't load.

OK. I got the file back. I had an issue with a corrup bookmark that linked to the wrong profile. Back to my original issue now. I have a places.sqlite file from today before my 'crash' that won't load. I can only open the older file. That tells me it is corrupted otherwise I don't know what it wouldn't load.

Question owner

If I can't get my places.sqlite back I would want to load the .jsonlz4 from a few weeks ago but the restore function of bookmarks doesn't see it.

If I can't get my places.sqlite back I would want to load the .jsonlz4 from a few weeks ago but the restore function of bookmarks doesn't see it.

Question owner

I tried the maintenance add-on but when I clicked on "options" Firefox locked up on me....

I tried the maintenance add-on but when I clicked on "options" Firefox locked up on me....
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

If the file is corrupted, usually Firefox will rename it with corrupted somewhere in the name. There is a somewhat complicated article about what to do in that case. I haven't tried it myself: https://developer.mozilla.org/docs/Mozilla/Tech/Places/places.sqlite_Database_Troubleshooting

To restore a bookmark backup that is in a different folder on your computer, you need to use Choose File (bottom of the Restore menu) and then navigate to it. For your convenience, you could drop a copy on the desktop or in your documents folder.

If the file is corrupted, usually Firefox will rename it with corrupted somewhere in the name. There is a somewhat complicated article about what to do in that case. I haven't tried it myself: https://developer.mozilla.org/docs/Mozilla/Tech/Places/places.sqlite_Database_Troubleshooting To restore a bookmark backup that is in a different folder on your computer, you need to use Choose File (bottom of the Restore menu) and then navigate to it. For your convenience, you could drop a copy on the desktop or in your documents folder.

Question owner

Had to delete and reinstall but still there are no bookmarks loading. The files don't have the "corrupt" annotation so it's not corrupt via Firefox but it somehow must be empty. The older file is 30M and the most recent is 10M. I know you said that wasn't important but it must mean something.

Had to delete and reinstall but still there are no bookmarks loading. The files don't have the "corrupt" annotation so it's not corrupt via Firefox but it somehow must be empty. The older file is 30M and the most recent is 10M. I know you said that wasn't important but it must mean something.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

Did you try to browse to the .jsonlz4 file via the Choose item in the Restore menu?

Note that best is to remove existing places.sqlite-shm and places.sqlite-wal SQLite temp files if you restore a places.sqlite file.


See this mozillaZine forum thread about Reading "jsonlz4" bookmarkbackup files:

Did you try to browse to the .jsonlz4 file via the Choose item in the Restore menu? Note that best is to remove existing places.sqlite-shm and places.sqlite-wal SQLite temp files if you restore a places.sqlite file. ---- See this mozillaZine forum thread about Reading "jsonlz4" bookmarkbackup files: *http://forums.mozillazine.org/viewtopic.php?f=38&t=2885435&start=15

Question owner

Yes, I tried to pick the jsonlz4 file but it didn't see it.

Thank you for telling me to delete those other 2 files. I was wondering about that.

As for the other link, I am following directions to get to the Browser Console but that doesn't tell me anything. I have no idea how to use the console to decompress the .jsonlz4 file.

Yes, I tried to pick the jsonlz4 file but it didn't see it. Thank you for telling me to delete those other 2 files. I was wondering about that. As for the other link, I am following directions to get to the Browser Console but that doesn't tell me anything. I have no idea how to use the console to decompress the .jsonlz4 file.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

You first need to make the command line in the Browser Console (Firefox/Tools > Web Developer) visible. You can do that by setting devtools.chrome.enabled to true on the about:config page.

Then you can paste the JavaScript in the command line and press Enter to evaluate the code.

You first need to make the command line in the Browser Console (Firefox/Tools > Web Developer) visible. You can do that by setting <b>devtools.chrome.enabled</b> to true on the <b>about:config</b> page. Then you can paste the JavaScript in the command line and press Enter to evaluate the code.

Helpful Reply

Actually I went back to the restore and it saw that file so there was no need to compress. It wasn't the latest. Apparently Firefox did not do its periodic bookmark backups. Luckily I had another profile from May and just copied that places file over. I lost a few additions but it will work.

Thank you all for your help.

Actually I went back to the restore and it saw that file so there was no need to compress. It wasn't the latest. Apparently Firefox did not do its periodic bookmark backups. Luckily I had another profile from May and just copied that places file over. I lost a few additions but it will work. Thank you all for your help.

Question owner

One other question. When I imported the .jsonlz4 file I assumed it worked because I got no errors but all it did was clear away all my bookmarks (like in an original install) even though it was a dated a month ago when I had bookmarks. Could that mean the import just didn't work because it was a compressed file?

One other question. When I imported the .jsonlz4 file I assumed it worked because I got no errors but all it did was clear away all my bookmarks (like in an original install) even though it was a dated a month ago when I had bookmarks. Could that mean the import just didn't work because it was a compressed file?
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

Importing a compressed file should work especially if it was created by the same Firefox version. An import can fail if there are (corruption) problems with the current places.sqlite file.

Did you try to decompress the file?

Importing a compressed file should work especially if it was created by the same Firefox version. An import can fail if there are (corruption) problems with the current places.sqlite file. Did you try to decompress the file?

Question owner

No I didn't. I haven't figured out how to use the Console to do that. There's one post that tells me how to open it and another post that tells me what to type but I can't figure out where I'm supposed to put those commands. None of the dropdown options give me a "command" type option.

No I didn't. I haven't figured out how to use the Console to do that. There's one post that tells me how to open it and another post that tells me what to type but I can't figure out where I'm supposed to put those commands. None of the dropdown options give me a "command" type option.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

You first need to open the about:config page.

Type about:config in the location (address) bar and press the Enter key to open the about:config page like you open a website by typing the URL in the location bar.

  • if you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be modified via Modify (String or Integer) or Toggle (Boolean) in the right-click context menu and by double-clicking the line with the pref

Use the search bar to locate the devtools.chrome.enabled and toggle this pref to true with a double-click on this line. That should make the command line appear at the bottom of the Browser Console (Firefox/Tools > Web Developer) window where you can paste the JavaScript code.

You first need to open the about:config page. Type <b>about:config</b> in the location (address) bar and press the <i>Enter</i> key to open the <i>about:config</i> page like you open a website by typing the URL in the location bar. *if you see a warning message then you can confirm that you want to access the about:config page. *use the Search bar at the top of the about:config page to locate preferences more easily *preferences that have been modified and do not have the default value show as bold (user set) *preferences that are user set (bold) can be reset to the default value via the right-click context menu *preferences can be modified via Modify (String or Integer) or Toggle (Boolean) in the right-click context menu and by double-clicking the line with the pref Use the search bar to locate the <b>devtools.chrome.enabled</b> and toggle this pref to true with a double-click on this line. That should make the command line appear at the bottom of the Browser Console (Firefox/Tools > Web Developer) window where you can paste the JavaScript code.