Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do i restore the back function. it doesnt work when searching

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by jscher2000

more options

when searching I get several options. If I choose an option and want to go back to the detailed search the "back" fumction doesnt work I have to reenter the search data again

All Replies (1)

more options

Is the back button grayed out so Firefox does not let you go back, or is the results page blank when you go back so you have to search again?

If the back button is grayed:

This usually indicates that your search results are opening in a new tab or window. This could be a setting on your search site. If you are using Google, check out the "Where results open" option on this page: https://www.google.com/preferences

If the results page is blank (and you use Google):

There is an old problem with going "back" to the Google search results page and having it blank out. It seems to occur only when you use a high zoom level on Google with "instant prediction results" (the default setting). When going back to that page, Firefox glitches when restoring the page from its in-memory cache, in fact, you may see the results for a split second before they blank out.

Possible workarounds:

  • reduce your zoom level on the results page before following a link to results (e.g., hold down the Ctrl key and tap the - key)
  • change a Firefox setting to turn off part of Firefox's in-memory caching (details below)
  • change to old style results, but then you don't get the "as you type" results (see the preferences page mentioned before)

Does one of those fix it for you?


To modify the hidden setting:

(1) In a new tab, type or paste about:config in the address bar and press Return/ Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change the value from -1 to 0 (that's a zero).

(Please don't change any other similar-sounding settings to 0 or you may disable Firefox's ability to save/restore your open windows and tabs.)

Then reload the Google results page and test.