Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webpages not displaying graphics/images properly

  • 6 replies
  • 2 have this problem
  • 10 views
  • Last reply by cor-el

more options

I have been running Firefox 40.0.2 on Windows 10 for a couple of weeks and recently Firefox has not been loading all web pages properly. A similar problem was logged here https://support.mozilla.org/en-US/questions/1056725

It appears that some sites are unable to load any graphical content (see attached screenshot for an example). Example of sites would be Facebook, Yahoo & Mozilla. Other sites load fine e.g. Radiotimes.com, metro.co.uk & Smugmug. 1 site I have found so far load’s fine until you try navigating anywhere on the site (Flickr).

I have tried: • Refreshing Firefox • Have checked that In private Browsing is not set to always on (Tools\Privacy – under History changing Firefox will to use custom settings for history) • Uninstalling and reinstalling • Changed default theme • Tried running in safe mode • Checked firewall settings • Cleared history • Flushed the DNS • Attempted to reset default user agent (all options have “reset” greyed out) • Creating a new user account on the PC • Deleting and creating a new profile

The default Administrator account is active and can display all the webpages mentioned above with no issue, if I change my standard account to an Administrator 1 the problem persists.

Any other ideas on what I can try??

I have been running Firefox 40.0.2 on Windows 10 for a couple of weeks and recently Firefox has not been loading all web pages properly. A similar problem was logged here https://support.mozilla.org/en-US/questions/1056725 It appears that some sites are unable to load any graphical content (see attached screenshot for an example). Example of sites would be Facebook, Yahoo & Mozilla. Other sites load fine e.g. Radiotimes.com, metro.co.uk & Smugmug. 1 site I have found so far load’s fine until you try navigating anywhere on the site (Flickr). I have tried: • Refreshing Firefox • Have checked that In private Browsing is not set to always on (Tools\Privacy – under History changing Firefox will to use custom settings for history) • Uninstalling and reinstalling • Changed default theme • Tried running in safe mode • Checked firewall settings • Cleared history • Flushed the DNS • Attempted to reset default user agent (all options have “reset” greyed out) • Creating a new user account on the PC • Deleting and creating a new profile The default Administrator account is active and can display all the webpages mentioned above with no issue, if I change my standard account to an Administrator 1 the problem persists. Any other ideas on what I can try??
Attached screenshots

Chosen solution

Are these the only certificate errors you've seen?

We don't see the "sec_error_bad_signature" error code too often. Do you use Avast or the Zscalar proxy?

Avast: Within the Web Shield, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

Zscalar: See this thread: https://support.mozilla.org/questions/1068675

Read this answer in context 👍 0

All Replies (6)

more options

Has Firefox presented any error pages related to SSL certificates?

One thing you didn't mention that seems to be affecting a lot of Windows 10 users is that parental controls are being applied to their accounts, which causes seemingly random silent blockages. Could you check Microsoft Family Safety and either disable it or take your account out of the family: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

more options

Have checked the link and followed it to "account.microsoft.com/family." - removing myself from the family has made no difference

more options

Could you test these addresses, they are the style sheets for some Mozilla sites. Do they load? Is there any error message?

(Note: a successful load is a wall of text starting with the text noted below.)

more options

No, neither loaded. Get following error:

Secure Connection Failed

An error occurred during a connection to support.cdn.mozilla.net. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.
more options

Chosen Solution

Are these the only certificate errors you've seen?

We don't see the "sec_error_bad_signature" error code too often. Do you use Avast or the Zscalar proxy?

Avast: Within the Web Shield, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

Zscalar: See this thread: https://support.mozilla.org/questions/1068675

more options

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

You can use this button to go to the current Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also: