Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't make Firefox my default browser in Windows 10.

  • 7 replies
  • 13 have this problem
  • 16 views
  • Last reply by AliceWyman

more options

I have replaced Firefox in Web Browser Settings in Windows 10. I boot Firefox and make it my default browser. When I search web sites in Firefox it does nothing. I tried it with Google, Bing, Yahoo - nothing happens. If I go back to Windows 10 settings and change it to Microsoft Edge, it surfs immediately with Bing. I have done this 100 times and it does the same. Very frustrating!

I have replaced Firefox in Web Browser Settings in Windows 10. I boot Firefox and make it my default browser. When I search web sites in Firefox it does nothing. I tried it with Google, Bing, Yahoo - nothing happens. If I go back to Windows 10 settings and change it to Microsoft Edge, it surfs immediately with Bing. I have done this 100 times and it does the same. Very frustrating!

Chosen solution

AliceWyman said

Have you tried other browsers, like Google Chrome or Internet Explorer? (See How to open Internet Explorer in Windows 10). If only Microsoft Edge can access websites, I'm thinking that this is not a Firefox issue and you may get better help on a Windows forum. Here's a thread from a Windows 10 forum about a similar problem (only Microsoft Edge accessed websites, other browsers did not) which was solved by resetting your network adapter by entering netsh winsock reset at a Command Prompt with Administrative privileges and then restarting Windows:
http://www.tenforums.com/network-sharing/10028-internet-connection-only-microsoft-edge.html

Fvanmeter said

This last thread from a Windows 10 forum worked. I can now get Internet from Firefox, Chrome as well as Edge. This ended days of frustration. Thanks Firefox for research. netsh winsock reset to free your adapter. My next step was to uninstall Windows 10. Thanks!

You're welcome, and thanks for posting back with the outcome. I'll mark this as the solution.

Read this answer in context 👍 3

All Replies (7)

more options

hi Fvanmeter, what anti virus program are you running & can you check if the solution from this similar thread applies to you as well: https://support.mozilla.org/en-US/questions/1075112

more options

Are you using Microsoft Family Safety

That can cause this sort of issue.

  • Try temporarily turning it off, does that solve the problem ?
    Or at least try from an Administrator account.
  • Do you need the Microsoft Family Safety feature ?
    Do you have others especially young persons using this computer ?

See also

  1. Wikipedia Microsoft_Family_Safety
  2. Microsoft: http://answers.microsoft.com/en-us/windows/wiki/windows_other-security/family-safety-frequently-asked-questions/5672f7b2-e3c0-498a-9a6c-c9cab39f68e5
Sorry I am not a Windows 10 user so am not able to test this out. From the Microsoft article above I note
How do I remove or turn off Family Safety?
  • Windows 8: Family Safety is built into Windows 8 and can’t be uninstalled, but you can always turn it off. To turn off Family Safety for an account change the account type from Child to Standard in PC Settings.
  • Windows 7 or earlier versions of Windows: How do I remove Family Safety?
Unfortunately I am not a Window 10 user, so I am not sure what the position is with Windows 10 and whether any problems caused because of use of MS Family Safety may be resolves easily from use the familiar settings options. Related thread

P.S. Windows 10 specific MS faqs

It is still not bringing up any other Windows 10 specific answer

Edit fixed links; a locale i.e. en-us mandatory. Thanks Ideato

Modified by John99

more options

Fvanmeter said

I have replaced Firefox in Web Browser Settings in Windows 10. I boot Firefox and make it my default browser. When I search web sites in Firefox it does nothing. I tried it with Google, Bing, Yahoo - nothing happens. If I go back to Windows 10 settings and change it to Microsoft Edge, it surfs immediately with Bing.

Forget about making Firefox your default browser for now. Even though Microsoft Edge is the default browser, can you still use Firefox to browse the Web? Does Firefox work correctly when you use Google, Bing, or Yahoo search? What about going to websites when you type its location in the Firefox address bar? Open Firefox and type in www.cnn.com or www.mozilla.org in the address bar - what happens? Can you get to those sites and, if not, is there any error message?

more options

See this thread for a reply by the OP:

Fvanmeter wrote:

Thank you for your answer but: I have tried Firefox as the default browser and not as the default browser. It will not bring up www.cnn.com or www.mozilla.org or any of my standard web sites www.nbcnews.com or www.huffingtonpost.com. Either. But if I go to Microsoft Edge it brings them all up, even when I have Firefox as my default browser.

I have TrendMicro Maximum Security anti-virus, etc and System Mechanic or system analysis. I have tried disabling both those programs and it still does the same thing as above.

Modified by cor-el

more options

To Fvanmeter: In reply to your post in the other thread,

Thank you for your answer but: I have tried Firefox as the default browser and not as the default browser. It will not bring up www.cnn.com or www.mozilla.org or any of my standard web sites www.nbcnews.com or www.huffingtonpost.com. Either. But if I go to Microsoft Edge it brings them all up, even when I have Firefox as my default browser.

I have TrendMicro Maximum Security anti-virus, etc and System Mechanic or system analysis. I have tried disabling both those programs and it still does the same thing as above.

Have you tried other browsers, like Google Chrome or Internet Explorer? (See How to open Internet Explorer in Windows 10). If only Microsoft Edge can access websites, I'm thinking that this is not a Firefox issue and you may get better help on a Windows forum.

Here's a thread from a Windows 10 forum about a similar problem (only Microsoft Edge accessed websites, other browsers did not) which was solved by resetting your network adapter by entering netsh winsock reset at a Command Prompt with Administrative privileges and then restarting Windows:

http://www.tenforums.com/network-sharing/10028-internet-connection-only-microsoft-edge.html

more options

This last thread from a Windows 10 forum worked. I can now get Internet from Firefox, Chrome as well as Edge. This ended days of frustration. Thanks Firefox for research. netsh winsock reset to free your adapter. My next step was to uninstall Windows 10. Thanks!

more options

Chosen Solution

AliceWyman said

Have you tried other browsers, like Google Chrome or Internet Explorer? (See How to open Internet Explorer in Windows 10). If only Microsoft Edge can access websites, I'm thinking that this is not a Firefox issue and you may get better help on a Windows forum. Here's a thread from a Windows 10 forum about a similar problem (only Microsoft Edge accessed websites, other browsers did not) which was solved by resetting your network adapter by entering netsh winsock reset at a Command Prompt with Administrative privileges and then restarting Windows:
http://www.tenforums.com/network-sharing/10028-internet-connection-only-microsoft-edge.html

Fvanmeter said

This last thread from a Windows 10 forum worked. I can now get Internet from Firefox, Chrome as well as Edge. This ended days of frustration. Thanks Firefox for research. netsh winsock reset to free your adapter. My next step was to uninstall Windows 10. Thanks!

You're welcome, and thanks for posting back with the outcome. I'll mark this as the solution.