Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to maximize a Youtube video, nothing happens.

  • 4 replies
  • 3 have this problem
  • 1448 views
  • Last reply by Chuckk

more options

Whenever I try to maximize a Youtube video, nothing happens. I click on the "maximize button" but there is no response.

I can watch Youtube videos in the "minimized" and "theatrical" view just fine. I can watch videos on other websites on fullscreen as well. When I switch to another web browser, like Chrome, I can watch Youtube videos in maximized view just fine.

Chosen solution

Hi Chuckk. 1. Go to Youtube. 2. Once the site has loaded, click on the small lock icon in the location bar. 3. Set the "Enter Fullscreen: " permission to "Always Ask" or "Allow".

(Don't forget to re-enable things like hardware acceleration if my solution worked.)

Read this answer in context 👍 4

All Replies (4)

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Try to "disable the hardware acceleration" in the Flash Player.

Flash "Display settings" window:

more options

None of that seemed to help. I disabled Hardware Acceleration for both Firefox and Flash Player. I still have the same issue.

more options

Chosen Solution

Hi Chuckk. 1. Go to Youtube. 2. Once the site has loaded, click on the small lock icon in the location bar. 3. Set the "Enter Fullscreen: " permission to "Always Ask" or "Allow".

(Don't forget to re-enable things like hardware acceleration if my solution worked.)

more options

kenkon said

Hi Chuckk. 1. Go to Youtube. 2. Once the site has loaded, click on the small lock icon in the location bar. 3. Set the "Enter Fullscreen: " permission to "Always Ask" or "Allow". (Don't forget to re-enable things like hardware acceleration if my solution worked.)

Jeez O' Pete! That did it! Thank you so much. I have no idea how that got switched off. I didn't even know it was there, and I've been using Firefox for over a year now with no problems.

Thank you again for solving this very annoying issue for me!