Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

automatically sign off after few minutes from webpages logged in in 36.0.4 version

  • 2 replies
  • 2 have this problem
  • 6 views
  • Last reply by srikanta

more options

i upgraded firefox version to 36.0.4 in maverick . it asks for separate login to gmail-chat though i am already logged in gmail. it logs out my account automatically after few minutes. not only in gmail, but from facebook also. should i go with older version or what to do ?

Chosen solution

Sometimes this can be caused by corrupted cookies, or by blocking "third party" cookies, or by using automatic private browsing mode.

Corrupted Cookies

You can use the Permissions Manager to clear your Firefox cookies for all Google sites.

Type or paste about:permissions in the address bar and press Return or Enter to load that page

Above the left column is a search box, go ahead and type google in there and pause while the list is filtered. This list may keep growing longer as the search proceeds in the background.

Select one of the Google domains and on the right side Firefox should show if there are any cookies saved for that domain. Work down the list and clear any cookies you find.

Then return to Google and log into your account again and see whether you can stay logged in. Any improvement?

Cookie Permissions and Private Browsing

You can use the Options/Preferences dialog to check these:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences > Privacy
  • Win: "3-bar" menu button (or Tools menu) > Options > Privacy

If the selector in the middle of the tab shows anything other than "Firefox will: Use custom settings for history" go ahead and change it to that so you can access settings.

  • If "Always use private browsing mode" is selected, uncheck that. Note that restarting normally probably won't be able to redisplay your current windows.
  • Under "Accept cookies from sites" make sure that "Accept third party cookies" is set to Always.

Any improvement?

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

Sometimes this can be caused by corrupted cookies, or by blocking "third party" cookies, or by using automatic private browsing mode.

Corrupted Cookies

You can use the Permissions Manager to clear your Firefox cookies for all Google sites.

Type or paste about:permissions in the address bar and press Return or Enter to load that page

Above the left column is a search box, go ahead and type google in there and pause while the list is filtered. This list may keep growing longer as the search proceeds in the background.

Select one of the Google domains and on the right side Firefox should show if there are any cookies saved for that domain. Work down the list and clear any cookies you find.

Then return to Google and log into your account again and see whether you can stay logged in. Any improvement?

Cookie Permissions and Private Browsing

You can use the Options/Preferences dialog to check these:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences > Privacy
  • Win: "3-bar" menu button (or Tools menu) > Options > Privacy

If the selector in the middle of the tab shows anything other than "Firefox will: Use custom settings for history" go ahead and change it to that so you can access settings.

  • If "Always use private browsing mode" is selected, uncheck that. Note that restarting normally probably won't be able to redisplay your current windows.
  • Under "Accept cookies from sites" make sure that "Accept third party cookies" is set to Always.

Any improvement?

more options

srikanta said

i upgraded firefox version to 36.0.4 in maverick . it asks for separate login to gmail-chat though i am already logged in gmail. it logs out my account automatically after few minutes. not only in gmail, but from facebook also. should i go with older version or what to do ?

It worked. Thanks a lot :)