Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how can I stop Firefox, my default browser, from asking permission every time I open it

  • 13 replies
  • 15 have this problem
  • 555 views
  • Last reply by jedakay

more options

It's only a small thing but every time I open my default browser, Firefox, up pops the page asking me to give permission.

Chosen solution

A possible cause of this error is that Firefox is set to run as Administrator. Check that Firefox isn't set to run as Administrator. Right-click the Firefox desktop shortcut and choose "Properties". Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder (C:\Program Files\Mozilla Firefox\). If you can't make changes then start Windows Explorer as Administrator.

Read this answer in context 👍 5

All Replies (13)

more options

Chosen Solution

A possible cause of this error is that Firefox is set to run as Administrator. Check that Firefox isn't set to run as Administrator. Right-click the Firefox desktop shortcut and choose "Properties". Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder (C:\Program Files\Mozilla Firefox\). If you can't make changes then start Windows Explorer as Administrator.

more options

Separate Issue; Your System Details shows;

Installed Plug-ins

Shockwave Flash 11.6 r602 Shockwave Flash 16.0 r0

Having more than one version of a program may cause issues.

Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac Then reinstall the latest version.

Flash Player v16.0.0.287
https://www.adobe.com/products/flashplayer/distribution3.html

more options

Thanks, when I went to the "Compatibility" tab of the Properties window I discovered it thought it was running XP, I don't know why, this computer has always had 7 on it. Once I altered that it began to work very well. It also solved one or two other niggles I've had with it!

more options

Am having same problems on both of my machines, started a few days ago. Although the mentioned compatibility boxes are blank I must run Firefox as an administrator and not use restart in order not to have to confirm for default browser; when I use restart then it'll ask me again to confirm. Never had a problem like this for years, sure is frustrating. The only change I made on both machines was to install FREE REGISTRY DEFRAG and their installer did not show any substitute browser. Strange thing is while Firefox will ask me to confirm that it is the default browser, IE programs shows that it is not set as the default browser; so what prompts FF to confirm?

more options

Sometimes, this works;

Open Windows Internet Explorer. Select Tools > Internet Options > Programs. Make IE the default browser under; Default Web Browser. Close IE.

Now open Firefox. Type about:preferences#general<enter> in the address bar. Turn on Always Check Firefox Default Browser.

more options

Thanks for your interest. Tried as you suggested, after a computer restart I'm back to square one; got to start FF as an administrator and not restart my machine, if I put in sleep mode and come out of it I can run FF without administrator's privileges. Is there any applicable setting in Firefox "about:config?"

Modified by jedakay

more options

Just discovered one more new problem. I run FF in tabbed mode with 5 start-up tabs and now while running it with administrators privileges I'm unable to open an internet short cut, let's say from my desktop which in the past would have opened as a sixth tab in Firefox. I can do it when when I open FF the regular way, being asked for confirmation and I can click on a short cut by itself to open FF, but not when I'm running FF in administrator mode.

more options

Also, perhaps I should add that Thunderbird was doing the same thing on both machines but after trying to set it as a default several times it finally quit asking me to confirm, for now anyway.

more options

At this point, you should ask your own question.

Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.

more options

This must be a Firefox problem, caused by the latest update to 35.01 on both machines about a week ago.

After I could not uninstall from Programs and Features I manually removed all traces of Firefox in Program Files, APPDATA, including registry keys, removed the profile folder, used CCleaner to clean up leftovers and did a fresh install of 35.01; guess what! It's doing the same thing!

And I did the same a second time, this time I was able to uninstall from Programs and Features, still I removed every trace again and after the install I disabled all my plugins, installed no extensions, just the basic install and never mind Run as an Administrator-I haven't tried it, but now it asks to be the default browser every time I open it. It simply will not accept its own confirmation nor accept to be default through the default setting program in the control panel, period.

I have no other browsers in my system except IE and it is set not be default.

Although I did this only on one machine, there's the reality that I have the same problem on two machines after updating to 35.0.1!

Someone at Firefox needs to listen.

more options

Forgot to mention that I've unchecked the Always check to see.......box and thereby stopped being asked to confirm every time I open Firefox but why does it state there in bold black letters that Firefox is not my default browser?

more options
more options

Thanks for your reply. I read the suggestions in the link you provided but I don't think I want to waste my time “experimenting,” I've already spent too many hours on this What I have now on two different machines is a brand new unadulterated installation of Firefox that will not accept itself to be the default browser; seems to me, that's a Firefox issue.