X
Tap here to go to the mobile version of the site.

Support Forum

Why is shockwave flash and akamaihd crashing constantly?

Posted

I'm sick of this, and seriously considering ditching Firefox.

Nearly every time Facebook updates or loads, Shockwave Flash crashes and I get a dialogue window saying the script "https://fbstatic-a.akamaihd.net/rsrc.php/v2/yd/r/M9WQeVKSbLt.js:13" has crashed.

My Flash plugin is up to date. I've disabled hardware acceleration. I've reset Firefox. What is there left to do? I've been sending crash reports but they seem to be a waste of time.

I'm sick of this, and seriously considering ditching Firefox. Nearly every time Facebook updates or loads, Shockwave Flash crashes and I get a dialogue window saying the script "https://fbstatic-a.akamaihd.net/rsrc.php/v2/yd/r/M9WQeVKSbLt.js:13" has crashed. My Flash plugin is up to date. I've disabled hardware acceleration. I've reset Firefox. What is there left to do? I've been sending crash reports but they seem to be a waste of time.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Battlelog Game Launcher (2.6.2)
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Application

  • Firefox 35.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Avast Online Security 10.0.2502.149 (wrc@avast.com)
  • NoScript 2.6.9.10 ({73a6fe31-595d-460b-a920-fcc0f8843232})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 760
  • adapterDescription2:
  • adapterDeviceID: 0x1187
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 28471462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 12-13-2014
  • driverDate2:
  • driverVersion: 9.18.13.4709
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 760 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? -------------------- Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.'''

Question owner

I disabled hardware acceleration again and the exact same thing is happening.

The only extensions I'm using are Avast, Adblock and NoScript. I've disabled Avast but I'm not disabling the other two, otherwise I may as well use another browser that can function properly.

I disabled hardware acceleration again and the exact same thing is happening. The only extensions I'm using are Avast, Adblock and NoScript. I've disabled Avast but I'm not disabling the other two, otherwise I may as well use another browser that can function properly.
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

In the address bar, type '''about:crashes'''<enter>.''' Note:''' If any reports do not have '''BP''' in front of the numbers, click it and select '''Submit'''. Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in.

Question owner

Ok here goes;

bp-77548d7f-d590-4eb0-ac4c-b37932150117 17/01/2015 16:38 bp-dd5060d0-c760-41d7-beda-132812150117 17/01/2015 15:27 bp-14687a5c-c822-4c6b-b96a-0cef42150116 16/01/2015 16:06 bp-aea958c8-4edb-4849-8326-59e692150116 16/01/2015 09:42 bp-9d1e53a9-a852-4acb-a5b4-324202150115 15/01/2015 12:38 bp-41e440fd-e407-48b8-bdae-0b02f2150115 15/01/2015 10:56 bp-1b385a75-2b95-4472-a9b3-4822e2150115 15/01/2015 09:15 bp-a0f9efe0-e98b-4b92-ad84-fbe692150115 15/01/2015 08:09 bp-cc584dda-1ff1-431b-b815-066bc2150114 14/01/2015 07:44 bp-c066ecf4-7e77-418c-b2cd-dbb562150112 12/01/2015 16:49

Ok here goes; bp-77548d7f-d590-4eb0-ac4c-b37932150117 17/01/2015 16:38 bp-dd5060d0-c760-41d7-beda-132812150117 17/01/2015 15:27 bp-14687a5c-c822-4c6b-b96a-0cef42150116 16/01/2015 16:06 bp-aea958c8-4edb-4849-8326-59e692150116 16/01/2015 09:42 bp-9d1e53a9-a852-4acb-a5b4-324202150115 15/01/2015 12:38 bp-41e440fd-e407-48b8-bdae-0b02f2150115 15/01/2015 10:56 bp-1b385a75-2b95-4472-a9b3-4822e2150115 15/01/2015 09:15 bp-a0f9efe0-e98b-4b92-ad84-fbe692150115 15/01/2015 08:09 bp-cc584dda-1ff1-431b-b815-066bc2150114 14/01/2015 07:44 bp-c066ecf4-7e77-418c-b2cd-dbb562150112 12/01/2015 16:49
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

The crash report flagged these programs;

Process Type plugin Shockwave Flash Version:16.0.0.257

Signature hang | CleanupPerAppKey


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

The crash report flagged these programs; Process Type plugin Shockwave Flash Version:16.0.0.257 Signature hang | CleanupPerAppKey ---------------- If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Scripts hangs with Flash can be caused by the protected mode feature of the Flash plugin. That feature has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Scripts hangs with Flash can be caused by the protected mode feature of the Flash plugin. That feature has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that: * Adobe support article under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] * Manual steps: https://support.mozilla.org/questions/968190?page=5#answer-509209 * Batch file to automate the manual steps: https://support.mozilla.org/questions/982093#answer-518078 (alternate version of Carm's batch file with a few changes by me: [https://onedrive.live.com/?cid=f7d304d92388737d&id=F7D304D92388737D!336&ithint=file,.bat&authkey=!AP2FXW2Y_3BXZyo]) Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.