Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open .pdfs in Firefox

  • 6 replies
  • 10 have this problem
  • 18145 views
  • Last reply by jesusjones

more options

My wife's machine is running Windows 8.1, Firefox 34.0.5 and Adobe Acrobat X Standard. Cannot open .pdfs in the browser. Clicking a link to a .pdf will open a new tab that immediately closes, leaving me right back where I was, as if I had never clicked the link. I can right click, then Save As, download the file and open in Adobe Acrobat X. But that's not what I want, and not how it was designed.

Internet Explorer 11 opens .pdfs in the environment described above, in-browser, with no problems.

I've followed all the instructions at https://support.mozilla.org/en-US/questions/972278 and http://helpx.adobe.com/acrobat/kb/cant-view-pdf-web.html. Neither Mozilla's nor Adobe's instructions can get me up and running.

As a nuclear option, I uninstalled Adobe Acrobat, restarted the machine, uninstalled Firefox, restarted the machine, re-installed Adobe Acrobat, restarted the machine, and re-installed Firefox, and restarted the machine. Attempting to open any .pdf yields the same result, even after uninstalling and re-installing everything. What's going on here? Why does Firefox open a blank tab, and then close it right away? Block pop-ups is set to off, and antivirus pop-up blocking is disabled.

My own machine running Windows 7, Firefox 34.0.5, and Adobe Acrobat X Standard opens .pdfs in-browser just fine, with no problems.

Any advice? I'm pulling my hair out!! Thanks for your time.

kjbgu04

Chosen solution

Hey,

Try the following:

  • Go to setting (3 bars) > options > applications.
  • Under applications panel.
  • Find Portable Document Format (PDF) in the list and click on it to select it.
  • Click on the drop-down arrow in the Action column for the above entry and select Use PDF reader name (in Firefox) or preview in firefox.

If PDF files are still downloaded instead of displayed, try these solutions Reset download actions

  • Open your profile folder:

Click the menu buttonNew Fx Menu, click helpHelp-29and select Troubleshooting Information. The Troubleshooting Information tab will open.

Under the Application Basics section, click on Show Folder. A window with your profile files will open.

Click the menu buttonNew Fx Menuand then click Exit Close 29

Delete the mimetypes.rdf file.

Then open firefox again and see.

I hope it helps.

Read this answer in context 👍 5

All Replies (6)

more options

Chosen Solution

Hey,

Try the following:

  • Go to setting (3 bars) > options > applications.
  • Under applications panel.
  • Find Portable Document Format (PDF) in the list and click on it to select it.
  • Click on the drop-down arrow in the Action column for the above entry and select Use PDF reader name (in Firefox) or preview in firefox.

If PDF files are still downloaded instead of displayed, try these solutions Reset download actions

  • Open your profile folder:

Click the menu buttonNew Fx Menu, click helpHelp-29and select Troubleshooting Information. The Troubleshooting Information tab will open.

Under the Application Basics section, click on Show Folder. A window with your profile files will open.

Click the menu buttonNew Fx Menuand then click Exit Close 29

Delete the mimetypes.rdf file.

Then open firefox again and see.

I hope it helps.

more options

Did all of this, no changes. Still opens a tab that immediately closes, and asks me to save instead. Very frustrating. Installed Acrobat Reader, checked the settings there, no difference. Running Windows 7 Ultimate and Firefox 38.0.5. Any other potential solutions?

more options

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer).

more options

Thanks for the help. Still the same. Doesn't matter if I choose preview in Firefox or Acrobat. Blank tab opens, closes, and then it asks me to save or open. Tried changing settings on both prefs. No difference. Thanks though.

more options

Isn't the internal PDF Viewer able to show PDF files as well?

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Still bombs in safe mode, running the default theme. Changing hardware acceleration setting (and restarting Firefox) does nothing. Same thing happens. PDFs are set to preview in Firefox. Thanks.