Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

I restored Firefox to its default settings but the slowness, crashing and non-responsiveness are not resolved

  • 5 replies
  • 2 have this problem
  • 181 views
  • Last reply by mrento

more options

Hello fellow-users of Firefox,

I followed the advice stated in the Support article about slowness, crashing, etc. by restoring Firefox to its default settings. But the problems didn't go away. The browser remains slow and still gives me error messages about a non-responsive script or plugin and crashes. To make matters worse I don't see the menu items on the top toolbar I was so used to using, like File, Edit, View, etc. I used the View menu very often to zoom in on texts too small for me to read. Now I can't do that. I tried to drag some icons from the menu on the top right-hand corner of the page onto the top tool bar above the address bar, but this is not the same as what I was used to using before, And there are no File, Edit, View, Tools icons in the menu. So now I'm seeing my g-mail inbox in tiny little characters. I tried using the magnifier suggested in the Troubleshooting page of Support, but it's too cumbersome so I gave up.

Would someone kindly please help me out on these issues? Thank you very much in advance.

Regards, Tom Graciano (globmart)

Chosen solution

If zooming serves your problem so just try using it through keyboard. Hold the control (Ctrl) key + '+' to zoom any window. Else if the crashing occurs suddenly So just try to uninstall and reinstall the Firefox with the updated one. As you have made many changes manually, it might be creating problem. So do reinstall it once and check if it serves you.

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

If zooming serves your problem so just try using it through keyboard. Hold the control (Ctrl) key + '+' to zoom any window. Else if the crashing occurs suddenly So just try to uninstall and reinstall the Firefox with the updated one. As you have made many changes manually, it might be creating problem. So do reinstall it once and check if it serves you.

more options

Thank you very much, Saudamini. You helped me solve my problem. Tom

more options

My pleasure!! :)

more options

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

@globmart -- You may notice that, helpfully, Firefox remembers the zoom level for each web site, to minimize the amount of Ctrl-[+] and Ctrl-[-] zooming you have to do. But of course it will forget this info if you reinstall Firefox or use the [Refresh Firefox] button in the about:support window.

Sometimes the File:Edit:View:History... menu is missing because the Menu Bar has become disabled. If the Menu Bar shows when you press and release the [Alt] key, this is what happened. Right-click on the blank area just below the Close ([X]) button in the extreme upper-right of the Firefox window, and a little pop-up menu will show -- then click on "Menu Bar". If the menu bar is not showing, but "Menu Bar" is already checked in that menu... Then the easiest fix to try is to [Refresh Firefox] in the about:support window.

For an article describing all of the customizations which are reset (forgotten) by [Refresh Firefox], see https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings