Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I prevent my addon buttons from being hidden by the "more tools" dropdown when width is above 700px?

  • 9 replies
  • 1 has this problem
  • 38 views
  • Last reply by cor-el

more options

I have several addon buttons in my toolbar to the right of the urlbar. Firefox hides them in a dropdown button labeled "More tools...". I don't want it to do this when it is wide enough, but I can't figure out how to change this behavior. When I enter the customize screen, the button vanishes, and neither it nor any of the buttons it hides appear on any toolbar or in the "additional tools and features" pane.

What I want is that when the window is wider than 700px screen pixels, it shows all buttons. If it gets even wider, then keep stretching the urlbar.

Here's how it looks like now. http://puu.sh/cw3qv/ceebc027c6.png

How can I achieve this?

All Replies (9)

more options

What items are there on the Navigation Toolbar in the more tools drop-down list?

Are there items with a flex attribute or items that are wider then a normal toolbar button?

Did you try to remove some items to see if you can identify a culprit?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thank you for answering. I didn't get e-mail warning about the answer so I didn't know one existed. Anyway, I'm always on the default theme. Safe mode doesn't solve it.

Sounds like this happens when my screen resolution changes to accommodate a game that runs (largest size) 1024x768 (yes, it is some years old)

more options

The problem may be there are too many icons on the tool bar. Remove some, or create another toolbar. Type about:customizing<Enter> in the address bar.

more options

It doesn't work. Even with 3 icons that happens. I've been testing. It only happens when my screen rescales to adjust for the game. Restarting firefox fixes it until the rescale happens again. Firefox, instead of fixing after the rescale back to the original format, it keeps the same way as the very small window size.

Is this a bug?

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

AGAIN?!?! I already did that. See the first answer.

more options

Sorry about that.

Did you try to reset the toolbar customization via Restore Defaults on the Customize page?

more options

yes; still the same

more options

You still haven't told us or show us via a screenshot what is in the more tools overflow area (drop-down list), so it is hard to tell what is going on.

Modified by cor-el