Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox very slow to close (2 - 4 minutes).

  • 36 replies
  • 16 have this problem
  • 270 views
  • Last reply by FredMcD

more options

I have used Firefox for Mac for several years. I have always had my pref set to "Clear History when Firefox closes" Up until version 32, Firefox would close in a few seconds. Now it takes 2 - 4 minutes to close. I have to quit Firefox separately before choosing "Shut Down", otherwise the shut down is stopped.

I have read articles here that suggest that unchecking the preference for clearing history is a "solution". Giving up the automatic clearing of history may solve this problem, but now there is a new problem. Do I need to manually clear history every time before quitting Firefox? That is not a true solution.

In my case, why did this problem start with v. 32?

All Replies (20)

more options

If it takes Firefox that long to shot down, It's a bigger issue then just history.

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences<Enter> in the address bar

Select Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

You can only place a tick for one item at the "Clear history when Firefox closes" settings to seee if you can identify which is causing the problem.

more options

I have been trying the five "Clear History when Firefox Closes" settings individually. ( preferences -> Privacy) So far, just checking a single setting does not cause the delay.

Prior to this test, all five settings were checked. This may be a "combination problem" with the settings. Unfortunately, there are a lot of 2-choice combos.

more options

Before turning off hardware acceleration, will this slow Firefox's performance?

more options

Before turning off hardware acceleration, will this slow Firefox's performance?

Not really. But there are a great many issues cleared with it off. You can always turn it back on later.

more options

Try to leave out only cookies or possibly history (i.e. only uncheck one item)

Note that Firefox will disable the disk cache if you clear the Cache when you close Firefox, see about:cache.

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

more options

Both FredMcD and cor-el know a great deal about this problem. I have decided to turn off "hardware acceleration" and to limit the number of settings for "Clear history when Firefox closes". So far if I use only "clear history', "Active downloads" and "cache" the problem appears to go away.

I will continue to test.

I used to know a lot about computers. But this recent experience demonstrates that I don't really know very much about browsers.

I'm glad you guys were here to help.

Modified by Joe_Heller

more options

After 6 days of testing, the results are unexpected, at least to me.

The "clear history when Firefox closes" settings are: history, cache, and active logins.

Here's what I found out.

1. If I only visit 10 pages, the shut down is very fast, <1 sec.

2. If I visit 50 pages, the shut down takes about 5 sec.

3. If I visit 200 pages, the shut down takes over 1 minute (and aborts the Mac shutdown).

Question: Regardless of how many pages I visit, shouldn't the clearing of history take the same amount of time? Whether it's 1 site or 500, clearing the database should be a simple operation that does not depend on the size of the history file. At least it didn't for v. 31.

more options

Did you notice that the more sites / tabs / windows that were opened, it takes longer for Firefox to shut down? This is because you set the active logins to be removed. Deselect this and test it again.

more options

I understand your point about open windows/tabs.

However, at the end of each day, I manually close all open windows and tabs. I selected "remove active logins" as a way to be sure.

So the tests that I did only had one window open when Firefox was shut down.

I'm going to try each setting separately starting with History. I'll try cache next and then active logins.

more options

You misunderstood my message. Its the clearing active logins that is causing the issue. As far as logging out of a web site, you really don't need to log out of everything. Places like banks, stores, and other high security places you should log out of when you are done on that site. Places like blogs, forums, and such do not require logging out. Also, only that computer is logged on the site. Someone on another computer, even you, would have to log in regardless. As I said in my prior message; Deselect clearing active logins and test it again.

more options

I have had this same problem with Firefox on my Macbook for a while now and I don't understand what happened! I like using Firefox but sometimes it's so slow to shut down it actually times out! I often have to use the Power Down button on the Macbook just to get Firefox to quit! It drives me nuts! Yes I have everything set to clear and I've been told by a tech not to change that, but I need help. I also need to be told what to do to fix this issue in EXTREMELY simple language. THANKS in advance

more options

Try to select only one item at the time in the settings for "Clear history when Firefox closes" to see if you can identify a specific item.

Let all cookies expire when Firefox is closed to make them session cookies.

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"

Create a cookie 'allow' exception for cookies that you would like to keep.

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: Exceptions
more options

Firstly can I say thank you cor-el ; b

Even though you have been very helpful it's still not detailed enough for this here dummy : (

more options

After a lot of testing, I discovered what is causing Firefox so long to quit (at least in my case).

In the preferences for "Use custom settings for history", the only box that I checked was "cache".

After viewing 100 web pages, I quit Firefox. Firefox took about 1 minute to close.

If the cache is simply being disabled, that would not take more than a few seconds, right?

If I uncheck the "cache" box and check all the other boxes, then Firefox quits immediately (after viewing the same 100 pages).

Clearing the cache is causing the delay in quitting.

If I decide to clear the cache, my only viable option is to use the "History-> Clear recent history " option. ("Preferences-> Advanced-> Network preferences" can also be used to clear the cache, but the History option is easier.)

As I said at the beginning, this huge delay did not happen until Firefox 32. Those who wrote the code can figure out what is happening.

You've been a great crowd! Thank you and good night!

Modified by Joe_Heller

more options

See if this is better;

Empty Cache Button {web link} Cache clearing made easy. One click.

more options

Thanks for the "Empty Cache Button" link.

On the author's website, it states:

"There will be two versions coming out in near future: - 2.8 (the last of the 2.* series, covering FX 2.0 to FX 31.0) - 3.0 (new 3.* series, covering FX 32.0 and later)"

Do you know when version 3.0 will be released?

more options

This is the first I heard of it. It will come when it will come.

more options

As I said at the beginning, this huge delay did not happen until Firefox 32. Those who wrote the code can figure out what is happening.

Reading release notes is recommended, unfortunately only few people do it. https://www.mozilla.org/en-US/firefox/32.0/releasenotes

I don't know why anyone would want to clear the cache every time Firefox is shut down. In that case not using the cache at all would be a better strategy. Alternatively you can use private mode.

more options

Thank you Joe_Heller : )

  1. 1
  2. 2