Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Some Unicode characters are not displaying properly

  • 4 replies
  • 11 have this problem
  • 26170 views
  • Last reply by jscher2000

more options

I run into this mostly on Diaspora*, Gihub, and Wordpress sites. I either get the standard block character or something I've never seen before.

see https://imgur.com/a/r5rvk for examples

Chosen solution

Let's check on Github. If you open a page on Github, then open the Web Console (Ctrl+Shift+k), the reload the page bypassing cache (Ctrl+Shift+r), Firefox should load the Octicons font. You can use the filter box on the upper right of the console to look for it and confirm that it was downloaded successfully (200 status). I have attached a screen shot showing a sample result.

Oh, I just realized you use NoScript. NoScript will block font downloads from untrusted sites, and possibly also trusted sites, so you might check the menu and look for "Blocked Objects" to see whether the font is blocked there.

Edit: Our posts crossed. You beat me to it. See http://hackademix.net/2010/03/24/why-noscript-blocks-web-fonts/

Read this answer in context 👍 2

All Replies (4)

more options

Many sites have started using custom fonts (downloadable fonts) for icons instead of image files. If Firefox can't get the font, and doesn't have a local match, it shows the character code in a tall box.

Do you know whether downloadable fonts generally work on other sites, so it's just a problem with those sites, or could it be that Firefox isn't using downloadable fonts at all?

The first requirement is that you let sites use their own fonts. This is set in the Options/Preferences dialog, Content panel, Advanced Font settings. So either:

  • "3-bar" menu button > Options > Content > Advanced button
  • Edit menu > Preferences > Content > Advanced button

Make sure the box is checked to "Allow pages to choose their own fonts".


There also is a hidden setting to block font downloading. This normally would not be blocked, but some users with enormous font collections discovered that Firefox will freeze up for a minute the first time it visited a page that used downloadable fonts, so in those cases they might have turned it off. Does that sound familiar at all?

more options

Sites seem to be able to use their own fonts, yes. And I have Firefox se to allow sites to choose their own fonts.

I guess it's possible that sites aren't downloading their own fonts. Sans Serif is pretty popular. How might I check this?

more options

Got it!

It was a function of NoScript to block some fonts. Switch that to "false" in about:config and it works!

go to about:config

search noscript.forbidFonts

toggle to "False"

Not sure why that's blocked by NoScript. I guess I should look into that.

more options

Chosen Solution

Let's check on Github. If you open a page on Github, then open the Web Console (Ctrl+Shift+k), the reload the page bypassing cache (Ctrl+Shift+r), Firefox should load the Octicons font. You can use the filter box on the upper right of the console to look for it and confirm that it was downloaded successfully (200 status). I have attached a screen shot showing a sample result.

Oh, I just realized you use NoScript. NoScript will block font downloads from untrusted sites, and possibly also trusted sites, so you might check the menu and look for "Blocked Objects" to see whether the font is blocked there.

Edit: Our posts crossed. You beat me to it. See http://hackademix.net/2010/03/24/why-noscript-blocks-web-fonts/

Modified by jscher2000