X
Tap here to go to the mobile version of the site.

Support Forum

How can I prevent Firefox from automatically updating?

Posted

Hello,

I am trying to prevent Firefox 28 from automatically updating to Firefox 29 (on OSX 10.7.5).

I have the option "Never check for updates" checked under 'Update' in the 'Advanced' Preferences. I have "Automatically update Search Engines" unchecked. I have uninstalled Firefox 29 completely using two separate uninstall clean-up kits and emptied the trash before re-installing Firefox 28... Yet every time I finally re-arrange, customize and re-sync Firefox 28 back to the way I like it, I restart my Mac and Firefox 29 rears it's over-drawn, bubbly, space-wasting, UN-SYNCED, ridiculous tabs on top nonsense user interface.

I've tried to work with Firefox 29 but the new SYNC simply does not work and that's a deal breaker. I need the changes I make on my mac to be reflected across the other two systems on my desk (one WinXP, one Win7) and vice versa. When I try to sync on FF29 it takes me to a page to log in and then refuses to recognize my email and password (which I have thoroughly confirmed on my other systems as correct).

Can you please help me prevent Firefox 28 from automatically updating to Firefox 29?

Hello, I am trying to prevent Firefox 28 from automatically updating to Firefox 29 (on OSX 10.7.5). I have the option "Never check for updates" checked under 'Update' in the 'Advanced' Preferences. I have "Automatically update Search Engines" unchecked. I have uninstalled Firefox 29 completely using two separate uninstall clean-up kits and emptied the trash before re-installing Firefox 28... Yet every time I finally re-arrange, customize and re-sync Firefox 28 back to the way I like it, I restart my Mac and Firefox 29 rears it's over-drawn, bubbly, space-wasting, UN-SYNCED, ridiculous tabs on top nonsense user interface. I've tried to work with Firefox 29 but the new SYNC simply does not work and that's a deal breaker. I need the changes I make on my mac to be reflected across the other two systems on my desk (one WinXP, one Win7) and vice versa. When I try to sync on FF29 it takes me to a page to log in and then refuses to recognize my email and password (which I have thoroughly confirmed on my other systems as correct). Can you please help me prevent Firefox 28 from automatically updating to Firefox 29?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 5.3.1.18536
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Provides communication between running browsers and Sheep Systems bookmarks management applications.
  • Facebook Video Calling by Skype
  • iPhoto6
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 5.1.20913.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • LogMeIn remote control components
  • Speed Download Plugin. Allows downloads to be redirected to Speed Download

Application

  • Firefox 29.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support URL: https://support.mozilla.org/1/firefox/29.0/Darwin/en-US/

Extensions

  • Abduction! 3.5.0 ({b0e1b4a6-2c6f-4e99-94f2-8e625d7ae255})
  • Adblock Plus 2.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net)
  • Add Google Search To New Tab Page 1.0.2 (newtabgoogle@graememcc.co.uk)
  • Bookmark Favicon Changer 1.74 (bookmarkfaviconchanger@sonthakit)
  • Classic Theme Restorer 1.1.8 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Custom New Tab 1.8.1 (CNT@ednovak.net)
  • Customizable Shortcuts 0.6.2 (customizable-shortcuts@timtaubert.de)
  • Flash and Video Download 1.55 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Flash Video Downloader - Full HD Download 5.9.1 (artur.dubovoy@gmail.com)
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Google Translator for Firefox 2.1.0.3m (translator@zoli.bod)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • Pocket 3.0.4 (isreaditlater@ideashower.com)
  • QuickDrag 2.1.3.23 (quickdrag@mozilla.ktechcomputing.com)
  • QuickToolbars 1.1.5 (quick@toolbars.be)
  • Rights To Close 1.0.4 (shan.developer@gmail.com)
  • Sheep Systems Firefox Extension 311 (firefoxextension@sheepsystems.com)
  • Tab Mix Plus 0.4.1.3.1 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • UnPlug 2.056 (unplug@compunach)
  • User Agent Overrider 0.2.3 (useragentoverrider@qixinglu.com)
  • Adobe Contribute Toolbar 6.0 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 407
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 8600M GT OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.search.openintab: True
  • browser.search.update: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140414143035
  • browser.startup.homepage: google.ca
  • browser.startup.homepage_override.buildID: 20140414143035
  • browser.startup.homepage_override.mstone: 29.0
  • browser.tabs.drawInTitlebar: False
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • browser.tabs.selectOwnerOnClose: False
  • browser.tabs.warnOnClose: False
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1400367724
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1400285986

Misc

  • User JS: No
  • Accessibility: No
Moses
  • Moderator
459 solutions 3607 answers

Thank you for trying the new Firefox. I'm sorry that you’re unhappy with the new design.

I understand your frustration and surprise at the removal of these features but I can't undo these changes. I'm just a support volunteer and I do not work for Mozilla. But you can send any feedback about these changes to http://input.mozilla.org/feedback. Firefox developers collect data submitted through there then present it at the weekly Firefox meeting

I recommend you try to adjust to 29 and see if you can't make it work for you before you downgrade to a less secure and soon outdated version of Firefox.

Here are a few suggestions for restoring the old design. I hope you’ll find one that works for you:


If you hate it that much, There was a previous way by going through the Options menu to disable updates but after disabling it through there, when you would go to Help > About Firefox, it would update regardless of that setting.

You can set these prefs in about:config to disable automatic updating:
app.update.auto - false
app.update.enabled - false
app.update.silent - false

Thank you for trying the new Firefox. I'm sorry that you’re unhappy with the new design. I understand your frustration and surprise at the removal of these features but I can't undo these changes. I'm just a support volunteer and I do not work for Mozilla. But you can send any feedback about these changes to http://input.mozilla.org/feedback. Firefox developers collect data submitted through there then present it at the weekly Firefox meeting I recommend you try to adjust to 29 and see if you can't make it work for you before you downgrade to a less secure and soon outdated version of Firefox. Here are a few suggestions for restoring the old design. I hope you’ll find one that works for you: *Use the [https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ Classic Theme Restorer] to bring back the old design. Learn more here: [[How to make the new Firefox look like the old Firefox]] *Use the [https://addons.mozilla.org/en-US/firefox/addon/the-addon-bar/ Add-on Bar Restored] to bring back the add-on bar. Learn more here: [[What happened to the Add-on Bar?]] If you hate it that much, There was a previous way by going through the Options menu to disable updates but after disabling it through there, when you would go to Help > About Firefox, it would update regardless of that setting. You can set these prefs in <code>about:config</code> to disable automatic updating:<br> app.update.auto - false<br> app.update.enabled - false<br> app.update.silent - false<br>

Question owner

Hi Moses, Thanks for your rapid attempt to help, I do appreciate it.

Yes, I confirmed those settings in about:config they all read just as you posted: app.update.auto - false app.update.enabled - false app.update.silent - false

...I checked them before I restarted and indeed, they're STILL all set to false even after the update!... and no, I didn't touch the 'check for updates' button in 'About Firefox'.

I'm aware of the security risks and because of that, I have put in a good deal of time trying to adapt to FF29, including using the Classic Theme Restorer to re-position the tabs close to the page content where it makes sense to me and trim the bloat around the bars and icons... but as I noted, the deal-breaker for me is that SYNC just does not work in Firefox 29. The changes I make on this system aren't reflected in my other synced Firefox installations on my other systems (nor theirs on this one) and when I press the sync button on this browser, I am sent to a sign-in page where I'm asked for my email and password and then presented with the error message "unknown account. Sign up". And if I click on 'Forgot Password?', I'm taken to a 'reset password' page ...but when I enter my email there, I get the error message 'unknown account'. And then that's it. What else can I possibly do? I know it's the correct information, I'm looking right at the sync account info on the other systems.

It's driving me batty... worse, it's pushing my Chrome-y.

Any other ideas you can suggest would be most welcome... thanks again.

Hi Moses, Thanks for your rapid attempt to help, I do appreciate it. Yes, I confirmed those settings in about:config they all read just as you posted: app.update.auto - false app.update.enabled - false app.update.silent - false ...I checked them before I restarted and indeed, they're STILL all set to false even after the update!... and no, I didn't touch the 'check for updates' button in 'About Firefox'. I'm aware of the security risks and because of that, I have put in a good deal of time trying to adapt to FF29, including using the Classic Theme Restorer to re-position the tabs close to the page content where it makes sense to me and trim the bloat around the bars and icons... but as I noted, the deal-breaker for me is that '''SYNC just does not work in Firefox 29'''. The changes I make on this system aren't reflected in my other synced Firefox installations on my other systems (nor theirs on this one) and when I press the sync button on this browser, I am sent to a sign-in page where I'm asked for my email and password and then presented with the error message "unknown account. Sign up". And if I click on 'Forgot Password?', I'm taken to a 'reset password' page ...but when I enter my email there, I get the error message 'unknown account'. And then that's it. What else can I possibly do? I know it's the correct information, I'm looking right at the sync account info on the other systems. It's driving me batty... worse, it's pushing my Chrome-y. Any other ideas you can suggest would be most welcome... thanks again.
Moses
  • Moderator
459 solutions 3607 answers

This might be a long shot, but when you made your first Sync account, was it on previous versions of Firefox such as 28 or further? If you did, you need to upgrade your Sync account to use the new Sync system in Firefox 29.

This might be a long shot, but when you made your first Sync account, was it on previous versions of Firefox such as 28 or further? If you did, you need to upgrade your Sync account to use the new Sync system in Firefox 29. *https://support.mozilla.org/en-US/kb/how-to-update-to-the-new-firefox-sync
BahtSimpson 2 solutions 17 answers

Helpful Reply

WHAT GIVES MOZILLA THE RIGHT TO FORCE USERS TO UPDATE TO VERSION 29?

How dare you install programs on my computer without my permission?

I don't want it. I don't like it. I will take care of "security".

MOZILLA IS NOW IN THE SAME CLASS AS MICROSOFT FOR NOT CARING WHAT THEIR USERS WANT.

Congratulations.

WHAT GIVES MOZILLA THE RIGHT TO FORCE USERS TO UPDATE TO VERSION 29? How dare you install programs on my computer without my permission? I don't want it. I don't like it. I will take care of "security". MOZILLA IS NOW IN THE SAME CLASS AS MICROSOFT FOR NOT CARING WHAT THEIR USERS WANT. Congratulations.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 158993 answers

You can look at the Classic Theme Restorer extension to restore some functionality that was lost with the arrival of the Australis style in Firefox 29.

  • You can check out the settings of the CTR extension via its Options/Preferences button on the "Firefox/Tools > Add-ons > Extensions" page.
  • You can find extra toolbar buttons and more toolbar settings in Customize (3-bar Firefox menu button > Customize)

See also:


You can move the tabs to the lower position just above the browsing area without using an extension with code in userChrome.css as basically you only need to give the Tab bar a higher -moz-box-ordinal-group value (most toolbars have a default -moz-box-ordinal-group:1 to show them in DOM order).

You can look at the Classic Theme Restorer extension to restore some functionality that was lost with the arrival of the Australis style in Firefox 29. *Classic Theme Restorer: https://addons.mozilla.org/firefox/addon/classicthemerestorer/ *You can check out the settings of the CTR extension via its Options/Preferences button on the "Firefox/Tools > Add-ons > Extensions" page. *You can find extra toolbar buttons and more toolbar settings in Customize (3-bar Firefox menu button > Customize) ---- See also: *https://support.mozilla.org/kb/how-to-make-new-firefox-look-like-old-firefox *https://support.mozilla.org/kb/common-questions-after-updating-to-new-firefox *https://support.mozilla.org/kb/learn-more-about-the-design-of-new-firefox ---- You can move the tabs to the lower position just above the browsing area without using an extension with code in userChrome.css as basically you only need to give the Tab bar a higher -moz-box-ordinal-group value (most toolbars have a default -moz-box-ordinal-group:1 to show them in DOM order). *[[/questions/997353]] How can I put the Tabs back below the navigation bar?
BahtSimpson 2 solutions 17 answers

Helpful Reply

Thank you for your comments, cor-el.

Yes, I know about Classic Theme Restorer, but the point is what gives Mozilla the right to update my Firefox when I already have quite clearly set every option to prevent automatic updates?

I have set:

app.update.auto - false app.update.enabled - false app.update.silent - false

So which secret magic setting has Mozilla used to bypass all these settings and what gives them the right to do it?

Also, moving the tabs bar and menu bar and whatever else has been moved in Firefox 29 is a THEME change. It is not a security fix. Mozilla should not be in the business of changing the theme or look of Firefox. It is not their business how I want my Firefox to look.

Regarding "tabs", I have mine down the left side, so this tweaking of the tab bar position is pointless anyway.

To Mozilla, Just for absolute clarification, there is no way you can possibly justify forcing an update on users computers without their explicit acceptance.

What if someone found out how Mozilla forced the update? They could then force an update that is NOT a genuine Firefox release and do untold damage to peoples' computers.

So now I am forced to delete Firefox from my startup script and start it manually just in case their is another forced update that I can stop.

To cor-el, thank you for your post. To Mozilla, you have lost the plot.

Thank you for your comments, cor-el. Yes, I know about Classic Theme Restorer, but the point is what gives Mozilla the right to update my Firefox when I already have quite clearly set every option to prevent automatic updates? I have set: app.update.auto - false app.update.enabled - false app.update.silent - false So which secret magic setting has Mozilla used to bypass all these settings and what gives them the right to do it? Also, moving the tabs bar and menu bar and whatever else has been moved in Firefox 29 is a THEME change. It is not a security fix. Mozilla should not be in the business of changing the theme or look of Firefox. It is not their business how I want my Firefox to look. Regarding "tabs", I have mine down the left side, so this tweaking of the tab bar position is pointless anyway. To Mozilla, Just for absolute clarification, there is no way you can possibly justify forcing an update on users computers without their explicit acceptance. What if someone found out how Mozilla forced the update? They could then force an update that is NOT a genuine Firefox release and do untold damage to peoples' computers. So now I am forced to delete Firefox from my startup script and start it manually just in case their is another forced update that I can stop. To cor-el, thank you for your post. To Mozilla, you have lost the plot.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40306 answers

If you're on a Windows PC see this:
https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service

At the bottom see - Note: You can also uninstall the Mozilla Maintenance Service from the Windows Control Panel.

If you're on a Windows PC see this: <br /> https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service At the bottom see - Note: You can also uninstall the Mozilla Maintenance Service from the Windows Control Panel.
BahtSimpson 2 solutions 17 answers

Thank you very much, the-edmeister, for your email with the link back to this topic.

The link you give in your post above says to uncheck the box in Options / Advanced / Update tab that is labelled "Use a background service to install updates".

Guess what? It was already unchecked!

Also, the box "Never check for updates" WAS checked.

So, basically, Mozilla are bypassing and ignoring all these options that the user has specified and has used the Mozilla Maintenance Service to install what THEY regard as an important update.

This is completely unacceptable.

If you have any influence, maybe you can tell them what I think.

I will now remove the Maintenance Service from my computer.

Thank you very much for the information.

Thank you very much, the-edmeister, for your email with the link back to this topic. The link you give in your post above says to uncheck the box in Options / Advanced / Update tab that is labelled "Use a background service to install updates". Guess what? It was already unchecked! Also, the box "Never check for updates" WAS checked. So, basically, Mozilla are bypassing and ignoring all these options that the user has specified and has used the Mozilla Maintenance Service to install what THEY regard as an important update. This is completely unacceptable. If you have any influence, maybe you can tell them what I think. I will now remove the Maintenance Service from my computer. Thank you very much for the information.
meegja 10 solutions 149 answers

Same here: Firefox 28 with all automatic update things disabled. Yet the Firefox 29 update is just as easily downloaded and installed without my permission.

Same here: Firefox 28 with all automatic update things disabled. Yet the Firefox 29 update is just as easily downloaded and installed without my permission.

Modified by meegja

BahtSimpson 2 solutions 17 answers

But of course. The people at Mozilla know better than you, so why are you complaining about them ignoring your personal preferences and installing what they KNOW is best for YOU!

Seriously, put this in user.js:

// turn off application updates: user_pref("app.update.enabled", false);

Also, remove "Mozilla Maintenance Service".

But of course. The people at Mozilla know better than you, so why are you complaining about them ignoring your personal preferences and installing what they KNOW is best for YOU! Seriously, put this in user.js: // turn off application updates: user_pref("app.update.enabled", false); Also, remove "Mozilla Maintenance Service".
trophyjoe 0 solutions 2 answers

I was able to prevent automatic updates, using the following, all of which came from this discussion. I'm running Windows 8.1, if that matters.

1. Backup the profile folder. (Not really necessary, but why not?)

2. Uninstall FF (any and all versions)

3. Reinstall FF28, but use advanced option and deselect the option about using background service for updating.

4. Uncheck the "run firefox" box before the installation begins.

5. Without running FF, make BahtSimpson's change to "user.js". I.E.: user_pref("app.update.enabled", false); Originally, I edited "pref.js" because there was no "user.js" in my profile. According to Mozilla, one should not edit "pref.js"; but you can create a "user.js" and put this code in there.

https://developer.mozilla.org/en-US/docs/Mozilla/Preferences/A_brief_guide_to_Mozilla_preferences

6. Confirm there is no update service installed. There was none on my machine. Uninstall it if it's there (in Control Panel\Programs and Features). I also checked running services by doing a WIN-R and entering [services.msc], don't type the brackets. If there is a Mozilla update service, and there should not be, simply disable it.

7. Now and only now, run FF28; you should see no update prompt and no unrequested downloading.

Hope this helps.

I was able to prevent automatic updates, using the following, all of which came from this discussion. I'm running Windows 8.1, if that matters. 1. Backup the profile folder. (Not really necessary, but why not?) 2. Uninstall FF (any and all versions) 3. Reinstall FF28, but use advanced option and deselect the option about using background service for updating. 4. Uncheck the "run firefox" box before the installation begins. 5. Without running FF, make BahtSimpson's change to "user.js". I.E.: ''user_pref("app.update.enabled", false); '' Originally, I edited "pref.js" because there was no "user.js" in my profile. According to Mozilla, one should not edit "pref.js"; but you can create a "user.js" and put this code in there. https://developer.mozilla.org/en-US/docs/Mozilla/Preferences/A_brief_guide_to_Mozilla_preferences 6. Confirm there is no update service installed. There was none on my machine. Uninstall it if it's there (in Control Panel\Programs and Features). I also checked running services by doing a WIN-R and entering [services.msc], don't type the brackets. If there is a Mozilla update service, and there should not be, simply disable it. 7. Now and only now, run FF28; you should see no update prompt and no unrequested downloading. Hope this helps.

Modified by trophyjoe

BahtSimpson 2 solutions 17 answers

Nice post, trophyjoe.

Could add: also put in "user.js":

// turn off application updates: user_pref("app.update.enabled", false);

The preferences in user.js override those in prefs.js.

(At least, they used to: https://developer.mozilla.org/en-US/docs/Mozilla/Preferences/A_brief_guide_to_Mozilla_preferences )

Nice post, trophyjoe. Could add: also put in "user.js": // turn off application updates: user_pref("app.update.enabled", false); The preferences in user.js override those in prefs.js. (At least, they used to: https://developer.mozilla.org/en-US/docs/Mozilla/Preferences/A_brief_guide_to_Mozilla_preferences )
trophyjoe 0 solutions 2 answers

I edited my answer to reflect this. Thanks for the link.

I edited my answer to reflect this. Thanks for the link.