Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Natao arisiva ity resaka mitohy ity. Mametraha fanontaniana azafady raha mila fanampiana.

userChrome.css broken in FF 10.0.2 and Nightly 13.0a1?

  • 2 valiny
  • 1 manana an'ity olana ity
  • 20 views
  • Valiny farany nomen'i sctl

more options

I noticed with the FF 10.0.2 update that userChrome.css is no longer being applied. To test, I created a new profile with no addons or extensions, and a single modified CSS value (to opacify the titlebar) in userChrome.css. It doesn't work as usual or expected (no result at all). I noticed that Nightly 13.0a1 is also affected. Here's the one CSS value I pared the userChrome down to:

#TabsToolbar {
 background-color: -moz-dialog !important;
}

Thanks

I noticed with the FF 10.0.2 update that userChrome.css is no longer being applied. To test, I created a new profile with no addons or extensions, and a single modified CSS value (to opacify the titlebar) in userChrome.css. It doesn't work as usual or expected (no result at all). I noticed that Nightly 13.0a1 is also affected. Here's the one CSS value I pared the userChrome down to:<br /> <br /> <pre><nowiki>#TabsToolbar { background-color: -moz-dialog !important; } </nowiki></pre> Thanks

Novain'i cor-el t@

Vahaolana nofidina

That tab bar already has that background-color: -moz-dialog !important; rule, but there is another rule that sets a background-image

background-image: -moz-linear-gradient(50% 100%, rgba(0, 0, 0, 0.3) 1px, rgba(0, 0, 0, 0.05) 1px, transparent 50%);

You probably need to add a -moz-appearance: none !important; rule and may also need to disable background images or set a different background image instead.


See line 27 and line 1429 in:

  • chrome://browser/skin/browser.css
Hamaky an'ity valiny ity @ sehatra 👍 1

All Replies (2)

more options

Vahaolana Nofidina

That tab bar already has that background-color: -moz-dialog !important; rule, but there is another rule that sets a background-image

background-image: -moz-linear-gradient(50% 100%, rgba(0, 0, 0, 0.3) 1px, rgba(0, 0, 0, 0.05) 1px, transparent 50%);

You probably need to add a -moz-appearance: none !important; rule and may also need to disable background images or set a different background image instead.


See line 27 and line 1429 in:

  • chrome://browser/skin/browser.css
more options

Thanks cor-el, sorry it took me so long. You are spot on, as usual!