Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Natao arisiva ity resaka mitohy ity. Mametraha fanontaniana azafady raha mila fanampiana.

Firefox 3.6.15 says QuickTime is obsolete, but latest QT 769 won't install

  • Tsisy valiny
  • 32 manana an'ity olana ity
  • 17 views
more options

I have just upgraded Firefox to 3.6.15. And my plugin check again says I need to update my outdated QuickTime Plugin 7.6.3. So I downloaded this and tried to install, but new QuickTime 7.6.9 says it's only for Leopard, NOT Snow Leopard. And the installer refused saying QuickTime X is already installed.

I have looked at support question https://support.mozilla.com/en-US/questions/709867?

but /Library/Internet Plug-Ins says I have QT version 7.6.6. Which mean my QuickTime is indeed outdated...

So why does Firefox 3.6.15 say I need QuickTime Plugin 7.6.3 upgraded, when I have 7.6.6 installed. Yet latest QuickTime 7.6.9 won't install.

Should I actually delete the Firefox QT 7.6.3 plugin since it seems Snow Leopard handles things differently anyway?

I have read link https://support.mozilla.com/en-US/kb/Using%20the%20QuickTime%20plugin%20with%20Firefox?s=quicktime&as=s

and a QuickTime movie on the Apple Events page does play. But this QT support page specifically says its info is invalid for Snow Leopard now at 10.6.7. Can we get updated info please...

Help!

I have just upgraded Firefox to 3.6.15. And my plugin check again says I need to update my outdated QuickTime Plugin 7.6.3. So I downloaded this and tried to install, but new QuickTime 7.6.9 says it's only for Leopard, NOT Snow Leopard. And the installer refused saying QuickTime X is already installed. I have looked at support question https://support.mozilla.com/en-US/questions/709867? but /Library/Internet Plug-Ins says I have QT version 7.6.6. Which mean my QuickTime is indeed outdated... So why does Firefox 3.6.15 say I need QuickTime Plugin 7.6.3 upgraded, when I have 7.6.6 installed. Yet latest QuickTime 7.6.9 won't install. Should I actually delete the Firefox QT 7.6.3 plugin since it seems Snow Leopard handles things differently anyway? I have read link https://support.mozilla.com/en-US/kb/Using%20the%20QuickTime%20plugin%20with%20Firefox?s=quicktime&as=s and a QuickTime movie on the Apple Events page does play. But this QT support page specifically says its info is invalid for Snow Leopard now at 10.6.7. Can we get updated info please... Help!

Novain'i CrisBCT t@