Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Natao arisiva ity resaka mitohy ity. Mametraha fanontaniana azafady raha mila fanampiana.

Firefox refuses to take me to the home page of my choice.

  • 6 valiny
  • 3 manana an'ity olana ity
  • 21 views
  • Valiny farany nomen'i Aardvark99

more options

I have been using earlier versions of Firefox, the most recent was the ESR, all of which would happily take me to my preferred home page Google.co.uk. After deciding to try Quantum it will only take me to Google.fr. I can switch to English by clicking on a button below the search box but I would prefer to have Firefox take me there as soon as it opens. I have repeatedly reset my home page to Google.co.uk but it changes nothing, taking me only to Google.fr.

I have been using earlier versions of Firefox, the most recent was the ESR, all of which would happily take me to my preferred home page Google.co.uk. After deciding to try Quantum it will only take me to Google.fr. I can switch to English by clicking on a button below the search box but I would prefer to have Firefox take me there as soon as it opens. I have repeatedly reset my home page to Google.co.uk but it changes nothing, taking me only to Google.fr.

All Replies (6)

more options

Hi, hold down the Shift key when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it works in Safe Mode, disable any theme or add-ons - Add-ons Manager (Ctrl+Shift+A) > Themes/Extensions and restart Firefox; then if it's OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some add-ons.

If that doesn't help, have a look on the Google results page > Settings > Languages.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

more options

Thankyou for your suggestion but it was only useful inasmuch as I wasn't aware of a Firefox Safe Mode. It could be useful in the future. My preference for my home page is still correct in my Options but Firefox just doesn't take me there. I have discovered that if I use a VPN set to UK then Google will open correctly. I guess that is a fix of sorts but doesn't really address the question of why all my previous versions of Firefox didn't need a VPN to work properly. I may just reinstall the old ESR version as I don't find Quantum of any particular advantage.

more options

Are you located in France?

What Firefox language version do you use?

Does it make a difference if you set en-gb as the first language?

more options

Yes, I am located in France. My OS and all my installed software is set with UK English as default. I have just installed Opera and the problem does not appear. I can go straight to Google.co.uk when the browser is opened. Firefox will no longer do it.

more options

I find that odd if you set the homepage it shouldn't change unless your ISP does the settings for you. I think it has more to do with a bad install possibly did you uninstall all FF and delete the Mozilla folder and reinstall to see what happens?

more options

Yes. It was a clean install. I have since posted this problem on another (non-technical) forum and other people have had the same problem.