Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Natao arisiva ity resaka mitohy ity. Mametraha fanontaniana azafady raha mila fanampiana.

How on earth is it possible that Firefox uses 40% of my RAM, doing absolutely NOTHING?

  • 6 valiny
  • 1 manana an'ity olana ity
  • 3 views
  • Valiny farany nomen'i FredMcD

more options

I start Firefox and my RAM usage immediately goes to 40%. No other apps open, all Firefox add-ons disabled, no sites open in tabs, nothing. I have 3 Gig RAM, that's not much, but it's more than sufficient for browsers like Chrome and Opera. I really prefer Firefox, but as soon as I have just two tabs open, my RAM goes to 90% and my CPU usage goes to at least 80%. It then doesn't take long till it crashes. Although the Crash-report "promises" feedback, I never ever got any. . .

I realize Firefox is a free app, so perhaps I shouldn't be complaining, but hey, all browsers are free these days and I would hate to go back to Chrome.

What can I do to reduce Firefox's use of resources? As I'm typing this it is using 250,000 K of RAM, basically doing nothing, accept keeping this one support-tab open.

All Replies (6)

more options

Hello, Try these easy fixes https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram report us back.

more options

Sorry, didn't work. Just tried the same configuration with Chrome and it's very fast, using half of the resources.

more options

Thunderbird has exactly the same problem, compared to Outlook, it must a Mozilla thing, I'm afraid.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Already manipulated all settins and all of my extensions/add-ons. What seems to give some "relieve" is disabling my Okay Freedom VPNS add-on, I guess because it works as a proxy.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?