Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Natao arisiva ity resaka mitohy ity. Mametraha fanontaniana azafady raha mila fanampiana.

Firefox crashes consistently in gmail.

  • 9 valiny
  • 12 manana an'ity olana ity
  • 70 views
  • Valiny farany nomen'i Jamesdaley

more options

Crash shortly after displaying gmail inbox. Also on many pages from guardian.co.uk. Occurs in safe mode. Have tried clearing cache, cookies, site preferences etc. with no help. Firefox 30.0 Kubuntu 14.10 fully patched to date.

Crash report bp-cefad394-2054-4c5a-b2f0-d4da42141130

Crash shortly after displaying gmail inbox. Also on many pages from guardian.co.uk. Occurs in safe mode. Have tried clearing cache, cookies, site preferences etc. with no help. Firefox 30.0 Kubuntu 14.10 fully patched to date. Crash report bp-cefad394-2054-4c5a-b2f0-d4da42141130

Vahaolana nofidina

You can also try to disable GStreamer support for the HTML5 media player.

  • about:config page: media.gstreamer.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Hamaky an'ity valiny ity @ sehatra 👍 6

All Replies (9)

more options

I also have the problem on version 34b from PPA

more options

That crash has a signature which matches 49 reports during the past 28 days, all amd64-based systems running Linux (see https://crash-stats.mozilla.com/repor.../list?product=Firefox&range_unit=days&range_value=28&signature=libc-2.19.so%400x36d27#tab-sigsummary). It's a fairly rare crash and unfortunately not much information is available to the volunteers here from those reports.

The Safe Mode test ruled out the most common issues, so my next thought is to take the most common plugin out of the equation. You can set Flash to click-to-play so that sites can load without it. You probably will need to activate it to watch videos, but on those sites that only use it for analytics, advertising, and local storage, you might not need to activate it.

To conduct this test, open the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then find "Shockwave Flash" and change the default permission to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

I suggest keeping Flash disabled as much as possible until you determine whether it is making any difference. Does it?

more options

Disabling plugins (even all of them) doesn't help, I'm afraid.

more options

Do Gmail and Guardian get far enough to display a plugin approval notification, or crash before that point?

Hopefully a Linux expert will recognize something in your crash report(s) that I don't see.

more options

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Vahaolana Nofidina

You can also try to disable GStreamer support for the HTML5 media player.

  • about:config page: media.gstreamer.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Novain'i cor-el t@

more options

jscher2000 : I was concentrating on the gmail issue where there was no visible plugin request. I did finally find a crashing grauniad page and yes - I did need to approve the plugin to play.

cor-el : The bad news is that OMTC was disabled BUT disabling Gstreamer support seems to have done the trick so you probably get the cigar. I shall continue to test before marking as solved.

more options

I nearly missed libgstlibav.so in the crashing thread.

  • bp-cefad394-2054-4c5a-b2f0-d4da42141130

Make sure that you have the latest updates for GStreamer.

more options

I am rather at the mercy of the packagers here but am up-to-date for the distro.

Thanks both for the amazing quick responses.