Can't Print Email

I can't print an email. The whole screen prints and is too small to read. I read previous answers to use the drop down menu and select print, but then I get window that… (read more)

I can't print an email. The whole screen prints and is too small to read.

I read previous answers to use the drop down menu and select print, but then I get window that says I have a blocking the print. I don't have an active blocker. I do have malwarebytes. Never had any trouble printing on chrome or safari.

Asked by Linda Andruska Prieš 2 valandas

Firefox browser

Since Firefox updated? a week ago we have lost our browser and can not install a new setup. The cursor freezes before we can finish the new install. Any ideas for what … (read more)

Since Firefox updated? a week ago we have lost our browser and can not install a new setup. The cursor freezes before we can finish the new install. Any ideas for what to do? We did like Firefox before they fixed? it and we lost use. Thank You.

Asked by debiggar Prieš 3 valandas

Firefox Web Notifications are interrupting typing

I just recently had Firefox updated, and I'm already having problems regarding notifications. When a notification starts up while I'm typing, it takes me out of it and I … (read more)

I just recently had Firefox updated, and I'm already having problems regarding notifications. When a notification starts up while I'm typing, it takes me out of it and I have to click back in. I had to turn them off temporarily to avoid flow breaking. This never ever happened before the update as the notifs worked perfectly fine w/ no interrupting. I also noticed in the taskbar, each notification is treated like a new browser window for some reason. This may be related to my current issue.

Asked by dyl-pickle2 Prieš 6 dienas

Last reply by jscher2000 - Support Volunteer Prieš 3 valandas

My startup's webgl app lags in FireFox, unless I profile with screenshots on

I am a startup founder. I'm making a webgl rendering engine. I'm doing a stress test with 4 large paragraphs amounting to tens of millions of triangles on a macbook air. … (read more)

I am a startup founder. I'm making a webgl rendering engine. I'm doing a stress test with 4 large paragraphs amounting to tens of millions of triangles on a macbook air. Firefox is on the latest version.

When I run the app in chrome/safari/opera, the performance is normal. ~45fps. But in Firefox, it's very slow. My FPS counter (in a requestAnimationFrame loop) says ~45fps on all browsers. But in Firefox, even though the counter says that, the real frame rate is ~3-5fps.

When I try to profile, the problem magically goes away and we're back to ~45fps. I played around with profiler settings, and the key determinant is whether or not I'm taking screenshots. No screenshots = slow. Screenshots = fast.

In the flame graph, in slow mode (no screenshots), it seems like I get stuck in the canvasRenderer and the Renderer mostly waits for it. But in fast mode (with screenshots), the canvasRenderer keeps up and the Renderer spents most it's time in: iokit_user_client_trap

I'm not sure what to do. This is only a problem on Firefox. There's some sort of gpu/threads/something that switches when I profile with screenshots that makes it way faster. This performance hit basically ruins my app for Firefox only. Any idea what I should do?

Asked by Ben Shumaker Prieš 6 valandas

Last reply by TyDraniu Prieš 4 valandas

Twitter notifications problems

I have a problem with firefox notifications for twitter. They appear in a separate window and when I click somewhere, they disappear as if they were in the foreground and… (read more)

I have a problem with firefox notifications for twitter. They appear in a separate window and when I click somewhere, they disappear as if they were in the foreground and hiding. The second thing is clogging and then I get a massive series of delayed notifications. help

Asked by essa Prieš 4 valandas

Last reply by essa Prieš 4 valandas

slow response from websites. With 1Gbps from comcast I can watch the screen paint a picture. Using Edge, pictures pop right up.

I have a 1 Gbps line from Comcast. I have a new HP desktop PC, 32 GB Ram. Speed tests from several test sites confirm good line speed. When I sign in to my email provi… (read more)

I have a 1 Gbps line from Comcast. I have a new HP desktop PC, 32 GB Ram. Speed tests from several test sites confirm good line speed. When I sign in to my email provider using Firefox, the circle on the screen goes round and round for up to 20 seconds. Not so with MS Edge. When I select an image to view using Firefox, I can watch the screen being painted. Not so with MS Edge. I have had slow responses from several other websites. Comcast has come out to my house twice to verify line speed. No problems found. Firefox appears to be the bottleneck at this point. Please help.

Thanks..........Bob

Asked by mrjedi2u1 Prieš 1 dieną

Last reply by mrjedi2u1 Prieš 4 valandas

Ctrl+Shift+T opening new tabs instead of restoring closed ones

I'm facing a bewildering problem with Ctrl+Shift+T, which has only started in the past few hours and persisted through troubleshooting. In short, it's opening a default … (read more)

I'm facing a bewildering problem with Ctrl+Shift+T, which has only started in the past few hours and persisted through troubleshooting.

In short, it's opening a default new tab when I press that combination, rather than reopening the last closed tab, as is its normal function. The problem is not that the tabs themselves are lost -- the "Reopen Closed Tab" drop-down menu entry is still available on right-click, and seems to function as expected. Similarly, I checked about:config to see if there was a problem with sessionstore or sessionrestore, both of which are at their default settings and can't be causing this. Rather, something about the combination itself is no longer working.

I ran Firefox in Troubleshoot Mode to see if any of my settings were causing this. The problem persisted there, so that doesn't seem to be the case.

A little over a month ago, I got a new phone and synced up my desktop and mobile (Android) Firefox tabs, which I hadn't done previously. This is really the only thing I can think of that would lead to any issues, but it's impossible to match the timeframes -- I noticed this problem today, five hours ago. (The failure for ctrl+shift+t to work includes tabs that were opened from mobile sync.) I make heavy use of this keyboard shortcut and would've noticed it earlier if it started earlier.

Something about Ctrl+Shift+T itself is not properly being 'translated'. Ctrl+T works as expected (opens a blank tab), which is the same thing the Shift version is doing. Both my Ctrl and Shift keys are working fine in other respects (e.g. shift key capitalizes letters and adds special characters), so it's not keyboard hardware. It's not "inconsistent" -- it consistently works for everything else, and consistently doesn't work for this.

I'm using Firefox 122.0 on Windows 11.

Asked by vaticidalprophet Prieš 3 savaites

Last reply by cor-el Prieš 4 valandas

History Disappeared

After Firefox did an update I opened up Firefox and ALL my history was gone. I still have my bookmarks. But I need my history for the past few weeks and months. I've trie… (read more)

After Firefox did an update I opened up Firefox and ALL my history was gone. I still have my bookmarks. But I need my history for the past few weeks and months. I've tried to search and find it through using an Index.dat analyzer. But when I've tried to use it, nothing was found. I've not shut down my computer since as I want to get this back. How do I do so?

Asked by davedc32 Prieš 15 valandų

Last reply by cor-el Prieš 4 valandas

Firefox macOS Constant Crashes: no blob image template

Hi, I'm hoping someone can help me figure out why Firefox continues to crash on my M-series Mac, when visiting certain websites. I am getting an error, no blob image temp… (read more)

Hi, I'm hoping someone can help me figure out why Firefox continues to crash on my M-series Mac, when visiting certain websites. I am getting an error, no blob image template [ EXC_BAD_ACCESS / KERN_INVALID_ADDRESS ], on each crash. I've looked this error up, to little avail. Can someone please help diagnose some of these? Thank you in advance!

e0442e78-9ed4-4875-998f-6ff790240222 a2ae5006-07be-468c-b0d0-2c34c0240224 ee2b7825-9613-4ba6-af38-cfb6c0240224

Asked by czArmageddon Prieš 2 dienas

Last reply by czArmageddon Prieš 5 valandas

Repeating "Welcome back" popup when starting Firefox

I have just upgraded to Firefox version 123. Now whenever I start Firefox on any of my profiles, it will immediately or almost immediately display a "Welcome back" popup … (read more)

I have just upgraded to Firefox version 123. Now whenever I start Firefox on any of my profiles, it will immediately or almost immediately display a "Welcome back" popup stating that "Here’s a quick reminder that you can keep your favorite indie browser just one click away." and provides a button to make the browser the default one. That's exceedingly annoying - I can understand that Firefox wants to notify my once in a while, but this happens at least once a day, probably more often than that. I looked over the source code and got that it is a "spotlight" feature, but I failed to find any settings that would turn it off. Any idea how can I disable this forever?

Asked by pepak Prieš 1 dieną

Last reply by cor-el Prieš 5 valandas

Azure DevOps unusable in Firefox

Hello, I'm using Firefox as my default browser for a while now (10+ years) and I'm getting frustrated with this issue when using Azure Devops. Comments don't load at all … (read more)

Hello, I'm using Firefox as my default browser for a while now (10+ years) and I'm getting frustrated with this issue when using Azure Devops. Comments don't load at all and most pages take a long time to load if they load at all. Various features also take a long time to load or don't work at all (examples include adding a reviewer, referencing a story with #, etc.). Anyone else experience this?

It works well for maybe an hour, and after a couple of days it makes no sense anymore.

Now I'm using firefox containers with a container only for Azure Devops and seems working better but ... Curious thing is that it pops up and asks for credentials periodically every 5 or 10 minutes. Well, unless the boxes are already filled up with the credentials.

Thanks,

Asked by leo87 Prieš 2 savaites

Last reply by leo87 Prieš 5 valandas

Cookies being written and automatically deleted

Hello, I work for Microsoft, and one of our sites offers users a way to opt out of personalized advertising on some Microsoft domains by setting a cookie. The site: http… (read more)

Hello,

I work for Microsoft, and one of our sites offers users a way to opt out of personalized advertising on some Microsoft domains by setting a cookie. The site: https://account.microsoft.com/privacy/ad-settings/signedout

When the user clicks the toggle to Off, we cycle through four domains via an iframe and write a TOptOut cookie on each one. If everything is working properly, the user should then be able to go to www.bing.com and see a TOptOut cookie on Bing that will prevent personalized advertising on that domain.

The problem is, this stopped working in Firefox. We have verified that it still works* in 115.7.0, but in 122.0.1 and 123.0, the cookie is written and then deleted on refresh. If the user doesn't already have Bing open in another tab, they'll never see the cookie at all. I have verified this behavior in Bing several times, on my work machine (Firefox 122.0.1 on Windows 10) and my personal machine (Firefox 122.0 snap on Xubuntu 23.10).

  • It still works on our corporate VPN in 115.7.0, but not on my coworker's non-VPN machine. Same version. I'm really not sure what's up with that one.

This is a large concern for us. Because the cookies can still be written, it doesn't trip our test for third-party cookies being disabled. Because the cookie for microsoft.com is written, the toggle will show up as Off even after a refresh. This is misleading to our users.

I have gone over the Firefox docs on Enhanced Tracking Protection and Total Cookie Protection, but neither seem to handle this case. Firefox does not block any trackers on account.microsoft.com or on www.bing.com. It's fine if the cookies are in separate jars, we just want them to be written to the proper domains and not deleted. Can anyone tell me what changed in Firefox recently? Is this expected behavior, or a bug? If it's expected behavior, what can we do to allow users to opt out of personalized advertising?

Asked by amleek Prieš 5 dienas

Last reply by jscher2000 - Support Volunteer Prieš 5 valandas

How to allow for self signed certificates?

Hi, I'm developing web app. I created and set up ssl auth for localhost with self signed cert. When I hit my endpoint with firefox I see: Secure Connection Failed … (read more)

Hi,

I'm developing web app. I created and set up ssl auth for localhost with self signed cert.

When I hit my endpoint with firefox I see:


Secure Connection Failed

An error occurred during a connection to localhost:8081. SSL peer cannot verify your certificate.

Error code: SSL_ERROR_BAD_CERT_ALERT

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.


How to disable security in FF so I can test my endpoint?

Asked by Krzysztof Łempicki Prieš 6 valandas

Controlling the "New Tab" default

The way New Tab works seems to have changed: The options are now "Firefox Home" or "blank page." Google is my home page and I want it to keep it as the New Tab default to… (read more)

The way New Tab works seems to have changed: The options are now "Firefox Home" or "blank page." Google is my home page and I want it to keep it as the New Tab default too. I've been looking on all the Mozilla help topics related to this, and they don't make sense to me. Please tell me how to do this. Thank you.

Asked by Alan Sanstad Prieš 7 valandas

Update from tar.bz2 files extracted

Ark extracted Version 119 files into /home/Downloads/Firefox/Firefox. I tried ./update from the BASH command line, but didn't know which argument(s) to add to that comman… (read more)

Ark extracted Version 119 files into /home/Downloads/Firefox/Firefox. I tried ./update from the BASH command line, but didn't know which argument(s) to add to that command. I'm hoping to update Firefox 78.14 ESR to a recent version, whether ESR or not. Thanks for your help.

Asked by lee.hinkleman Prieš 1 dieną

Last reply by lee.hinkleman Prieš 7 valandas