Showing questions tagged: Show all questions

Strange behaviour when copying images on Mac

Long time listener, first time caller... :) [Seriously have been using and loving Firefox/Mozilla since 2004-2005, before that was Netscape Navigator, this is the first t… (read more)

Long time listener, first time caller... :) [Seriously have been using and loving Firefox/Mozilla since 2004-2005, before that was Netscape Navigator, this is the first time I can recall having an issue that I can't find already written up and solved. Hence, this post.]

I've been having some odd issues with Firefox (85.0.2 64-bit) on my Intel Mac (Big Sur 11.2.1) for the past few months, and this morning decided to dig in deeper.

The backstory: When I’ve wanted to copy and image and paste it into Apple Messages, the images sometimes don’t send because Messages doesn’t support TIFF, WEBP, or PNG formats when sending to someone who doesn’t have an iMessage account (aka using standard MMS like to Android phones). So, I then have to convert the failed image to JPG, delete the failed message, and drag the saved JPG image file into Messages and can then resend it.

The issue: Today, I discovered that when I copy a JPG image from Firefox, and paste it into Apple messages, it seems that it doesn’t send because it appears to be either copied or pasted as a different format than the original image?

To reproduce:

  1. Go to a web site with a JPG image ( http://www.lunarbaboon.com for example)
  2. Right-Click on the JPEG image ( comicorder038.jpg for example) and select “View Image Info”
  3. Right-Click on the JPEG image and select “Copy Image”
  4. Paste into Messages to send to someone who doesn’t have an iMessage account
  5. Hit enter to send
  6. Wait a few seconds for failure
  7. Click on failure Info
  8. Right-Click on image and select Open
  9. Preview shows the file as TIFF not JPG

To simplify:

  1. Go to a web site with a JPG image ( http://www.lunarbaboon.com for example)
  2. Right-Click on the JPEG image ( comicorder038.jpg for example) and select “Copy Image”
  3. Open Preview and select “New from Clipboard”
  4. Select “Tools -> Show Inspector”
  5. Preview shows the file as PNG not JPG

What I’ve tried: Copy & paste of same image from Firefox - Safe Mode fails - So, doubt it is something in my Firefox config Copy & paste of same image from Safari works - So, doubt it is something MacOS related However, copy & paste of same image from Chrome fails too - So, maybe it is something MacOS related?

Any suggestions on what to try next?

Asked by sck626 Prieš 2 savaites

Last reply by cor-el Prieš 5 dienas

Disable Firefox Disk Cache Completely

Hello, I recently purchased a SSD and I am using it. I was shocked to see that my SSD's TBW was 800GB in just 2 months whereas I never write any big files and then I real… (read more)

Hello, I recently purchased a SSD and I am using it. I was shocked to see that my SSD's TBW was 800GB in just 2 months whereas I never write any big files and then I realize that Firefox was eating my TBW and I have disabled some features in "about:config".

Those features are: browser.cache.disk.enable = false browser.cache.disk_cache_ssl = false browser.cache.memory.enable = true


But disabling those things did not helped me. I am trying to save my TBW. I want Firefox to never write anything in my SSD. I want to disable cache forever. I want Firefox to store all cache in Memory. I know it will take more internet bandwidth but no problem for me.

Can I tweak these settings in about:config?

browser.cache.disk.capacity = 0 or 1 (Not use if 0 means unlimited or disable in Firefox so I am using 1 and please tell me how what does 0 does) browser.cache.disk.content_type_media_limit = 0 or 1 (Not sure what this is) browser.cache.disk.enable = false browser.cache.disk.free_space_hard_limit = 0 or 1 browser.cache.disk.free_space_soft_limit = 0 or 1 browser.cache.disk.max_chunks_memory_usage = 0 or 1 browser.cache.disk.max_entry_size = 0 or 1 browser.cache.disk.max_priority_chunks_memory_usage = 0 or 1 (Not sure what this is) browser.cache.disk.metadata_memory_limit = 0 or 1 (Not sure what this is) browser.cache.disk.preload_chunk_count = 0 or 1 browser.cache.disk.smart_size.enabled = false browser.cache.disk_cache_ssl = false browser.cache.offline.capacity = 1 browser.cache.offline.enable = false browser.cache.offline.storage.enable = false

Can I create a new setting like browser.cache.disk.disable = true?

Asked by The Most Honourable Prieš 5 dienas

Last reply by jscher2000 Prieš 4 dienas

After an Update I get white screens only

I did an Update to Firefox 86 and the Webbrowser crashed. Since then I'm not able to open any page. I reinstalled several times including deleting all folders and all rec… (read more)

I did an Update to Firefox 86 and the Webbrowser crashed. Since then I'm not able to open any page. I reinstalled several times including deleting all folders and all records in Regestry I found. All what I can find is the following: Starter Process is deactivated after error. All details out of Error Report see in Troubleshooting Information

Asked by kar16 Prieš 5 dienas

Last reply by FredMcD Prieš 5 dienas

On Screen Keyboard will not open, Surface Pro 7

I'm using a Surface Pro 7, running Win10H. Firefox had a brief period when I first installed it where the on screen keyboard would appear and work, that stopped after a f… (read more)

I'm using a Surface Pro 7, running Win10H. Firefox had a brief period when I first installed it where the on screen keyboard would appear and work, that stopped after a few hours and has not worked since. I fiddled with the settings on both Firefox and my surface, though nothing has changed. Un/re-installing did not help, thought it could reset something. Any fixes or advice would be greatly appreciated.

For clarification, the Accessibility Menu on-screen keyboard does work, but the tablet-specific larger keyboard does not function. It does open and type in other applications.

Asked by Big Daddy Prieš 5 dienas

Last reply by jscher2000 Prieš 5 dienas

Reset the default language and search engine at each update

Hello, at each firefox update, on each session of my PC, under ubuntu 20.04, the language is reset (in English) and the default search engine changes (I use Qwant). Do ot… (read more)

Hello, at each firefox update, on each session of my PC, under ubuntu 20.04, the language is reset (in English) and the default search engine changes (I use Qwant). Do others have the same problem?

Bonjour, à chaque mise à jour de firefox, sur chaque session de mon PC, sous ubuntu 20.04, la langue se réinitialise (en anglais) et le moteur de recherche par défaut change (j'utilise Qwant). D'autres on-ils le même problème ?

Asked by Jean-Luc Prieš 5 dienas

Last reply by cor-el Prieš 5 dienas

Firefox NIGHTLY 88.0a1 64bit slow freezing..

Firefox NIGHTLY 88.0a1 64bit Operating system windows 7 64bit Intel Xeon 1230v3 RAM 32gb GeForce 970 wd blue ssd 500gb One day, Nightly began to slow down. Creating 20 ne… (read more)

Firefox NIGHTLY 88.0a1 64bit

Operating system windows 7 64bit Intel Xeon 1230v3 RAM 32gb GeForce 970 wd blue ssd 500gb

One day, Nightly began to slow down.

Creating 20 new tabs didn't slow it down, but now creating 4 new tabs freezes or doesn't respond.

Even if you turn off hardware acceleration, turn off additional functions, or turn off unnecessary functions among experimental functions, it will only speed up for a while.

Over time, it stops again or stops responding.

Since it is a problem with the computer, there is no change even if I run it again after cleaning the registry and other optimizations. There is no problem in Chrome or Opera, but only Nightly is the problem.

I didn't even have to reinstall and I don't know what to do. I might try installing the old version, but I don't know where to get it.

In other words, it seems that it runs without problems when it is first started. But after running If you repeat creating 10 new tabs several times, it becomes slower and stops responding.

It's as if the capacity is full and you can't take it anymore... however, my hard disk has 200 GB of free space.

If this problem is not resolved, I don't think I can use Nightly anymore.

Error message

설명:

 오류로 인해 이 프로그램이 Windows와 상호 작용하지 않습니다.

문제 서명:

 문제 이벤트 이름:	AppHangB1
 응용 프로그램 이름:	firefox.exe
 응용 프로그램 버전:	88.0.0.7728
 응용 프로그램 타임스탬프:	603acfd6
 중단 서명:	9c0e
 중단 유형:	0
 OS 버전:	6.1.7601.2.1.0.256.1
 로캘 ID:	1042
 추가 정지 서명 1:	9c0ebfe75cb0efa66b21762d6b9e2733
 추가 정지 서명 2:	a774
 추가 정지 서명 3:	a7742fb7cef8ff4e7802a3ccd85b4c6e
 추가 정지 서명 4:	9c0e
 추가 정지 서명 5:	9c0ebfe75cb0efa66b21762d6b9e2733
 추가 정지 서명 6:	a774
 추가 정지 서명 7:	a7742fb7cef8ff4e7802a3ccd85b4c6e


I don't know if the meaning is well conveyed using Google Translate. Anyway, I hope for help.

Asked by ninjasoul84 Prieš 5 dienas

Last reply by user3585702 Prieš 4 dienas

Firefox 86 Crash On Startup

I'm currently running Ubuntu 20.04 although this problem began yesterday while I used Ubuntu 18.04. Simply put, I went to sleep on February 26 and on February 27 when I t… (read more)

I'm currently running Ubuntu 20.04 although this problem began yesterday while I used Ubuntu 18.04. Simply put, I went to sleep on February 26 and on February 27 when I tried to start up firefox I only get the crash reporter. I am able to run 78.8.0esr thankfully, however I would greatly prefer to use the latest version of the browser. I can think of nothing I did between shutting down my browser on the 26 and waking up the next morning. Firefox will not start up in safe mode. I clean install from the snap store or ubuntu repositories has done nothing.

Below is my crash ID and i've attached all the details the crash reporter gives me.

Crash ID: bp-2e4e360d-605b-4fa6-9cdf-17eb90210227

Asked by jyevoli01 Prieš 4 dienas

Last reply by cor-el Prieš 4 dienas

firefox crash ubuntu 18.04

Hi Firefox has been crashing on my linux system since february 27th Whether I attempt to start it safe mode or not, it will crach on startup, and Mozzilla Crash Reporter… (read more)

Hi Firefox has been crashing on my linux system since february 27th Whether I attempt to start it safe mode or not, it will crach on startup, and Mozzilla Crash Reporter GUI will open. If I attempt to run it from the terminal in safe mode, the following error message appears in the console ExceptionHandler::GenerateDump cloned child 21529 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal...

This is the content of the most recent file in ~/.mozilla/firefox/Crash Reports/pending


{"AdapterDeviceID":"0x0166","AdapterDriverVendor":"mesa/i965","AdapterDriverVersion":"20.0.8.0","AdapterVendorID":"0x8086","AvailablePageFile":"0","AvailablePhysicalMemory":"122281984","AvailableSwapMemory":"1374183424","AvailableVirtualMemory":"1683070976","BuildID":"20210222142601","CrashTime":"1614523618","DesktopEnvironment":"gnome","EMCheckCompatibility":"true","FramePoisonBase":"9223372036600930304","FramePoisonSize":"4096","InstallTime":"1614417559","IsWayland":"0","IsWaylandDRM":"0","MozCrashReason":"OOB","Notes":"Ubuntu 18.04.5 LTSFP(D00-L1000-W00000000-T000) WR? WR- OMTP? OMTP- ","ProductID":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","ProductName":"Firefox","ReleaseChannel":"release","SafeMode":"1","SecondsSinceLastCrash":"10","ServerURL":"https://crash-reports.mozilla.com/submit?id={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&version=86.0&buildid=20210222142601","StackTraces":{"crash_info":{"address":"0","crashing_thread":0,"type":"SIGSEGV /SEGV_MAPERR"},"modules":[{"base_addr":"0x7f212ff74000","code_id":"1e756486b2b98ce1a7aaf89f21df80a87ae917ae","debug_file":"libxul.so","debug_id":"8664751EB9B2E18CA7AAF89F21DF80A80","end_addr":"0x7f21384f3000","filename":"libxul.so","version":""}],"status":"OK","threads":[{"frames":[{"ip":"0x7f2135a23a0b","module_index":0,"trust":"context"},{"ip":"0x7f2134e1fa7e","module_index":0,"trust":"scan"}]}]},"StartupCrash":"1","StartupTime":"1614523616","TelemetryClientId":"eedb5a75-0b05-48d7-9f0b-e0ff7d7a1bef","TelemetryServerURL":"https://incoming.telemetry.mozilla.org","TelemetrySessionId":"54d80b9d-456a-4e17-9863-807eb6a296b8","ThreadIdNameMapping":"9568:\"IPC I/O Parent\",9569:\"Timer\",9570:\"Netlink Monitor\",9571:\"Socket Thread\",9572:\"Permission\",9575:\"JS Watchdog\",9576:\"JS Helper\",9578:\"JS Helper\",9579:\"JS Helper\",9577:\"JS Helper\",9587:\"Cache2 I/O\",9588:\"Cookie\",9589:\"StreamTrans #1\",9591:\"DOM Worker\",9593:\"IPDL Background\",9594:\"StreamTrans #2\",9605:\"StreamTrans #3\",9614:\"QuotaManager IO\",9629:\"IndexedDB #1\",9701:\"Worker Launcher\",9755:\"SoftwareVsyncThread\",9756:\"Compositor\",","TotalPageFile":"5408432128","TotalPhysicalMemory":"4028993536","UptimeTS":"1.39140296","Vendor":"Mozilla","Version":"86.0"}

What can I do to get fireworks working again?

Best wishes,

Will

Asked by william23b Prieš 4 dienas

Last reply by jonzn4SUSE Prieš 3 dienas

FIrefox does not load anything, including local, external, and firefox config pages.

Problem: FIrefox suddenly quit working. Firefox refuses to load anything including local, external, and firefox config pages. When attempting to go to a webpage or config… (read more)

Problem: FIrefox suddenly quit working. Firefox refuses to load anything including local, external, and firefox config pages. When attempting to go to a webpage or config page by pressing the enter button nothing happens and the page is entirely blank. The developer console does not open. After about 2 minutes of not doing anything, it crashes. Issue persists past re-installs. I am unable to submit a bug report as normal(I only have pending crash reports), as when I attempted, it said "something unexpected happened" and then the bug report itself crashes.

Chrome works normally as expected.

Troubleshooting steps taken:

  • Refresh and safe mode
  • Launched in incognito
  • apt-get purge
  • Removing profile
  • removing .mozilla, .adobe, .macromedia, /etc/firefox, firefox-extensions, .cache
  • installing nightly, beta, reinstalled multiple times.

Current workaround: Using chrome

Machine information Ubuntu 20.04.2 Kernel Version: 5.4.0-66-generic

Relevant image of issue and contents of detail tabs attached.

Asked by mario65889 Prieš 4 dienas

Last reply by FredMcD Prieš 3 dienas

Brower

Soooo idk why this is happening to my firefox whenever i search things this always happen. I dont know how to fix it. If anyone can help me that would be great. Thank you… (read more)

Soooo idk why this is happening to my firefox whenever i search things this always happen. I dont know how to fix it. If anyone can help me that would be great. Thank you

Asked by ken198611 Prieš 4 dienas

Last reply by FredMcD Prieš 3 dienas

MOZILLA_PKIX_ERROR_REQUIRED_TLS_FEATURE_MISSING

Dear All, I tried to upload a free ssl certificate to make my site sicure. With other browser I don't have any problems, but with Firefox I received this message: MOZILLA… (read more)

Dear All, I tried to upload a free ssl certificate to make my site sicure. With other browser I don't have any problems, but with Firefox I received this message: MOZILLA_PKIX_ERROR_REQUIRED_TLS_FEATURE_MISSING Someone have any solution about? Thanks to all.

Digital5

Asked by digital5 Prieš 4 dienas

Last reply by TyDraniu Prieš 3 dienas

Mozilla Firefox crash

Hi, I tried to open the Mozilla Firefox today, but it crashes inmediately. this never happened before. Attached the message I get everytime I try to open Firefox browser.… (read more)

Hi,

I tried to open the Mozilla Firefox today, but it crashes inmediately. this never happened before. Attached the message I get everytime I try to open Firefox browser. I would appeciate your asssistance.

Thanks.

Asked by maithuna5 Prieš 3 dienas

Last reply by FredMcD Prieš 3 dienas

Firefox on one of computer is not working at

GM Last Saturday morning Firefox crashed and my troubles started. Firefox works fine 2 other computers in the house just mine seems to affected. I have done everything… (read more)

GM Last Saturday morning Firefox crashed and my troubles started. Firefox works fine 2 other computers in the house just mine seems to affected. I have done everything that I could find on line to no avail. I would like some help PLEASE Greg

Asked by gregor13 Prieš 3 dienas

Last reply by FredMcD Prieš 3 dienas

mouse cursor disappears when uploading file

About once every 3 times, my mouse cursor will visually disappear when uploading files. It's still there and functioning, I just can't see it. This happens at any site wh… (read more)

About once every 3 times, my mouse cursor will visually disappear when uploading files. It's still there and functioning, I just can't see it. This happens at any site where I need to upload such as voices.com, voice123.com or ACX (I do voice work). It started with a Logitech M330 mouse and continues to happen with a Nexus Wired 5D optical mouse. Machine is a 2021 M1 Mac Mini. The firmware on the logitech is up to date. Haven't checked on the Nexus yet but THAT mouse is working except the problem described in this post. Not seeing the problem when uploading files in Safari. Just Firefox. That being said, the sample size is much bigger with Firefox so I will keep using Safari to see if the problem pops up there. I want to rule out an issue with Firefox.

Asked by zamboknee Prieš 2 dienas

Last reply by brisu Prieš 1 dieną