Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webfonts in headings don't display correctly

  • 2 replies
  • 2 have this problem
  • 32 views
  • Paskiausią atsakymą parašė cor-el

more options

I'm designing a website with @fontface fonts hosted locally on my site. Fonts display properly in all browsers except Firefox... and it's probably something really simple that's wrong. Body text is okay, but headings and classes don't work. I uploaded a few start pages to http://www.wineartandheart.org to test them... hope someone can help?

Chosen solution

Note that the Web Console (Firefox/Tools > Web Developer) shows a missing ';' in a style rule:

Expected end of value but found ':'.  Error in parsing value for 'font-family'.  Declaration dropped.
ul.MenuBarHorizontal li
{
	margin: 0;
	padding: 0;
	list-style-type: none;
	font-family: Urbana-Medium, Urbana-light, "Trebuchet MS", sans-serif /* missing semi colon */
	font-size: 100%;
	position: relative;
	text-align: center;
	cursor: pointer;
	width: 6em;
	float: right;
}
Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (2)

more options

Could you use the Inspector feature to see what font Firefox is using? You can right-click an element and choose Inspect Element (Q). On the right side of the Inspector pane, click Font. (Screen shot attached.)

More generally, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Chosen Solution

Note that the Web Console (Firefox/Tools > Web Developer) shows a missing ';' in a style rule:

Expected end of value but found ':'.  Error in parsing value for 'font-family'.  Declaration dropped.
ul.MenuBarHorizontal li
{
	margin: 0;
	padding: 0;
	list-style-type: none;
	font-family: Urbana-Medium, Urbana-light, "Trebuchet MS", sans-serif /* missing semi colon */
	font-size: 100%;
	position: relative;
	text-align: center;
	cursor: pointer;
	width: 6em;
	float: right;
}