X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

How can I get reasonable speed on sending / receiving messages

Paskelbta

I am in the process of upgrading from a Pentium 4 running Windows XP Home (SP3) to an Intel Core i7-4770 system under Windows 8 (x64). At the same time I am looking into the possibility of changing my mail program to Thunderbird.

I have installed Thunderbird 24.3.0, and I am gradually getting into the workings. Generally I like what I am seeing, but I have one major problem -- it takes a very long time for e-mails to be processed, whether they are being sent or received.

In researching this problem in Mozilla support I did find a reference to Bitdefender which I am using as an AV program. Is there some component of Thunderbird which I should be excluding from Bitdefender's attentions, or can anyone suggest any other reasons for the glacial pace of e-mail input/output?

I am in the process of upgrading from a Pentium 4 running Windows XP Home (SP3) to an Intel Core i7-4770 system under Windows 8 (x64). At the same time I am looking into the possibility of changing my mail program to Thunderbird. I have installed Thunderbird 24.3.0, and I am gradually getting into the workings. Generally I like what I am seeing, but I have one major problem -- it takes a very long time for e-mails to be processed, whether they are being sent or received. In researching this problem in Mozilla support I did find a reference to Bitdefender which I am using as an AV program. Is there some component of Thunderbird which I should be excluding from Bitdefender's attentions, or can anyone suggest any other reasons for the glacial pace of e-mail input/output?

Chosen solution

The last piece of the puzzle fell into place when I found that the "leave message on server" setting for some accounts was set to a different value on the two systems. As a result, a message was being delivered either to both systems or to only one, depending on which system checked for messages first.

Having sorted out this boo-boo, and turned off the Bitdefender SSL Scan the message I/O rate now seems fine.

Problem solved.

Skaityti atsakymą kartu su kontekstu 0

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

iamjayakumars Sprendimų: 489 Atsakymų: 5951

Naudingas atsakymas

I don't face any issues as you mentioned?

Are you using any alternative address for sending an email?

Are you using proxy?

Try in thunderbird safemode

I don't face any issues as you mentioned? Are you using any alternative address for sending an email? Are you using proxy? Try in thunderbird safemode

Klausimą uždavęs asmuo

iamjayakumars: Thanks for your input.

I am not quite sure what you mean by "using ... alternative address".

I have five e-mail accounts defined in Thunderbird, three of which are also in use on my previous system. The outgoing server (SMTP) defined for one of the common accounts is also used as a default outbound server for the other four.

No proxy.

iamjayakumars: Thanks for your input. I am not quite sure what you mean by "using ... alternative address". I have five e-mail accounts defined in Thunderbird, three of which are also in use on my previous system. The outgoing server (SMTP) defined for one of the common accounts is also used as a default outbound server for the other four. No proxy.
jscher2000
  • Top 10 Contributor
Sprendimų: 8690 Atsakymų: 71037

Bitdefender has a feature to intercept some transmissions for filtering. If you are connecting on a secure port (which is preferred, so probably you are), this involves an extra round of decryption and re-encryption.

To test with that feature turned off:

BitDefender -> Privacy settings -> disable Scan SSL

Bitdefender has a feature to intercept some transmissions for filtering. If you are connecting on a secure port (which is preferred, so probably you are), this involves an extra round of decryption and re-encryption. To test with that feature turned off: BitDefender -> Privacy settings -> disable Scan SSL

Klausimą uždavęs asmuo

jsscher2000: Thanks for the suggestion.

I made the change, and outgoing messages now seem to be dispatched faster. I changed a few other settings at the same time so I am not yet sure whether the improvement was solely due to the Bitdefender change -- I will have to test further to check (btw -- is running without Scan SSL to be recommended or could it cause potential security problems?).

There still seems to be a problem with incoming messages,some of which seem to be severely delayed (or do not turn up at all). I think this may be something that I need to take up with my ISP. I will post back if anything significant turns up.

jsscher2000: Thanks for the suggestion. I made the change, and outgoing messages now seem to be dispatched faster. I changed a few other settings at the same time so I am not yet sure whether the improvement was solely due to the Bitdefender change -- I will have to test further to check (btw -- is running without Scan SSL to be recommended or could it cause potential security problems?). There still seems to be a problem with incoming messages,some of which seem to be severely delayed (or do not turn up at all). I think this may be something that I need to take up with my ISP. I will post back if anything significant turns up.
Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3251 Atsakymų: 22397

Naudingas atsakymas

I would suggest you turn off all of bit defenders email scanning capabilities and see what happens re speed.

They claim to have a shield thingy that catches a virus of you launch it, so having no scanning of mail just places more emphasis on that component working as advertised. So the security risks are minimal.

You might also find you need to exclude your Thunderbird profile from "on access" scanning. Thunderbird stores mail in a single file per folder. if the anti virus program is going to scan this file (which could be 3 or 4Gb in size) it can slow things to a crawl. Most well behaved anti virus programs manage to not mess this up, but periodically they all jump in boots and all.

I would suggest you turn off all of bit defenders email scanning capabilities and see what happens re speed. They claim to have a shield thingy that catches a virus of you launch it, so having no scanning of mail just places more emphasis on that component working as advertised. So the security risks are minimal. You might also find you need to exclude your Thunderbird profile from "on access" scanning. Thunderbird stores mail in a single file per folder. if the anti virus program is going to scan this file (which could be 3 or 4Gb in size) it can slow things to a crawl. Most well behaved anti virus programs manage to not mess this up, but periodically they all jump in boots and all.

Chosen Solution

The last piece of the puzzle fell into place when I found that the "leave message on server" setting for some accounts was set to a different value on the two systems. As a result, a message was being delivered either to both systems or to only one, depending on which system checked for messages first.

Having sorted out this boo-boo, and turned off the Bitdefender SSL Scan the message I/O rate now seems fine.

Problem solved.

The last piece of the puzzle fell into place when I found that the "leave message on server" setting for some accounts was set to a different value on the two systems. As a result, a message was being delivered either to both systems or to only one, depending on which system checked for messages first. Having sorted out this boo-boo, and turned off the Bitdefender SSL Scan the message I/O rate now seems fine. Problem solved.