Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes/hangs (both actually)

  • 9 replies
  • 7 have this problem
  • 267 views
  • Paskiausią atsakymą parašė TheSakib

more options

It mostly crashes on startup. Rarely it opens but crashes on the first or second click. It doesn't even work on safe mode. Tried every possible steps from http://mzl.la/Kpf7Zn and http://mzl.la/MP6ZBS but none of them worked. I even re-installed the windows 7. Then it worked for a day then it again started crashing.

PC spec:

Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1

System Manufacturer: Gigabyte Technology Co., Ltd.

BIOS: BIOS Date: 07/05/12 17:46:39 Ver: 04.06.05

Processor: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.7GHz

RAM: 4096MB RAM

Graphics Driver: NVIDIA GeForce GTX 560 Ti

Modified by TheSakib

All Replies (9)

more options

We are sorry to hear about the crashes and Firefox hanging, if you can provide an example of when it crashes by submitting a crash report, this can be really helpful. Since this is a nightly version of Firefox there are a number of issues that are updated on a regular basis.


_________________

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.

SubmittedCrashReports-Win7

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

The weird thing is there is no submitted crash report. Again it worked for a day when I installed MalwareBytes but again it stopped working today. Okay I managed to take a picture of about:crashes page. There isn't any. But right after some moment (when I clicked on the history), It again crashed and not opening anymore (not even in safe mode).

more options

I was able to recover raw data of Troubleshooting Information:

{

 "application": {
   "name": "Firefox",
   "version": "30.0a1",
   "userAgent": "Mozilla/5.0 (Windows NT 5.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0",
   "supportURL": "https://support.mozilla.org/1/firefox/30.0a1/WINNT/en-US/"
 },
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "modifiedPreferences": {
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.smart_size_cached_value": 358400,
   "browser.places.smartBookmarksVersion": 6,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20140205030203",
   "browser.startup.homepage_override.mstone": "30.0a1",
   "browser.startup.homepage_override.buildID": "20140206030201",
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "30.0a1",
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "network.cookie.prefsMigrated": true,
   "places.database.lastMaintenance": 1391718360,
   "places.history.expiration.transient_current_max_pages": 104858,
   "plugin.importedState": true,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "privacy.sanitize.migrateFx3Prefs": true,
   "storage.vacuum.last.places.sqlite": 1391718360,
   "storage.vacuum.last.index": 0,
   "toolkit.startup.recent_crashes": 3
 },
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 0,
   "windowLayerManagerType": "Basic",
   "windowLayerManagerRemote": false,
   "numAcceleratedWindowsMessage": [
     ""
   ],
   "adapterDescription": "NVIDIA GeForce GTX 560 Ti  ",
   "adapterVendorID": "0x10de",
   "adapterDeviceID": "0x1200",
   "adapterRAM": "1024",
   "adapterDrivers": "nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um",
   "driverVersion": "9.18.13.3221",
   "driverDate": "12-19-2013",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": false,
   "directWriteEnabled": false,
   "directWriteVersion": "6.2.9200.16492",
   "direct2DEnabledMessage": [
     ""
   ],
   "webglRenderer": "Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti   Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "skia",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "cairo"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.3 Beta",
     "version": "4.10.3 Beta"
   },
   "NSS": {
     "minVersion": "3.15.5 Basic ECC Beta",
     "version": "3.15.5 Basic ECC Beta"
   },
   "NSSUTIL": {
     "minVersion": "3.15.5 Beta",
     "version": "3.15.5 Beta"
   },
   "NSSSSL": {
     "minVersion": "3.15.5 Basic ECC Beta",
     "version": "3.15.5 Basic ECC Beta"
   },
   "NSSSMIME": {
     "minVersion": "3.15.5 Basic ECC Beta",
     "version": "3.15.5 Basic ECC Beta"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": []

}

more options

Can you bring up the Profile Manager to create a new profile?

Are you using a 32 bit build or a 64 bit Nightly build?

If you use the 64 bit build then try the 32 bit build instead.

more options

Creating a new profile didn't work. And I'm using 64 bit Nightly build.

But the amazing thing is it is running for last two days after I changed some things in properties. I don't know which of them did the effect but here is the things I changed:

  • Properties > Compatibility > Run this program in compatibility mode for "Windows XP (Service pack 3)
  • Properties > Compatibility > *tick* Run this program as an administratior
  • General > Advanced > *tick* the both box of "File attributes"
more options

Did you try the 32 bit Nightly build?

The 64 bit Nightly build for Windows is only generated to test for compilation errors and doesn't undergo all the tests that other builds get, so the risk that something goes wrong can be quite high.

more options

Working fine right now (actually not full crushes randomly and less often). Uninstalling may starts the problem again.

FYI- The problem started in Firefox version 25. Then I tried the older versions and then the beta then the Nightly build (alpha). None of them worked and had same start-up crashes. And the weirdest thing, none of them reported any Crash Report.

more options

You posted this under "more system details" in your original question:

Problem signature:
Problem Event Name: APPCRASH
Application Name: firefox.exe
Application Version: 30.0.0.5149
Application Timestamp: 52f2429c
Fault Module Name: StackHash_0a9e
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 07400001
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I googled APPCRASH StackHash_0a9e and found a similar issues with the APPCRASH reported for Google Chrome:

I would check for malware. See Troubleshoot Firefox issues caused by malware

more options

I checked malware. That didn't help. Though I found out a new thing today. If I run it as administrator then it rarely crashes. But if I don't do that then it crashes on start-up.