Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm only getting one quarter of a screen on Flash Player on Firefox.

  • 60 replies
  • 105 have this problem
  • 35394 views
  • Paskiausią atsakymą parašė forrie

more options

Only the upper left quadrant of the Flash Player screen has content. The rest of the screen is either blank or the original static image. This occurs on YouTube and any website that has Flash Player content. Computer is a Macbook Pro Retina using OSX 10.8.4. I've uninstalled and reinstalled Flash Player (twice) and uninstalled and reinstalled Firefox. The problem doesn't occur when I'm using Safari.

Chosen solution

This solved it for me. After selecting "Use hardware acceleration when available" in Firefox Advanced preferences, reboot Firefox - and viola - now see the other three quarters...

Skaityti atsakymą kartu su kontekstu 👍 11

All Replies (20)

more options

Hi mr_drlove, the most relevant part is really short. I've attached a screen shot of what I'm looking for.

more options

So I think, this is the part you need:


"graphics": {

   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "OpenGL",
   "windowLayerManagerRemote": false,
   "adapterDescription": "",
   "adapterVendorID": "0x10de",
   "adapterDeviceID": "0x fd5",
   "adapterRAM": "",
   "adapterDrivers": "",
   "driverVersion": "",
   "driverDate": "",
   "webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine",
   "info": {
     "AzureCanvasBackend": "quartz",
     "AzureFallbackCanvasBackend": "none",
     "AzureContentBackend": "none"
   }
 },

ciao mr_drlove

more options

Hi mr_drlove, thank you for that. Your Firefox is using hardware acceleration, so if you are only seeing a quarter of the Flash then that problem must have a second cause.

more options

Sad to say, FF 24 doesn't solve the problem, at least for me. I was auto-updated to 24 overnight, and the quarter screen video problem returned at the very same time.

I reverted back to 22 and the problem is gone.

Jen.

more options

Hi reporterjen, can you confirm that Firefox is applying hardware acceleration to all open windows? Please see this earlier post

https://support.mozilla.org/en-US/questions/968863?page=2#answer-480456

and screen shot

https://support.cdn.mozilla.net/media/uploads/images/2013-09-18-00-14-24-b4cf1b.png

for the data I'm asking about. (You do not need to change versions to check this.)

more options

Thanks jscher2000.

Consider me chagrined.

It appears that in my last attempt to fix this via changing the hardware acceleration option, I left it off. *blushing* I restored my preferences to have hardware acceleration enabled in 22, where video has always worked. I then upgraded to 24 again. So far, I am not having flash video problems.

So, to reiterate: I'm currently having *no* problems with flash video with hardware acceleration enabled in preferences and with verification from about:support that it is indeed functioning in FF 24.

Here's the line in question from about:settings right now: GPU Accelerated Windows 2/2 OpenGL

Thanks, Jen.

more options

Also note this should be fixed in version 26 (you can try the aurora channel), for now use the fixes on this page.

more options

Hi reporterjen, all's well that ends well. We still need to figure out why it isn't working for mr_drlove...

more options

My problem is still the same. Hardware acceleration is ticked and about:support says "GPU Accelerated Windows 0/1 Basic"

By the way, I'm having to post this on Safari as every time I try Firefox it says "Oh, no! It looks like an unexpected error occurred. We've already notified the site administrators. Please try again now, or in a few minutes."

more options

Hi davebesag, you wrote:

My problem is still the same. Hardware acceleration is ticked and about:support says "GPU Accelerated Windows 0/1 Basic"

I think that indicates that Firefox isn't compatible with your graphics card drivers so it is not actually using hardware acceleration. Can you find out whether any updates are available either from Apple or your card manufacturer?

more options

Hi davebesag

Try to clear the cache and cookies only from websites that cause problems for the "Oh, no! " issue.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"
more options

This is the graphics card information. If this isn't compatible then I am stunned. "Graphics Intel HD Graphics 4000 512 MB"

more options

Hi davebesag, your driver version might be blocked.

more options

Sorry, how exactly would I solve this if it is the problem?

more options

Hi davebesag, if a driver is blocked (e.g., because it causes crashes), hopefully an update is available from your vendor. Otherwise, Firefox will just not use hardware acceleration.

A fix for this problem is coming in Firefox 25. Since it was just submitted yesterday, you probably will not find the current beta version has the solution, but maybe in about a week there will be a fresh beta available with the fix.

more options

No matter. The new OS from Apple seems to have sorted it. Thanks for helping.

more options

and of course now having restarted my machine the problem returns! Seeing as a new Apple OS hasn't solved the problem I really do think it must be an issue with Firefox.

more options

Does it still work with hardware acceleration disabled?

more options

Hi davebesag, could you try turning hardware acceleration off and back on again? You'll need to exit and restart Firefox in between.

Firefox 26 is scheduled to go into beta release during this coming week, so if you find no other solution, you could try switching to the beta channel after Tuesday. There may be other stability issues in early beta releases, so if the problem can be tolerated a while longer, I'd wait at least another week before installing it.

more options

I have this same problem. However, the bug report indicates above "with hardware acceleration OFF" - my replication of this problem is with hardware acceleration ON. If I turn it off, the problem goes away.

SMH, this is really annoying.

  1. 1
  2. 2
  3. 3