Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

open links in email

  • 7 replies
  • 10 have this problem
  • 2725 views
  • Paskiausią atsakymą parašė jscher2000

more options

I am unable to access the web with links shown in my emails. This is a fairly recent problem (within the last 10 days). Are you aware of any updates that may have changed my settings?

Chosen solution

What software are you using for handling email? Usually, if Firefox is the default browser, web pages should open in Firefox.

Go to Settings -> Advanced -> General -> System settings and check whether Firefox is the default browser.

Skaityti atsakymą kartu su kontekstu 👍 2

All Replies (7)

more options

Chosen Solution

What software are you using for handling email? Usually, if Firefox is the default browser, web pages should open in Firefox.

Go to Settings -> Advanced -> General -> System settings and check whether Firefox is the default browser.

more options

Am having the same problem. I seem to notice that when FF will not open a link it is usually because FF is already open and won't open another tab. If I close FF and then hit a link in an email or other program FF will start.Please note that not opening a link in an email is NOT an always. It is sporatic. I also THINK it has something to do with the url that is in the 1st tab. FF will not open sometimes if the first tab is a secure site.

more options

Thanks Southwalker for your input. I did solve my problem. Somehow when my computer was having some work done on it FF had been unselected as my default browser.

more options

Glad you found your problem however mine continues although FF is the default browser.

more options

Southwalker - I have exactly the same problem and FF is my default browser and I made the suggested registry changes.

more options

Hi Edward27821,

On the first, one, this is to make Firefox the default web browser, which on Windows is done here:

orange Firefox button (or Tools menu) > Options > Advanced > "General" mini-tab

On the second one, many versions ago Clear Private Data was renamed to Clear Recent History. In Firefox 21 it moved to the History menu. However, I don't know what Incredimail is recommending... please be very careful with this feature as they might be suggesting you blow away all your history for no good reason.

more options

Hi Edward27821, is the Incredimail application external like Thunderbird? Usually the app will follow the same system settings (e.g., Windows registry) so history really doesn't seem relevant at all. Can you provide a link to the support page with the instructions for a second opinion?