Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

sync custom server no URL field

  • 8 replies
  • 2 have this problem
  • 18 views
  • Paskiausią atsakymą parašė IT Fixt

more options

In "Set up Sync" Window, "Create a new account" then server: "Select a custom server" -> No field displayed to input server URL. It may be relevant that I get an "unable to read from file" message from FF at startup time.

Chosen solution

This problem solved - (a) I was being stupid - I misread something & expected a separate field to appear for the custom, server URL. That's not what happens - the selection field changes to a text box, as iamjayakumars said - apologies for that :} (b) The theme I use made the text in the field black... which on a black background is not too visible!

However, I now have the problem that FF is saying "please enter a valid server URL". I have tried it both with & without http://. It looks like this: http://mzs.itfixt.com:5000 Which can't be reached normally yet as it's not set up in DNS - I do it by editing the "hosts" file on my machine.

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (8)

more options

When you click the "custom server" it automatically changed to textbox.


Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

No, it didn't change to anything - in any case, the textbox is supposed to appear as well, not instead of. The Terms of Service elements disappeared, though. That's the problem.

I well understand the consequences of cookie & cache problems, as well as corrupt FF profiles - sorry, I should have made it clear that I'd tried all the normal methods for resolving the problem.

I was wondering if this is a beta version issue?

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

Chosen Solution

This problem solved - (a) I was being stupid - I misread something & expected a separate field to appear for the custom, server URL. That's not what happens - the selection field changes to a text box, as iamjayakumars said - apologies for that :} (b) The theme I use made the text in the field black... which on a black background is not too visible!

However, I now have the problem that FF is saying "please enter a valid server URL". I have tried it both with & without http://. It looks like this: http://mzs.itfixt.com:5000 Which can't be reached normally yet as it's not set up in DNS - I do it by editing the "hosts" file on my machine.

more options

OK, the log on the server is showing access from, I presume, FF, looking for a folder called "user". That doesn't exist in the sync server folder, so that explains the error message - FF validates the existence of the server during this setup phase.

Right, so it's looking for user.py. I presume there is something wrong with the way I have the Apache VS set up, so I'll go away & look at that again...

That error message isn't entirely helpful. FF must know it got a 404, so it could say that the server was either the wrong one or is misconfigured :)

Modified by IT Fixt

more options
more options

I have WSGI set up and followed the how-to, but one thing I didn't find clear: if I have built the server in the default folder name of "server-full", where do I point the document-root? What I want to do is copy the required files to the virtual server's root folder but I can't find anything which tells me which files are required for runtime, as opposed to build. Does that make sense?

AFAICS, FF is looking for the user.py file but the only instances of that are buried in the "deps" and "local" subfolders of "server-full".