Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get rid of the three new buttons in the top right of the browser window?

  • 6 replies
  • 2 have this problem
  • 5 views
  • Paskiausią atsakymą parašė cor-el

more options

I'm on the beta update channel (just installed the latest update to 21.0 this morning) and in the last update or two there's been 3 buttons on the top right of the window. I know the 2 on the left and center are to minimize and shrink the window and based on the icon I'm guessing the 3rd will exit or close. These 3 icons are taking up a full line dropping down everything else and I want to get rid of them to move everything back to the top. I can still move around and change everything else but these 3 seem to be permanent. Is there any way to move them or even better just delete them completely? They're very annoying!!!

All Replies (6)

more options

Hopefully it will attach this. Here are the 3 on the top in the upper right corner that I'm taking about. They're the only 3 things on this line and they push everything down a full line to be there and I haven't found a way to get rid of them.

more options

Does that happen when you are using the default Firefox theme?

more options

Maybe it is a theme compatibility issue? I've tried it with all of my themes and they all have done this but setting the default theme it's not there. HHhhhhmmmm... I'm not a fan of the default theme so I guess I'll have to decide if it annoys me enough to use it or if I'll just live with it and keep my themes. At least it's a minor issue and nothing major!!

more options

You aren't showing the full screen in the screenshot.

Is the bar on top the regular Firefox menu bar as maintained by your Mac OS and to you get this extra bar below that bar?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

Tabs on the bottom, hmmm, maybe that's not supported as well as it used to be?

more options

Such window control buttons can be shown on the Navigation Toolbar if Firefox is in full screen mode.
There may be a detection issue on Mac with the theme where toolbars may behave differently and the menu bar can't be styled or otherwise modified.