Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

External Links Always Open in A New Non-Private Window

  • 7 replies
  • 6 have this problem
  • 540 views
  • Paskiausią atsakymą parašė Yaron

more options

I've filed the following bug. https://bugzilla.mozilla.org/show_bug.cgi?id=856839

If you have a solution, please let me know.

Thanks.

Modified by Yaron

Chosen solution

You can check this bug report (fixed Firefox 21):

  • bug 829180 - Externally opened urls may open in private browsing windows

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (7)

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

more options

It happens in Safe Mode as well. Don't you have the same problem in Fx 20?

Thank you.

more options

Chosen Solution

You can check this bug report (fixed Firefox 21):

  • bug 829180 - Externally opened urls may open in private browsing windows

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

more options

Thanks a lot. I Appreciate it.

more options

https://bugzilla.mozilla.org/show_bug.cgi?id=856839

Josh Matthews [:jdm] 2013-04-01 21:31:31 PDT

Yes, this is an intentional design choice from bug 829180.

more options

Try to create a copy of the Firefox desktop shortcut and add the -private-window switch to the command line (target) of that copy and see if dragging the link on that icon works.

more options

Thanks again. Copy and paste would be easier. :)

I don't understand why they can't add a setting allowing the user to choose in which mode to open external links.