Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since installing Windows 8 on my laptop I cannot directly use the number keys on the keyboard (not the keypad), nor can I use the !@#$%^&*()_+. Please help

  • 3 replies
  • 8 have this problem
  • 2099 views
  • Paskiausią atsakymą parašė cor-el

more options

This problem only happens when I use Firefox or the IE browser. It only happens in the browser, but not in any other programs. When I need to use any numbers I can use the number pad, but not the keyboard number keys. The special characters such as !@#$%^&*()_ also will not work. When I try to use them the screen shows the last letter I typed for example my email address when I type it directly looks like this: peteralffcomcast.net the second "f" should be the "@" symbol but it doesn't work from the keyboard, I have to type it in notepad then copy and past it. This only occurred after installing Windows 8 pro on my laptop.

All Replies (3)

more options

I can think of two possibilities.
One is that the keyboard layout has been changed by accident (Windows remembers this layout for each application).
The other is that you have pressed some key combination to make those keys work differently (function keys?) and you may need to check that in the setup of that notepad.

more options

i have this problem too. only with IE10 and Firefox 17 or 18.

lang: eng L shift 2 goes to @ shift ' goes to "

lang gr with alt-L shift L shift 2 goes to " L shift ' goes to @

BUT if you press L shift for 2 times the problem disappears

"""@@@@@@

Its very annoying

more options

It is possible that you have switched the keyboard layout by accident.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that Firefox uses for some menu items
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)
  • Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence