X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Occasionally, Firefox will only load pages if I move my mouse around or hit a key on the keyboard constantly.

Paskelbta

I'm a web developer, and I love using Firefox for my initial testing. However, lately - since upgrading to Firefox 4 - I've been having an odd problem. I am currently running the latest version, Firefox 4.01, both at home on my powerhouse of a machine, and at work on a less-than-impressive machine.

What happens is, Firefox will be working fine with no problems. Then suddenly, I will try going to a webpage such as google.com and I will notice that Firefox freezes. The little circle in the tab that lets you know the page is loading will freeze, and the entire page will stop loading no matter where it's at. For example, if a page is half loaded, it will sit there half loaded UNTIL I start moving my mouse. It's not just the mouse though - I can also hit keys on the keyboard over and over (such as up down up down) and the page will load when I'm either pressing keys or moving the mouse. As soon as I stop moving the mouse or pressing keys the page will stop loading again.

Once I encounter this error - it does not go away until I restart Firefox - but upon restarting, the problem goes away (at least until it decides to popup again making me restart again).

Most recently, this happened this morning while I was working. I decided to restart in safe mode with no add ons at all. Not more than a few hours later, the problem returned even while running Firefox in safe mode!

FYI my boss is running Firefox 4.01 and he has not encountered this problem before. The ONLY difference between his copy of FF 4 and my copy of FF 4 is I'm using the "Sync" functionality so that my home computer and work computer can share bookmarks. Perhaps the issue is with the Sync operation?

I'm a web developer, and I love using Firefox for my initial testing. However, lately - since upgrading to Firefox 4 - I've been having an odd problem. I am currently running the latest version, Firefox 4.01, both at home on my powerhouse of a machine, and at work on a less-than-impressive machine. What happens is, Firefox will be working fine with no problems. Then suddenly, I will try going to a webpage such as google.com and I will notice that Firefox freezes. The little circle in the tab that lets you know the page is loading will freeze, and the entire page will stop loading no matter where it's at. For example, if a page is half loaded, it will sit there half loaded UNTIL I start moving my mouse. It's not just the mouse though - I can also hit keys on the keyboard over and over (such as up down up down) and the page will load when I'm either pressing keys or moving the mouse. As soon as I stop moving the mouse or pressing keys the page will stop loading again. Once I encounter this error - it does not go away until I restart Firefox - but upon restarting, the problem goes away (at least until it decides to popup again making me restart again). Most recently, this happened this morning while I was working. I decided to restart in safe mode with no add ons at all. Not more than a few hours later, the problem returned even while running Firefox in safe mode! FYI my boss is running Firefox 4.01 and he has not encountered this problem before. The ONLY difference between his copy of FF 4 and my copy of FF 4 is I'm using the "Sync" functionality so that my home computer and work computer can share bookmarks. Perhaps the issue is with the Sync operation?

Papildomi duomenys apie sistemą

Tai nutiko

keletą kartų per savaitę

Tai prasidėjo, kai...

I installed Firefox 4

Įdiegti papildiniai

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • Shockwave Flash 10.1 d50
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
Sprendimų: 17571 Atsakymų: 158915

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 you can use one of these to start in Troubleshoot Firefox issues using Safe Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)
Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). * Don't make any changes on the Safe mode start window. * https://support.mozilla.com/kb/Safe+Mode * [[Troubleshooting extensions and themes]] If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears. * Use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions. * Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") ---- In Firefox 4 you can use one of these to start in <u>[[Safe mode]]</u>: * Help > Restart with Add-ons Disabled * Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)

Klausimą uždavęs asmuo

cor-el,

I appreciate your input. If you re-read my original post, I disabled all add-ons by going into Safe Mode and I still had the problem. However, even in Safe Mode I did still have a theme that was being used. So, per your suggestion, this morning I am running in Safe Mode with the default Firefox 4.01 theme.

I will let you know if the problem persists either later today or within a couple of days.

cor-el, I appreciate your input. If you re-read my original post, I disabled all add-ons by going into Safe Mode and I still had the problem. However, even in Safe Mode I did still have a theme that was being used. So, per your suggestion, this morning I am running in Safe Mode with the default Firefox 4.01 theme. I will let you know if the problem persists either later today or within a couple of days.
aadnetgrrretw Sprendimų: 0 Atsakymų: 1

I have been having this problem. I thought it might be flash or a plugin, but it's not. I have an NVIDIA 9600 GT, driver version 8.17.12.6724, with the same version of Firefox. When I disabled hardware acceleration, the problem went away. So jneal, try disabling hardware acceleration, and if that works, then please tell us what card/driver you have. I suspect it might be a strain of NVIDIA drivers.

EDIT: never mind, I still seem to have the problem, but it is no longer a consistent problem. Strange. For the record, I have Flash 10.3 RC, if that helps anyone.

EDIT 2: it seems that disabling sync, as jneal suggested, has improved the situation. So both hardware acceleration and sync seem to be culprits.

I have been having this problem. I thought it might be flash or a plugin, but it's not. I have an NVIDIA 9600 GT, driver version 8.17.12.6724, with the same version of Firefox. When I disabled hardware acceleration, the problem went away. So jneal, try disabling hardware acceleration, and if that works, then please tell us what card/driver you have. I suspect it might be a strain of NVIDIA drivers. EDIT: never mind, I still seem to have the problem, but it is no longer a consistent problem. Strange. For the record, I have Flash 10.3 RC, if that helps anyone. EDIT 2: it seems that disabling sync, as jneal suggested, has improved the situation. So both hardware acceleration and sync seem to be culprits.

Modified by aadnetgrrretw

travis8787 Sprendimų: 0 Atsakymų: 1

update your graphics driver. thats what i did and it works fine now

update your graphics driver. thats what i did and it works fine now
sydhilton Sprendimų: 0 Atsakymų: 1

Reverted to 3.6 and problem went away

Reverted to 3.6 and problem went away

Klausimą uždavęs asmuo

I have not seen the problem since disabling my theme - so I believe that may be the culprit.

I have not seen the problem since disabling my theme - so I believe that may be the culprit.

Klausimą uždavęs asmuo

Using the most up-to-date graphics driver btw. And it happens on both my PC's.

Yesterday, this happened again. I restarted in safe mode and the problem immediately ceased, so it didn't bother me. However, the issue is, I no longer have a theme - so disabling my theme cut down on the # of times it happens tremendously, but even then it still happens. And it's happened in safe mode before - so I'm thinking more and more this is a bug in FF code

Using the most up-to-date graphics driver btw. And it happens on both my PC's. Yesterday, this happened again. I restarted in safe mode and the problem immediately ceased, so it didn't bother me. However, the issue is, I no longer have a theme - so disabling my theme cut down on the # of times it happens tremendously, but even then it still happens. And it's happened in safe mode before - so I'm thinking more and more this is a bug in FF code
Cheekies77 Sprendimų: 0 Atsakymų: 1

How do you revert back please? Every since I downloaded the 4.0 I have been having so much problems with it being slow, doesn't save my tabs, lagging, and the page not loading unless I keep hitting the mouse...very frustrating! It was much better with the old version. Thanks!

How do you revert back please? Every since I downloaded the 4.0 I have been having so much problems with it being slow, doesn't save my tabs, lagging, and the page not loading unless I keep hitting the mouse...very frustrating! It was much better with the old version. Thanks!
sellsworth001 Sprendimų: 0 Atsakymų: 1

Naudingas atsakymas

I have Add-ons for a reason. I don't want to disable my Add-ons. As a developer, most are valuable and I have come to rely on them. It is obviously not just one Add-on, so Mozilla needs figure out why this is happening and fix it. It is extremely annoying.

I have Add-ons for a reason. I don't want to disable my Add-ons. As a developer, most are valuable and I have come to rely on them. It is obviously not just one Add-on, so Mozilla needs figure out why this is happening and fix it. It is extremely annoying.
hypercleats Sprendimų: 0 Atsakymų: 2

Naudingas atsakymas

Running Firefox with addons disabled is no solution. The addons are the only reason I use Firefox! Please fix this before Google completely takes over my desktop!

Running Firefox with addons disabled is no solution. The addons are the only reason I use Firefox! Please fix this before Google completely takes over my desktop!
ankur27 Sprendimų: 0 Atsakymų: 1

same problem, cant help my self...most of the time my transaction fails just because of this problem and few times i have suffered a heavy loss of money... get my money back or get a solution of this silly problem. Coman guys , if u people can develop this browser , why cant you eliminate this problem....

same problem, cant help my self...most of the time my transaction fails just because of this problem and few times i have suffered a heavy loss of money... get my money back or get a solution of this silly problem. Coman guys , if u people can develop this browser , why cant you eliminate this problem....
Rimas Kudelis
  • Locale Leader
Sprendimų: 3 Atsakymų: 28
This is supposedly fixed in upcoming Firefox 8, see https://bugzilla.mozilla.org/show_bug.cgi?id=627084. Related SUMO issues: http://support.mozilla.com/lt/questions/743870 and http://support.mozilla.com/lt/questions/752301.