Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I make firefox remember passwords on ALL sites?

  • 13 replies
  • 403 have this problem
  • Paskiausią atsakymą parašė mykmelez

more options

Firefox has a feature to remember my passwords, which is very useful. However, some sites mess with this so they won't save my passwords. In some cases these sites turn "autocomplete" off for the password field in their html; in other cases they appear to use some kind of javascript magic to stop me from saving my passwords.

First of all, why should websites try to stop me from saving my password? Do they really think its more secure if people have to write their passwords on stickynotes on their monitor to remember them--or worse, use the same password on all sites? I what way is it conceivably more secure? In any case it's MY business how I manage my passwords--not theirs!

I have had some success in battling evil sites that try to stop my from saving my passwords by editing the nsLoginManager.js file. But this is not convenient as I must keep doing this every time firefox gets upgraded, and it doesn't work for some sites like American Express which I think use some sort of javascript to stop me from doing what I want.

So my question is, how can I effectively make firefox remember ALL the passwords I want, when _I_ want to--and NOT obey evil websites that just want to practice CYA while actually making me LESS secure?

All Replies (13)

more options

Firefox 4 may be doing a better job once bug 518516 gets fixed.
You can also try form fill mangers like Autofill Forms:

See Bug 518516 - Make login manager work with JS generated forms (after pageload)

(please do not comment in bug reports)

more options

You can use the Remember Password bookmarklet:
Has worked for me when I have needed it to save a password on a web site that used autocomplete=off. As far as the Bug that cor-el linked, I can't remember ever running across a website that did it like that.

Or, you can use the Saved Password Editor extension, which includes a means of manually adding Username/Passwords to Firefox.

more options

I’ve re-compiled the ‘omni.jar’ with a modified ‘nsLoginManager.js’ file and now it works for me. If you want I can send you the file, so you will be able to replace it with the original one.

more options

It seems every time I update versions, I lose more passwords. I went from 3.6.15 to 4, then back to 3.6.15, then I just updated to 3.6.16. V4 was freezing in the search bar so I reverted to the earlier version, which I previously reverted to an earlier version because of a bug with Ad Block Plus (that was later fixed), I do not like adding add-ons or playing with script and I certainly do not want a master password; I would prefer a more stable browser. Passwords are not being saved on sites where there is no strict security, like a newspaper or something.

I have been running FF for a very long time. Bookmarklets does not seem like a workable solution - and since more and more people complain every week, my other question would be, Firefox, are you reading these posts?

Alon, if you get very positive responses from your solution, may I get more detail? I am technical enough to follow instructions, but I do not understand yours. Thank you.

more options

You can find more information in the following post -

more options

on firefox5 no nsLoginManager.js in omni.jar , none of yours methods works !

Help !!!!

more options

There does no appear to be fix for this in Version 5.01 because there are no applicable java script files to edit. Thus, it appears to be a systemic bug that only the Mozilla team can address.

more options

This isn't really a website problem, it's how Mozilla have implemented the 'autocomplete' attribute. As a website developer, this attribute promises a good way to prevent different users of the same computer from viewing what has previously been entered in a form by clicking in or starting typing a word in a field. This is autocomplete - it is not and should not be related to whether or not a password manager stores passwords.

Therefore the most sensible and user-friendly solution is for Firefox to only disable autocomplete on fields with autocomplete set - ie not show previously typed values - and it should always offer to save your password.

This way leaves the user in control, and really being in control must be one of the biggest reasons why people use an independent browser such as Firefox.

more options


Mozilla is following W3C standards where websites declare "autocomplate =off" by not saving the login data - username and password. The standard is to not save that data - period.

Over a year ago in this thread, I posted a way to allow the user to override autocomplete = off, but most users aren't familiar with bookmarklets and how they can put the user more in control of the web.

Multiple users of a PC shouldn't even have access to any other user's personal information like passwords. The first line of security is separate Logon User Accounts for each user - each user has their own preferences, settings, and saved data for all the programs that they use.

If you think Mozilla is wrong with the way password autocomplete is handled in Firefox, file a Bug report with a proposal about how you think it should work. But search Bugzilla to make sure a similar Bug hasn't already been filed and marked as "wontfix".

more options

Mozilla will never ignore attributes like autocomplete=off or implement a build-in way to pass it or you get a big problem with deploying Firefox in large companies where thing like that are undesirable and will make it impossible to get Firefox accepted by their IT department.
Autocomplete can be useful not saving search data in specific search fields or other field where you do not want to keep data.

Login forms created by JavaScript however are a problem.
Among the sites that use that method are and (Hotmail).

more options

@the-edmeister I haven't read the W3C standards document, so can't comment authoritatively about the compliance or non-compliance aspects of this issue.

That said, it seems possible that the issue here is one of how the standards are interpreted. My interpretation would be that 'autocomplete' data is different to saved passwords managed by a password manager (such as the one built into Firefox).

I do in fact have the 'remember password' bookmarklet, and use it to remember logins for those sites that set autocomplete to off,

However, when I, or any other person using my computer for that matter, return to such a site, Firefox will actually autocomplete my login details. You only have to click in the username box and Firefox will show any saved username even though the box is marked 'autocomplete=off'. This doesn't seem to be a sensible interpretation of the autocomplete attribute to me.

If it's blind adherence to a literal interpretation of the standard, then OK, great, let's all saddle up and head on down into the valley of death like the noble Light Brigade.

Edit: I can't find a bug that seems to correspond to this particular issue on the FF bugzilla, which isn't entirely surprising as it's clear this is how Mozilla have done things on purpose. So I'm not sure whether or not to file a bug - I can't imagine they would listen!

Modified by lightstream

more options

I also had the same problem of FF not remembering passwords.when I upgraded from FF 3.6.28 to FF 12 on both my XP machines , I lost some passwords on some web sites but not others.

I tried doing a complete new download/save and then install trying to overwrite any of the side effects of the upgrade from ver 3.6 -> ver 12 and it still didn't work.

I fixed the problem by downloading the extension Saved Password Editor 2.6.2 so that I could directly edit or create new usernames and passwords for any web site.

Installing this extension for some reason enabled the prompting to save new usernames and passwords on new web sites.

I think that what has possibly happened is that the FF password files  may have become corrupted during the upgrade and using the Saved Password Editor may have created a newer password file version of signons.sqlite.

Another thing is that I have read that if there are password files signons2.text , signons3.txt and signons.sqlite then they should be deleted and then re-enter your passwords again.

These password files are located in

XP C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Profiles\default\ez8jzbjw.slt

( signons2.text , signons3.txt , signons.sqlite )

Win 7 C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Profiles\ip9ve4f9.default

( signons.sqlite )

more options

The new RememberPass addon does this and is easier to use than either the bookmarklet or the Saved Password Editor addon. Just install it, and it'll set autocomplete=on for password fields automatically. And it works on both Firefox Desktop and Firefox for Android!