Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

links and new tabs

  • 6 replies
  • 1 has this problem
  • 1 view
  • Paskiausią atsakymą parašė sisterkate1950

more options

when i click on links, they do not open in new tabs without me having to right click for option. it used to. what changed? it was fine until today (3/14).

when i click on links, they do not open in new tabs without me having to right click for option. it used to. what changed? it was fine until today (3/14).

Chosen solution

it was actually a combination of suggestions that solved the problem. thank you all so much for your help!!

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (6)

more options

It depends on how the page is coded. If the site has set the links to open in a new window, Firefox normally opens them in a new tab instead. But if the links are set to open in the same tab, Firefox doesn't change that to open them in a new tab.

Search sites usually have an option in their settings/preferences to choose between the same tab and a new window/tab. For example, with Google: https://www.google.com/preferences

For other sites, you might need to use an add-on. As an example: https://addons.mozilla.org/firefox/addon/open-link-with-new-tab/ (you need to go into its options to choose your preferred behavior)

Any progress so far?

Helpful?

more options

although you are very kind in attempting to help, your answer does not satisfy. i had no problem with Firefox/ Mozilla opening in new tab when i clicked on the link, it only started today. i have tried several different links and still had the issue. i re-checked my settings and found that they are as before (open in new tab) but it still makes me right-click to open in new tab. thank you so much for trying to help. i really appreciate it.

Helpful?

more options

Is the problem on a specific page or site? Such as a search results page?

Helpful?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

The default option is to open links in a new tab. You could check the preference in about:config. The value should be 3. An extension may have changed it. browser.link.open_newwindow

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Helpful?

more options

Chosen Solution

it was actually a combination of suggestions that solved the problem. thank you all so much for your help!!

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.