Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mac Dock won't disappear when I put youtube video (or other things like google slides) in fullscreen

  • 3 replies
  • 0 have this problem
  • 17 views
  • Paskiausią atsakymą parašė zeroknight

more options

Hi, I am using the newest Mac Air 15" with M3 chip, with the latest version of firefox (123.0.1) I have found an issue where when I put YouTube videos in fullscreen mode, the dock will not disappear like it normally would. The only workaround I've found is to put firefox in actual fullscreen mode (which then makes the dock disappear entirely), but I would prefer not to do as I typically maximize my screen instead. I'm assuming this is a bug on firefox specifically as fullscreen mode for videos/other things works normally in Chrome and Safari (which I also maximize screen), with the dock disappearing as it should.

I don't know if anyone else has encountered this issue though (as everything works fine on my older Mac...) Hopefully this can be resolved soon? I hope this makes sense :")

Hi, I am using the newest Mac Air 15" with M3 chip, with the latest version of firefox (123.0.1) I have found an issue where when I put YouTube videos in fullscreen mode, the dock will not disappear like it normally would. The only workaround I've found is to put firefox in actual fullscreen mode (which then makes the dock disappear entirely), but I would prefer not to do as I typically maximize my screen instead. I'm assuming this is a bug on firefox specifically as fullscreen mode for videos/other things works normally in Chrome and Safari (which I also maximize screen), with the dock disappearing as it should. I don't know if anyone else has encountered this issue though (as everything works fine on my older Mac...) Hopefully this can be resolved soon? I hope this makes sense :")
Pridėtos ekrano nuotraukos

Chosen solution

Try to enter about:config in the address bar and set full-screen-api.macos-native-full-screen = true.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (3)

more options

Chosen Solution

Try to enter about:config in the address bar and set full-screen-api.macos-native-full-screen = true.

Helpful?

more options

TyDraniu said

Try to enter about:config in the address bar and set full-screen-api.macos-native-full-screen = true.

This worked! thank you!

Helpful?

more options

This will be default in version 124.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.