Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo Email Not Signing on Firefox

  • 3 replies
  • 0 have this problem
  • 205 views
  • Paskiausią atsakymą parašė TheBob3

more options

All of a sudden, Yahoo email is not signing on Firefox on Windows 11. It is working on other browsers on the same computer, and even on Firefox on the Mac computer that is running the Windows 11. I tried all possible solutions but to no avail.

1) Cleared all cached data and cookies 2) Refreshed FF 3) Completely uninstalled FF and deleted the profile folder and reinstalled a fresh copy 4) Disabled all add-ons and extensions. 5) Private window

I am stuck at " Uh-oh... We can’t sign you in right now. Please try again in a while" every time I try to sign in. I get (https://login.yahoo.com/account/challenge/fail) instead of (https://login.yahoo.com/account/challenge/password).

Any suggestions?

Thank you

All of a sudden, Yahoo email is not signing on Firefox on Windows 11. It is working on other browsers on the same computer, and even on Firefox on the Mac computer that is running the Windows 11. I tried all possible solutions but to no avail. 1) Cleared all cached data and cookies 2) Refreshed FF 3) Completely uninstalled FF and deleted the profile folder and reinstalled a fresh copy 4) Disabled all add-ons and extensions. 5) Private window I am stuck at " Uh-oh... We can’t sign you in right now. Please try again in a while" every time I try to sign in. I get (https://login.yahoo.com/account/challenge/fail) instead of (https://login.yahoo.com/account/challenge/password). Any suggestions? Thank you
Pridėtos ekrano nuotraukos

Chosen solution

What happens when you start from here? https://mail.yahoo.com/ It works for me. see screenshot

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (3)

more options

How do I open Yahoo Mail in Firefox? Open Yahoo! Mail in Mozilla Firefox and go to Options > Set Y! Mail as default webmail. Go to Options > Preferences > Applications. Under mailto Content Type, make sure Yahoo! Mail is selected

Regards, Will

more options

Chosen Solution

What happens when you start from here? https://mail.yahoo.com/ It works for me. see screenshot

more options

Somehow the issue disappeared on its own. There was probably a glitch somewhere but now everything works just fine. Thanks.