Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to have normal and private windows sharing the same taskbar item (Windows)

  • 5 replies
  • 3 have this problem
  • 6 views
  • Paskiausią atsakymą parašė Fedtsten

more options

Recent changes have made my private browsing windows create a separate item on my taskbar. Is there any currently existing method to revert this to allow them to share a single icon other than downgrading firefox?

Recent changes have made my private browsing windows create a separate item on my taskbar. Is there any currently existing method to revert this to allow them to share a single icon other than downgrading firefox?
Pridėtos ekrano nuotraukos

All Replies (5)

more options

AFAIK those are two different running process and can't be integrated. Unless you have a Addon that stacks them into one taskbar action.

more options

I understand that they're separate processes, but it seems strange that this did not happen before but it does now. I may end up just downgrading to avoid screen clutter.

more options

They are separate browsers process. It could be a change from previous firefox process or it was there but wasn't noticed. I don't recall standard browser and incognito being stacked unless this was something you saw in Chrome.

more options

I can only assume it is a change from previous versions as I have used firefox exclusively for the past 10 years and never encountered them being separate taskbar items before this morning after it updated.

more options

evc, you are quite correct. I know this for a fact, as I have always navigated between my open Firefox windows (both normal and incognito) by cycling through them using WIN + 1 (always opens or cycles through the first pinned app on your taskbar) for years.

You can revert this annoying behavior by changing a setting. See this thread for details: https://support.mozilla.org/en-US/questions/1393494#answer-1542568

Basically, in about:config, set browser.privateWindowSeparation.enabled = false.

Modified by Fedtsten