Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how can I add content type .docx to General->Applications so I can print in yahoo preview pane

  • 10 replies
  • 1 has this problem
  • 365 views
  • Paskiausią atsakymą parašė snuckols

more options

I want to be able to print my .docx files without saving them first. I went to General and Applications. .docx is not in the list, so I'm unable to select how it handles these files. How do I add .docx to the list of content types?

I want to be able to print my .docx files without saving them first. I went to General and Applications. .docx is not in the list, so I'm unable to select how it handles these files. How do I add .docx to the list of content types?

Chosen solution

I don't have Microsoft Word installed but I have an old version of the discontinued "Microsoft Word Viewer"Microsoft Word Starter that will open .docx files. (Edit) It's also possible to use Wordpad (C:\Program Files\Windows NT\Accessories\wordpad.exe) to open .docx files.

If you want to tell Firefox how to handle .docx files you will have to download a .docx file and then right-click the entry in the Downloads panel and select "Always Open Similar Files". This will open it in the default program your system uses to open .docx files and will add a new entry to the Applications section of Firefox settings. (I had to restart Firefox to see the new "Microsoft Word Document" entry that was added for .docx files). I used this site for testing: https://filesamples.com/formats/docx

See this article for more information, under the "Adding download actions" section: Manage file types and download actions in Firefox

Skaityti atsakymą kartu su kontekstu 👍 2

All Replies (10)

more options

It doesn't appear to be a browser issue. In yahoo preview I see the same behavior in Chrome when I hit the print button on a word doc. It prompts me to download the doc. see screenshots

Modified by jonzn4SUSE

Helpful?

more options

......

Modified by jonzn4SUSE

Helpful?

more options

Nope. It is definitely a browser problem. I had the same problem with pdf's. I went into General->Applications, selected PDF and then selected to ask. The problem is that there is NO doc or docx content type, therefore no way to tell the browser how to deal with it.

These issues seemed to have started after the last update was pushed.

Modified by shannon_k_shaffer

Helpful?

more options

Okay, let me go try an older version and see what happens. After giving it some thought, it would be difficult for me to replicate because I don't have Word installed. Maybe someone else will chime in.

Modified by jonzn4SUSE

Helpful?

more options

The browser is up to date. I noticed a couple of other folks have posted similar problems with other content types. It is really weird. Hopefully, someone will have a solution.

Helpful?

more options

Chosen Solution

I don't have Microsoft Word installed but I have an old version of the discontinued "Microsoft Word Viewer"Microsoft Word Starter that will open .docx files. (Edit) It's also possible to use Wordpad (C:\Program Files\Windows NT\Accessories\wordpad.exe) to open .docx files.

If you want to tell Firefox how to handle .docx files you will have to download a .docx file and then right-click the entry in the Downloads panel and select "Always Open Similar Files". This will open it in the default program your system uses to open .docx files and will add a new entry to the Applications section of Firefox settings. (I had to restart Firefox to see the new "Microsoft Word Document" entry that was added for .docx files). I used this site for testing: https://filesamples.com/formats/docx

See this article for more information, under the "Adding download actions" section: Manage file types and download actions in Firefox

Modified by AliceWyman

Helpful?

more options

Thank you so very much!! It solved the problem of adding to the Applications Content Type. I opened the file, then clicked on the down loads, selected and right clicked on the MS Doc file and looked at General->Applications Content Type and the docx was there and I set it to ask first!! Although it still will not let me print from within the mail preview pane. So I have a partial fix now. At least I can open it from the mail.

Thank You again.

Modified by shannon_k_shaffer

Helpful?

more options

I have a similar problem in Firefox 91.10.0esr, however, when I try to apply the chosen solution, a right-click after opening the downloaded docx file does not give me the option to "Always Open Similar Files". Is this a bug in this particular version? Maybe I'm missing a step. If someone could post some screen shots along with the instructions, that would be great.

Helpful?

more options

sharon_nuckols said

I have a similar problem in Firefox 91.10.0esr, however, when I try to apply the chosen solution, a right-click after opening the downloaded docx file does not give me the option to "Always Open Similar Files". Is this a bug in this particular version?

Hi Sharon, this solution is for Firefox 98 and higher, where the whole approach to downloading was changed. For Firefox 91, can you find Microsoft Word in your Applications list on the Settings/Preferences page? This is a newer screenshot, so I don't know whether yours has the little search box:

I should also mention that some sites do not use the official Content-Type for all of their files, and may use a generic description which Firefox fails to match up with your stored action list. In that case, you can open the file from the Downloads list. If it becomes a frequent irritation, I have an add-on that can help: https://addons.mozilla.org/firefox/addon/content-type-fixer/ (after installation, click the Zzzz button to wake it up)

Helpful?

more options

Thank you for clarifying. Word doesn't show up in the Applications list, unfortunately. I can search for it but that search doesn't hold in subsequent browser sessions. Opening from the downloads list doesn't work because Firefox is treating the file as if it is an xhtml file. As this is a work situation, I will see if I can get permission to try the add-on. Thanks again for the information.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.