Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default Amazon Search Thinks I'm in Canada

  • 3 replies
  • 1 has this problem
  • 54 views
  • Paskiausią atsakymą parašė -elison-

more options

I was using a VPN set to Canada a little ways back, and now Firefox seems to believe I'm forever in Canada. Any time I go to use the default Amazon search included with the browser now, it defaults to Amazon.ca rather than Amazon.com. I've tried going to Amazon.com directly and manually adding the search, but that just gives me an error message. I don't have anything set to Canada at all anymore. How do I get my Amazon search to go back to normal? Is there something on the back-end I can edit to fix it?

I was using a VPN set to Canada a little ways back, and now Firefox seems to believe I'm forever in Canada. Any time I go to use the default Amazon search included with the browser now, it defaults to Amazon.ca rather than Amazon.com. I've tried going to Amazon.com directly and manually adding the search, but that just gives me an error message. I don't have anything set to Canada at all anymore. How do I get my Amazon search to go back to normal? Is there something on the back-end I can edit to fix it?
Pridėtos ekrano nuotraukos

Chosen solution

Hello! You can try: Open a New Tab and type about:config> Search browser.search.region> Double-click> Type in your region(abbreviated)

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (3)

more options

Chosen Solution

Hello! You can try: Open a New Tab and type about:config> Search browser.search.region> Double-click> Type in your region(abbreviated)

more options

That fixed it! Thank you so much!

more options

You're Welcome! :)