Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to play video on numerous websites

  • 1 reply
  • 1 has this problem
  • 18 views
  • Paskiausią atsakymą parašė FredMcD

more options

When I try to play video embedded in many websites, I just get a spinning wheel, and no videos will play. I've cleared my cache, and followed numerous other tips that I found when searching on this problem, but nothing has helped thus far. Any additional advice would be much appreciated! Thanks!

When I try to play video embedded in many websites, I just get a spinning wheel, and no videos will play. I've cleared my cache, and followed numerous other tips that I found when searching on this problem, but nothing has helped thus far. Any additional advice would be much appreciated! Thanks!

Chosen solution

http://kb.mozillazine.org/Images_or_animations_do_not_load

https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox

https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems

https://support.mozilla.org/en-US/kb/warning-unresponsive-plugin


https://support.mozilla.org/en-US/questions/1359657#answer-1463359 and updated to 95.0. . . . I finally found where the plugin "Widevine Content Decryption Module provided by Google Inc." was not updating to the newest version of December 1, 2021. Ver #4.10.2391.0

cor-el; Make sure you have the latest Widevine version. You can toggle DRM off/on to see if that makes Firefox (re)load DRM components.

You can possibly check the XHR requests in the Browser Console if this doesn't work.

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (1)

more options

Chosen Solution

http://kb.mozillazine.org/Images_or_animations_do_not_load

https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox

https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems

https://support.mozilla.org/en-US/kb/warning-unresponsive-plugin


https://support.mozilla.org/en-US/questions/1359657#answer-1463359 and updated to 95.0. . . . I finally found where the plugin "Widevine Content Decryption Module provided by Google Inc." was not updating to the newest version of December 1, 2021. Ver #4.10.2391.0

cor-el; Make sure you have the latest Widevine version. You can toggle DRM off/on to see if that makes Firefox (re)load DRM components.

You can possibly check the XHR requests in the Browser Console if this doesn't work.