Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 94.01 for Mac disconnects from GMail, other Google apps

  • 3 replies
  • 2 have this problem
  • 25 views
  • Paskiausią atsakymą parašė FredMcD

more options

My Firefox browser (94.01) disconnects from GMail and all associated Google apps (Calendar, Doc, Sheets, etc) after a few minutes. Since everything at my work is on Google, I have to restart the browser. I have uninstalled all my Firefox extensions except for Ad Block Plus. I have cleared all cookies and the cache. The problem still remains.

I am using a Macbook Air with macOS Monterey.

Thanks!

My Firefox browser (94.01) disconnects from GMail and all associated Google apps (Calendar, Doc, Sheets, etc) after a few minutes. Since everything at my work is on Google, I have to restart the browser. I have uninstalled all my Firefox extensions except for Ad Block Plus. I have cleared all cookies and the cache. The problem still remains. I am using a Macbook Air with macOS Monterey. Thanks!

Chosen solution

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (3)

more options

Chosen Solution

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks for the prompt reply, Fred.

I followed these steps. Even though the browser still hangs up performing the TLS handshake with accounts.google.com, the issue eventually resolves itself.

Best, Marc

more options

Glad to help. Safe Surfing.