Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Javascript in Firefox 90 PDF form viewer

  • 5 replies
  • 1 has this problem
  • Paskiausią atsakymą parašė fuffberry

more options

As of Firefox 90, the PDF viewer within Firefox is reported to handle Javascript in PDFs. What must be done to disable JAVASCRIPT within the PDF viewer?

Chosen solution

Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs.enableScripting and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I'm not sure how to test that it worked. Maybe Adobe has a safe example on their website?

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (5)

more options

Chosen Solution

Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs.enableScripting and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I'm not sure how to test that it worked. Maybe Adobe has a safe example on their website?

Helpful?

more options

By the way, it was false up to Firefox 87 and flipped to true starting in Firefox 88.

Helpful?

more options

I only see that pref set to true in Nightly.


  • 1702796 - Update pdf.js to version 2.8.320
    • #13116 Enable scripting by default in the viewer (PR 13053 follow-up)

Modified by cor-el

Helpful?

more options

Helpful?

more options

Thanks for the info - It was Firefox 88 release notes where I saw the bit about JAVASCRIPT in PDFs. I wish I could change the title on this issue to say "Javascript in Firefox 88 PDF form viewer" - upgraded my test system to FF90 then upgraded 'production' to FF88. Usually my questions are associated with the test 'nightly' version. I overlooked it when nightly went to version 88.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.